Jump to content

Recommended Posts

I type out text using the Artistic Text or Text Frame tools, then double (or triple) click and proceed to highlight the text that I want to make adjustments to. The only problem is, I can't see what I've selected because the text doesn't become highlighted! I could still make edits, but it takes alot more time if I am moving quickly and don't put my cursor where I think it should be.

Any help?

Screenshot 2018-03-27 20.51.51.png

Affinity Designer 1.6.1, Mac 10.13.3

Share this post


Link to post
Share on other sites

Hard to say more unless you say what program or what operating system you are using but it works for me. Dragging to select, double clicking or triple clicking. Photo on Windows.

STEP.jpg.42de2a67de9d7849eabeeb26d301abfb.jpg


Windows PCs. Photo and Designer, latest non-beta versions.

Share this post


Link to post
Share on other sites
7 hours ago, toltec said:

Hard to say more unless you say what program or what operating system you are using but it works for me.

Affinity Designer 1.6.1, Mac 10.13.3

Updated thanks.

Share this post


Link to post
Share on other sites

I also use Affinity Designer 1.6.1 & macOS 10.13.3. I do not have any problems highlighting text. One reason you might is because you have installed some third party 'enhancement' software that affects text entry, copy & paste, the clipboard, or anything that might intercept user input before passing it on to an app. Though not common, it is possible for this kind of software to conflict with only one or a few apps, so even if no other app is affected you can't be 100% certain that it is not causing this issue with Affinity Designer.

 

Do you have anything like that installed on your Mac? If so, is it the latest version & known to be compatible with High Sierra?


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
3 minutes ago, R C-R said:

Do you have anything like that installed on your Mac? If so, is it the latest version & known to be compatible with High Sierra?

I actually do have something like that its called Flycut however I quit the application, restarted AD and the problem still persists :(

Share this post


Link to post
Share on other sites

You may also want to check if it is possibly affected by the used font style/type, try the same with some other common font and see if the problem then still persists too.


☛ Affinity Designer 1.7.1 ◆ Affinity Photo 1.7.1 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
32 minutes ago, modiophile said:

I actually do have something like that its called Flycut however I quit the application, restarted AD and the problem still persists :(

I am not familiar with Flycut so I am just guessing, but it is possible that quitting it leaves some daemon or background 'helper' running. Activity Monitor might show if that is true or not but I don't know what to look for so unfortunately you are on your own with that.

 

I also did a very brief web search which did not turn up much other than a user comment that the Mac App Store version has not been updated in a long time & might cause problems, but I do not know how reliable that info really is.

 

It is a long shot, but maybe just quitting the app & restarting your Mac might help, as long as it does not restart automatically when you log into your user account.

 

Sorry I cannot be of more help. :(


Affinity Photo 1.7.3, Affinity Designer 1.7.3, Affinity Publisher 1.7.3; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.3.155 & Affinity Designer 1.7.3.1 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.1.2

Share this post


Link to post
Share on other sites
On 4/3/2018 at 4:16 AM, solarDog said:

This seems to correspond with certain fonts. I was having the same issue with Gotham. Switched to another font and it worked.

What could be causing that to happen?

Screen Shot 2018-04-02 at 2.14.25 PM.png

Screen Shot 2018-04-02 at 2.14.40 PM.png

This is a really unusual bug. I'm having the same problem when using Gotham as a typeface. Any solutions?

Designer 1.6.5 on Mac OS 10.14.2

 

Share this post


Link to post
Share on other sites

I can select Gotham

753461624_ScreenShot2019-01-24at07_47_54.png.37c9ea459766e440b98880b424f2aee3.png


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - FeedbackInstagram & Flickr

Share this post


Link to post
Share on other sites

I am running into this exact same problem with the exact same font. I'm on the Mac. If I choose another font it works.

Share this post


Link to post
Share on other sites
On 4/4/2019 at 4:44 AM, Diego Merello said:
  1. MACOS 10.14 (18A391) MOJAVE
  2. AFFINITY DESIGNER 1.6.5
  3. SAME FONT, SAME PROBLEM.
  4. OTHER FONT, NO PROBLEM.

Just noticed this exact same problem


------------------------

Fernando Velarde

www.velarde.com

Share this post


Link to post
Share on other sites

same basic problem: can't see text selection highlight. But with this unusual twist:

If I zoom out, I can eventually see the selection. Thankfully the text is still legible. Font size has no effect, it is solely tied to the zoom scale.

Share this post


Link to post
Share on other sites

I have same problem. Text highlighting not working properly.

There are any shortcut that disable this function?

Thanks

Share this post


Link to post
Share on other sites

I think that the problem is when the text is out of Altboard!, if text is inside altboard highlighting is visible.
 

Cheers!

Share this post


Link to post
Share on other sites

There was a reported problem some time ago, with text that is outside an artboard. If you zoom in enough that no artboards are visible in the window, the text won't highlight when selected.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Definitely a weird behavior.

I had no problem highlighting text, and suddenly, I can't highlight any text in my file (opening a different tab, copy/paste text frame, I can select/highlight).

I kept clicking around in text, played a bit with some frames (making sure they were within bleed - they were), put the "Show bleed" off and back on… At some point it started working again, not sure which action solved it though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.