Jump to content
PifLyon

[Fixed] Keyboard shortcuts stop working in Affinity Designer 1.6.4 after a while.

Recommended Posts

Hi,

I updated to version 1.6.4.104 and for a reason I don't know how to reproduce, keyboard shortcuts (AD and windows ones) stop working after about a minute ONLY  in Designer (not windows).

 

1 - I quit and relaunched AD and the problem appears again about a minute later. I sometimes press the Windows key by mistake, if that helps.

2 - I reverted to AD 1.6.2.97 and there is no problem.

 

So I keep 1.6.2.97 (french) and will wait for further versions, hoping that this bug is known and will be solved. If someone knows more about it...

 

Cédric.

 

Windows 10 Home French 1709 / 16299.309, 16Go Ram, Core i5-6500, Nvidia GTX1060 driver 391.01,.

Share this post


Link to post
Share on other sites

Hey PifLyon,

 

Is this all shortcuts or just custom ones? If it is just custom ones, can you tell me what shortcut keys you are adding and to what? What keyboard are you using? Are you also using a French keyboard?

Share this post


Link to post
Share on other sites

Yes, all shortcuts stop working ONLY in designer (not in windows or other apps).

No, I have not any custom shortcut

Yes, french keyboard (Steelseries Apex 150 that works fine everywhere else including Designer 1.6.2.97)

 

Share this post


Link to post
Share on other sites

If you open the app and do not touch anything for say, 5 minutes, do the keyboard shortcuts work? I wonder if a combination of keys you're pressing might be breaking them in general in the app. We had an issue a while ago where pressing Alt Gr would completely break shortcuts. 

 

I take it you have no other apps on the computer that assist with shortcuts? What antivirus software are you running? 

 

If you go to %appdata%\Affinity\Designer\1.0\Workspaces\Vector can you see if the Shortcuts.xml file gets modified? Make a note of what time you run the app up and then let a minute pass and refresh the folder to see if the xml file has a different modified date. Something might be nuking that file. 

If you go to Preferences > Keyboard Shortcuts, is the list of shortcuts still populated when they stop working? Does resetting them fix the issue temporarily? 
 

Share this post


Link to post
Share on other sites

I am experiencing a similar (if not the same) issue with 1.6.4.104 where all hotkeys stop working.  Essentially, once it happens, hotkeys like "P" (pen) or "A" (node) no longer do anything, and neither do general hotkeys like CTRL+Z or CTRL+C/V.  Curiously, though, you can still type into textboxes (like changing a layer name or editing a stroke width), so it is still processing the keyboard, just not any of the hotkeys.

Since I have a project that I have to must get completed, I have temporarily rolled back to 1.6.2.97 as well.  Plus, 1.6.4 has crashed on me a couple times while 1.6.2 rarely, if ever, did.  Once I'm done with my current project, I will probably go back to 1.6.4 and see if I can reproduce the error.  I didn't get a chance to see if the hotkey file was getting "nuked" or modified, however, I will say that simply restarting Affinity Designer would fix the issue (until it happened again).  For me, though, it was never one minute into working - it was way more random than that.  Sometimes I could work for an hour, sometimes five minutes.

I feel like sometimes it would happen when I was modifying stroke properties from the drop-down on the toolbar (not the panel on the right) and then pressed ESC to dismiss the properties drop-down.  But honestly I'm not 100% sure.

Share this post


Link to post
Share on other sites

I assume you are both using a US locale with a US keyboard? I'm not sure what we've changed between 1.6.2 and 1.6.4 to make this break. 

The fact jslrn60 is unable to type into a text frame is odd but suggests this might be two issues and not one. 

If you go to Preferences > Keyboard Shortcuts, is there a list of available shortcuts or have they vanished? 

Share this post


Link to post
Share on other sites
On 3/19/2018 at 8:36 AM, PifLyon said:

Hi,

I updated to version 1.6.4.104 and for a reason I don't know how to reproduce, keyboard shortcuts (AD and windows ones) stop working after about a minute ONLY  in Designer (not windows).

 

1 - I quit and relaunched AD and the problem appears again about a minute later. I sometimes press the Windows key by mistake, if that helps.

2 - I reverted to AD 1.6.2.97 and there is no problem.

 

So I keep 1.6.2.97 (french) and will wait for further versions, hoping that this bug is known and will be solved. If someone knows more about it...

 

Cédric.

 

Windows 10 Home French 1709 / 16299.309, 16Go Ram, Core i5-6500, Nvidia GTX1060 driver 391.01,.

Go to Settings and reset shortcuts from there.
Check if you created personal ones and set them again using the "shortcut" section.
Should work !


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites
15 hours ago, Chris B said:

If you go to Preferences > Keyboard Shortcuts, is there a list of available shortcuts or have they vanished? 

There is a list of available shortcuts.

Share this post


Link to post
Share on other sites

Okay, now that I've finished up the project I was working on, I was able to reinstall 1.6.4.104.

I can reproduce the hotkeys issue (and a crash) 100% of the time.  I'm pretty sure this is the issue I was getting as I mentioned in my previous post, it always seemed like it happened after I pressed the ESC key.  And to answer the moderator's question, I am using a US locale, US keyboard.  Windows 10 Pro 64-bit, latest updates and drivers.

Steps to reproduce:

1) Start a new project.

2) Use the pen to create a new line.  Two points is all you need.

3) Click on the Stroke properties in the toolbar, and then click on the Pressure option.  I've attached a screenshot of what it should look like at this step.

If you press ESC without modifying the Pressure properties, Affinity Designer will crash.  If you modify the Pressure properties (eg, change the curve or add points) and then press ESC, Affinity Designer won't crash, but the hotkeys will stop working until you restart.

I did check the Preferences to make sure the hotkeys are still assigned and they are.

Also, I don't think this is the only sequence that reproduces it, but I'm just so used to using ESC to dismiss those little "sub" panels that I ran into it a lot after installing 1.6.4.

Hopefully this helps.

 

ad_crash.png

Share this post


Link to post
Share on other sites

Is there a way to get keyboard shortcuts working again without reinstalling?


Microsoft Windows 10 Home (Build 18363)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
16GB DDR4 (3100Mhz)
NVIDIA GeForce GTX 1060 6GB
Monitor 1: 4K @ 150%
Monitor 2: 1080p @ 100%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Share this post


Link to post
Share on other sites
51 minutes ago, debraspicher said:

Is there a way to get keyboard shortcuts working again without reinstalling?

At least one other user in this thread mentioned that restarting Designer resolves the issue, until it happens again. Does that work for you?


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.693 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.693 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.687 Beta.

Share this post


Link to post
Share on other sites
Just now, walt.farrell said:

At least one other user in this thread mentioned that restarting Designer resolves the issue, until it happens again. Does that work for you?

Unfortunately no, I restarted several times and just comes back. I'm using the beta now, and no problems there so far.


Microsoft Windows 10 Home (Build 18363)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
16GB DDR4 (3100Mhz)
NVIDIA GeForce GTX 1060 6GB
Monitor 1: 4K @ 150%
Monitor 2: 1080p @ 100%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Share this post


Link to post
Share on other sites
7 hours ago, debraspicher said:

Unfortunately no, I restarted several times and just comes back. I'm using the beta now, and no problems there so far.

A fix has gone in the beta that stops shortcuts being broken after certain dialog interactions/key presses. Hopefully, this will be the last we see if this issue! 

Share this post


Link to post
Share on other sites

 This issue just happened to me on the latest version. Is it a compatibility issue with Wacom drivers? I have a Wacom Intuos Pro L when it was on I could not use any shortcuts by default. No CTRL-Z, P for the pen tool wouldn't work, v for move tool. I turn off the Wacom Tablet and everything returns to normal. All my drivers are updated.

Share this post


Link to post
Share on other sites
On 9/30/2018 at 5:28 AM, Existencilist said:

 This issue just happened to me on the latest version. Is it a compatibility issue with Wacom drivers? I have a Wacom Intuos Pro L when it was on I could not use any shortcuts by default. No CTRL-Z, P for the pen tool wouldn't work, v for move tool. I turn off the Wacom Tablet and everything returns to normal. All my drivers are updated.

Hey Existencilist, can you remember what exactly you did/clicked? Or is the issue present as soon as the app opens? If you can remember what you did I can try and reproduce it. What driver are you using?

Share this post


Link to post
Share on other sites
On 10/1/2018 at 3:01 AM, Chris B said:

Hey Existencilist, can you remember what exactly you did/clicked? Or is the issue present as soon as the app opens? If you can remember what you did I can try and reproduce it. What driver are you using?

I turn on the tablet and as soon as it turns on and I begin to use the pen and touch ring the shortcut keys do not work. I disconnect it and restart Designer, everything is fine.

Driver version 6.3.31-4

Share this post


Link to post
Share on other sites
On 10/2/2018 at 3:41 PM, Existencilist said:

I turn on the tablet and as soon as it turns on and I begin to use the pen and touch ring the shortcut keys do not work. I disconnect it and restart Designer, everything is fine.

Driver version 6.3.31-4

And you're definitely not interacting with a certain part of the UI first? They break the moment your tablet turns on?

Share this post


Link to post
Share on other sites

The issue is still happening for me as well: Shortcuts work after a fresh start, but they stop working when I use  [AltGr]+[TAB] to switch to/from another application.

Version: 1.6.5.123 (Beta)

OS: WIndows 10 Pro

 

Edited by bnowack
wrong key reported (it's AltGraphic, not the Windows key that causes the bug)

Share this post


Link to post
Share on other sites

Does anyone still have this problem?  My keyboard shortcuts (undo, save, pen tool, etc) also seem to be disabled after I do an alt-tab into another program.

I'm using version 1.7.3.481 on Windows 10 Home 1903

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.