Jump to content
DSNet

Exception Error when opening FilterForge filter

Recommended Posts

I opened Serif Affinity Photo which has just added support for FilterForge in the latest update. I opened a 10Mb jpeg photo and then attempted to access FilterForge via the Filters menu. I immediately received this exception error (the following is the detailed log which was generated by FF. I've highlighted the line that was the main reason for the error). This may be a fault in FF but when I opened FF as a standalone and then opened the same file , it worked perfectly. 

 

Operating system:  x64 Edition (6.2 build 9200) 
Physical memory: 16301 MB
Number of processors: 4, available: 4
Processor info: Intel(R) Core(TM) i5-2500K CPU @ 3.30GHz, ~3317 MHz

Filter Forge x86 4.016.40486.28338 Release, July 05, 2016 15:14 [17/03/2018 07:19:52 GMT Standard Time]
Exception caught at thread 000037DC 'Application':
<class XFW::ArgumentError> The handle 155FD050 is not a valid window handle.

<unknown file>(0) : <unknown function>()+0 at 005C159A in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 008DBEF7 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 008DBEF7 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : NtGdiExtGetObjectW()+12 at 758C2EFC in J:\WINDOWS\System32\win32u.dll
<unknown file>(0) : <unknown function>()+0 at 005C0A51 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 008DA532 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 008DA576 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 005C144E in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
<unknown file>(0) : <unknown function>()+0 at 008DA532 in K:\Program Files (x86)\Filter Forge 4\Bin\Filter Forge x86.exe
CONTEXT_CONTROL: CS:EIP 0023:75A308F2, SS:ESP 002B:01D3D710, EBP 01D3D76C, FLAGS 00200212
CONTEXT_INTEGER: EAX 01D3D710, EBX 00000000, ECX 00000003, EDX 00000000, ESI 00B78584, EDI 01D3D7AC
CONTEXT_SEGMENTS: DS 002B, ES 002B, FS 0053, GS 002B

Affinity Photo FilterForge Error.JPG

Share this post


Link to post
Share on other sites

Hey DSNet,


Have you tried removing the plugin and adding it again? This is the error message we received back in August last year when it was first reported but it should have been fixed a while ago :S

Share this post


Link to post
Share on other sites
On 17.03.2018 at 10:54 AM, DSNet said:

<class XFW::ArgumentError> The handle 155FD050 is not a valid window handle.

This bug is connected with the FF's plugin mode. It means that FF can't work as a plugin with AP. The possible ways out:

 

1. Updating AP. In the newest version Filter Forge works fine as far as we know.

2. Reinstalling Filter Forge.

3. Installing Filter Forge as a plugin maually. (Please, try the previous two options first, if they fail, I'll give you full guide on how to install FF manually.)

Share this post


Link to post
Share on other sites

Have recently purchased Filter Forge 6. It runs fine in Photoshop CC, it is also listed as a plugin in Affinity Photo. It will open in AF and I can edit a photo and the filter is applied on screen within FF6. However, when I click on the apply button, the Filter Forge screen closes and just leaves me with my original photo in AF. All works fine up to that point. Has anyone any suggestions as to why it is not working properly ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×