Jump to content
Aristarxos

Copied vector pasted wrong

Recommended Posts

Hi again,

Just noticed something that i am not aware if already noticed. Apologies if posting again.

The first image (above) is a vector copied from a software designing chemical structures. The second image (below) is the how is getting pasted in Affinity Designer.

I should add that when exporting the structure as SVG using Illustrator, AD opens it normally without errors. Just in case this helps.

However, when copying the structure from Illustrator with command+C, the structure is not getting pasted correctly in AD.

Many thanks.

A.

 

 

Image 1.png

Image 2.png

Share this post


Link to post
Share on other sites

Hi Chris B.

 

Attached are the files requested.

The name of each file explains the actions I followed for each one.

 

1st: Structure correctly exported (EPS) from the specific software. Correct structure.

2nd: Exported as EPS, opened in AI and pasted in AD with command+V. Issues on size and stroke.

3rd: Exported file opened directly in AD. Mostly OK except the OH that look a bit funny.

4th: Copied the structure with command+C and pasted with command+V in AD. 

 

Thanks.

A.

Structure correct exported.eps

AD file opened in AI and pasted in AD.afdesign

Exported file opened directly in AD.afdesign

Structure pasted direcly in AD.afdesign

Share this post


Link to post
Share on other sites

I'm having the same issues (copy / pasting from Chemdraw into affinity designer).

I have noticed that if I import the structure into affinity by making "new from clipboard" file, the vectors are correct; however, when I try to directly copy / paste, it gets messed up like Aristarxos' files. Here's a test file from chemdraw that has the same issues, and a pdf showing what it should look life.

TEST.cdx

TEST.pdf

 

Here are the two affinity files.

1. directly copy / pasted from chemdraw

2. "new from clipboard"

TESTcopypaste.afdesign

TESTnewfromclipboard.afdesign

TEST.pdf

Share this post


Link to post
Share on other sites

Hi all,

I  just bought Affinity Publisher and tried to paste in a ChemDraw graphic.

I also tried drag from ChemDraw and drop into Affinity Publisher.

In both cases, only the bottom tenth of the image shows at the top of the graphics box.

The rest of the image box below the partial image is blank. 

The image box looks like the correct size but with the image displaced upward  by 90%.

I was hoping to use Affinity Publisher to layout a chem book, but ChemDraw must paste in properly for that.

I hope that in the two years since the first post and the year since the last post a fix has been worked out.

Thanks for any help the community might have.

Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.