Jump to content

Crashes when developing RAW files

Recommended Posts

New update crashes everytime I try to adjust clarity, shadows or highlight sliders in develop persona. These are raw files from Fujifilm x-t20 on iPad Pro 10.5 running current iOS and Affinity. File management also running extremely slow. The 2/28/2018 update has broken the app I think.

Share this post

Link to post
Share on other sites

Hey Blittle, welcome to the Affinity Forums. 


It might be worth doing a quick reinstall of the app. On a desktop we can do something called a 'ctrl runup' which resets the app back to default and clears a lot of old data. We can't do that on an iPad which is why I've advised you to reinstall the app as it does the same thing.

Failing that, could you send me one of your files? I've downloaded some sample files from the same camera from the net but it's working fine for me.

Cheers :) 

Share this post

Link to post
Share on other sites
On 3/16/2018 at 11:53 AM, Chris B said:

It might be worth doing a quick reinstall of the app. 

Hi Chris,

I have a similar issue. Working on a file with two layers, one is originally a .ARW (sony RAW file). Using the clarity on that layer freezes the app. I can't even force quit and have to wait till it quits on it's own. Any idea what it could be? Reinstalling the app didn't help.

EDIT: I have converted the ARW files to DNG, otherwise they wouldn't open on the iPad.

Share this post

Link to post
Share on other sites

I wanted to report the same problem. As of the last update to the iPad app, I can no longer open TIFF files to edit them. It doesn't matter if those files are 8bit or 16bit.

Here's my workflow:

  1. Edit a RAW file quickly in Pixelmator Photo beta.
  2. Save TIFF file to Dropbox.
  3. Open TIFF file from Affinity Photo.

At this point, the file usually would load into Development mode. After the last update, the Development persona opens and everything is black. I still see all the sliders, and for the heck of it, I tap the checkmark to develop the image I can't see.

Now Affinity Photo *always* crashes.

Once I reopen the app, I can see the image I just tried to load in the little preview, but when I tap to open it again loads into the all black Development persona and I can keep playing the crashing game ;)

  • To rule out sudden issues with the Pixelmator Photo beta (mind you, it did work just fine grabbing files from it before the last Affinity update), I created some TIFF files directly from Lightroom on the Mac. Same result.
  • To rule out a corrupted app bundle (due to the update), I reinstalled Affinity Photo on iPad. Same result, the crashes continue.

Current workaround for me: export to PSD instead of TIFF. Those files are opened just fine. I haven't noticed anything else being affected, I just can't work with TIFF files anymore.

Sorry, forgot to add the tech specs:

  • iPad Pro 9.7" (2017)
  • iOS 12.1.2 (16D5024a)

Share this post

Link to post
Share on other sites

Hello, I have a thread open with a topic similar to this 

To me it seems we are all reporting the same issue.

My observation is that the app freezes, but is internally still working on the adjustment, and unfreezes itself after waiting some minutes. In my case this semi-crash happened repetitively when adjusting clarity, and sometimes when adjusting shadows.

Share this post

Link to post
Share on other sites

Just to clarify @Blende21

In my case, the app does fully crash. It does not freeze (become unresponsive). The app quits itself and returns me to the Home Screen from where I have to launch it again. As a result of the crash, a crash report is saved to Settings → Privacy → Analytics etc.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.