Jump to content
Gear maker

Break Curve and Join Curve not working.

Recommended Posts

I've seen lots of topics on Breaking curves and Joining curves and I am still having trouble.

 

I have an elongated rounded corner rectangle.  I'm trying to turn it into an elongated C.  I did an Expand Stroke.  Then I selected a node on the outside curve, hit Break Curve.  Then selected a node on the inside curve and hit Break Curve.  I can now move a node so that they look to be separate, no path between the nodes.  But the fill still continues between the broken nodes.

 

 

 

Then I try to do a join and they will not join.  I used the snap to get one node from the outside curve to align right over the node from the inside curve, select them both by holding shift and drawing a box around the two nodes, hit join curves.  And sure enough they are still separate.

 

I suspect the join just isn't going to work seeing as the fill continues along that they aren't truly broken.  I would guess that I couldn't have fill if I had two truly open curves.

 

Has anyone any ideas?  Has anyone tried breaking a shape following an Expand Stroke?


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

Hi Gear maker,

Regarding the fill, select your object go to the Pen tool, check Use Fill (on the context toolbar), then remove the check again. It should make your fill disappear. 

 

Regarding the nodes, after breaking them (resulting in two objects), select each one of the objects individually and press Close Curve button in the context bar (Node Tool).

 

 

In Affinity Designer you can have fills for open paths.

Share this post


Link to post
Share on other sites

Fill for open paths, wow.  I don't see how the software could figure out where it would go.  It must remember where it was from.

 

I'll try what you suggest.  Because the two objects are from an Expand Stroke they are both in the same layer and when one is selected the other is automatically selected.  Or, do you mean select all nodes in both curves?  I didn't try selecting all nodes, just the two that overlap.

 

Thanks for the help MEB.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

MEB, when I press Close Curve I get my O back instead of a C.  I even turned the end nodes until they almost touched and they still jumped the long distance to where they were when I broke the curve.  I tried selecting the curves and I tried selecting all nodes in both curves.  No difference, still O's.

 

I then tried to snap the end nodes from both curves together.  Pressed Close Curve and it still completed the O just very misshapen. The inside curve tried to heal and the outside curve tried to heal.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

@J.L. Forrest Can you be a bit more specific?

Perhaps a screenshot or provide the file along with a description of what you are trying to achieve.

Then I'm sure we can help :)


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

It's 2020, I have had this problem since the last 2 updates. I select 2 lines with the shift key, move one node on top of the other, and nothing happens. Join curves is greyed out, so can"t select it.

Any suggestions?

 

3.png.a2bda337dc90cb32603b9104a9247a19.png

 

1.png

2.png

Share this post


Link to post
Share on other sites
On 11/17/2020 at 7:01 AM, SS Gilbert said:

It's 2020, I have had this problem since the last 2 updates. I select 2 lines with the shift key, move one node on top of the other, and nothing happens. Join curves is greyed out, so can"t select it.

What's happened is that your shape has been auto closed when you dropped the one ending node exactly on top of the other end node.  If you grab one of the nodes you will move both ends as they are no longer separate.  That's why the Join Curves is grayed out.  But for some reason your shot shows Break Curve grayed out which it shouldn't be.  Instead the Close Curve should be grayed out.  Check to see if this is really how it's shown.

On a closed curve when any node(s) is selected Break Curve should be usable.  But Join and Close should not.  But when an end node is selected on an open curve Break will be grayed and Join and Close will be usable.  I hope that helps.  As you can tell from my entries from 6 years ago I fought figuring out what was going on.  The auto close still bites me sometimes when I am just trying to have the 2 end nodes very close but not closed.  I have one application I draw frequently that has this case and I've found workarounds that aren't too difficult.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites
47 minutes ago, SS Gilbert said:

Thank you, Gear maker. Sometimes it auto closes, but most of the time it does not.

Yup, I always have to check.  Have fun.


iMac (27-inch, Late 2009) with macOS Sierra

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.