Jump to content
Moonie

The same file keeps opening up in Affinity Photo

Recommended Posts

Hi, not sure if this is a bug but I've been facing this particular problem lately.

 

For the past few sessions, whenever I try to edit a RAW with Affinity via Mac Photos, the same photo keeps loading, i.e., even though I open file A, or B, or C, or whatever, it's always file D that appears. Even when I used another Mac Photos file (I've divided my photos into Photos 2018, Photos 2017, etc), the same D appears. It's just like a never-ending nightmare loop. 

 

I can't really remember the exact details as to how or when the problem started appearing. I suspect it was when I was figuring out how to open and edit the RAW in .ARW format and not TIFF when I might have closed the file in question before completing my editing. 

 

The same problem happens even when I open a JPEG. Affinity will instead open at Develop Persona with the above mentioned File D. 

 

Really no idea what I can do. Would appreciate any help or advise. Thanks!

Share this post


Link to post
Share on other sites

First, see if this option is selected

 

 

reopen.jpg


Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites

I think I might have figured it out. 

 

I tried to delete and reinstall. Didn't work. 

 

I tried again to delete Affinity, then searched for any remaining files and folders. Found and deleted this "Apple Photos Document.afextensiondocument", then reinstalled Affinity. And somehow it worked. Now it's back to normal. Not quite sure why but it's good enough for me. :-D

Share this post


Link to post
Share on other sites

Hi MEB, yah actually I think I might have force quit the app. Most probably encountered some problem n it hung or something. Nonetheless I think it would be good if you guys could eventually look into replicating the problem to prevent it from happening. Not the most convenient to have to reinstall the app every time I force quit especially since I am running it on a rather old Mac. Other problem I have now is that the app seems to take up a lot of CPU on my 2012 iMac. I suspect the reason is because of my iMac's vintage. Hopefully no other problems anytime soon :-D Thanks.

Share this post


Link to post
Share on other sites

@MEB Hi! The same problem happened again. Only that this time I did not force quit the app. I completed editing Photo 'A' then I closed the app. When I opened to edit another photo the next day, the same Photo A appeared. Only managed to 'reset' after deleting the file "Apple Photos Document.afextensiondocument". I really think there is a bug. Looking forward to a permanent resolution.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×