Jump to content
Tschens

Wrong/No lens correction?

Recommended Posts

Hello,

Please check this strange disortion of my startrails pic I shot with my Olympus OMD E-M1. The upper one is the interpretation from Affinity Photo without applying any lens correction. The lower one shows how it should look like (screenshot from Irfan View). I could not find a way to correct the startrails to circular. However, obviously Affinity Photo tries to correct the lens disortion somehow since the traces from the airplanes are straight and not bended as they look in the original non-corrected pic. But this is definitely NOT what I want when I excplicitely deselect lens correction.

Help/comments appreciated.

Jens

Affinity_Photo.jpg

Share this post


Link to post
Share on other sites

Hi Tschens

 

That fish eye lens is on our lens correction list so it will automatically apply the correction. If you simply turn the lens correciton off in the develop assistant it will appear more as you expect

 

thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites
1 hour ago, Chris_K said:

Hi Tschens

 

That fish eye lens is on our lens correction list so it will automatically apply the correction. If you simply turn the lens correciton off in the develop assistant it will appear more as you expect

 

thanks

 

Yes, thats how it SHOULD work. But unfortunately,  it makes absolutley no difference wether I activate "lens correction" or not.

Share this post


Link to post
Share on other sites

Any news on that problem? Here is another example. Left: Irfan view. Richt: Affinity. The tree on the right side is totally blurred in Affinity Photo. I provide the original ORF file as well.

Unfortunately, I found now way to bypass this problem. A correction of this bug would be very much appreciated since currently  I cannot work on my 8 mm fisheye ORF files with Affinity Photo.

Affinity_Lens_Problem.jpg

PA140224.ORF

Share this post


Link to post
Share on other sites

After searching around for 10 minutes, I finally found out what you mean. I have to disable the lens correction in the assistant. I was always playing around with the check box on the right hand side (see screenshot) which did not help at all. BTW: The checkbox in the assistent window "Hinweis, sobald der Assisstent eine Aktion durchführt" [something like: Message, as soon as the assistent performs an action] does exactly nothing. No message. Never. This would have been helpful to solve my issue.

I think we have some potential for improvement in the GUI here :-)

Thx for your help!

Jens

What_the_heck.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.