Jump to content
cc7

AD 1.6.4.104 takes too much loading time.

Recommended Posts

ad1.png.f57ac99e8e554d4eab415d547011f142.png

I just uninstall Affinity Designer 1.6.1.93 and install the latest version 1.6.4.104
I found a problem when I startup program it takes too long time on loading fonts splash screen.
On 1.6.1.93 has no problem with this issue.

I have tested on laptop Asus A550V with ram 8 gb on Windows 10 Home version 1709 x64 bit.

 

Share this post


Link to post
Share on other sites

Now around 1,700+ fonts, Also when I can access to AD. app when I am choosing and scrolling to any fonts in character palette it's freeze for a while.

On 1.6.1.93 there are no problem with startup loading and not freeze like this.

* I have checked on Photoshop CC and Illustrator CC2014 there are no problem with this cases.

Share this post


Link to post
Share on other sites

Now I back to 1.6.1.93 I got the same problem when scroll for choosing fonts!! What'up !

Have I formatted windows 10 ?

Share this post


Link to post
Share on other sites
4 hours ago, MEB said:

Hi cc7,

Did you have the same number of fonts installed when you were using version 1.6.1.93 or did you install quite few new ones recently?

Hi, Yes, the same number of fonts installed.
I just tried to re-format and install clean windows 10 and AD 1.6.4.104 now I got same problems slow startup at loading fonts splash screen.

And when I double click for highlight the text and go to character palette then scroll for choosing fonts, it's freeze for a while.

Please fix and improve when scroll for choosing fonts, it is not smooth and get some freeze.

Share this post


Link to post
Share on other sites

I think maybe it's because of fonts preview in font listing in character palette when 1700+ fonts installed AD can not previews all fonts instantly and get freeze or crash.

Also too much loading time on startup because of 1700+ fonts installed.

Photoshop and Illustrator no problem with this issue.

Share this post


Link to post
Share on other sites

I have 1,500+ font installed, and there was a crash when hovering the mouse pointer over this font (forgot to report that to the Devs, sorry). Maybe it's not the number of fonts but a case like this.

Also, on my System, the startup time is around 28 secs., with 50 secs. more until the Usermode Font Driver Host and Designer/Photo stop using CPU up to 15%.

Best regards!


You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Share this post


Link to post
Share on other sites

By the way, I tried again and I don't have that crash anymore.

Best regards!


You'll never know what you can do until you get it up as high as you can go!   

AMD FX 8350 :: Radeon HD 7870 :: Windows 10 ::  http://mithferion.deviantart.com/

Oxygen Icons :: Free Quality Fonts :: Public Domain Pictures :: iOS 11 Design Resources :: iOS App Icon Template :: Hot to do High Quality Art :: Mesh Warp / Distort Tool Considerations

Share this post


Link to post
Share on other sites

I tried to count loading time on stratup same laptop machine

 

AD 1.6.4.104 = around 1.20 min. 

AD 1.6.5.109 beta = around 1.20 min. 

Photoshop CS6 = around 6.x sec.

Illustrator CS6 = around 9.x sec.

Inkscpae = around 5.x sec.

 

Windows 10 Fall Creator Update Home 64 bit

Ram 8 GB ddr4 / Nvidia GTX 950M

 

Please urgent fix this problem.

Share this post


Link to post
Share on other sites
On 10/03/2018 at 11:21 AM, cc7 said:

Also too much loading time on startup because of 1700+ fonts installed.

 

You need a font manager!

 

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

I've the same issue! 

 

Both with AP and AD. The start takes much longer with the current version of both programs than with the previous versions.

I installed an older version of Paint Shop Pro for testing purposes. PSP starts within seconds!  


System: AMD Ryzen 5 1600 - 16 GB DDR4 3000MHz - GTX 1060 6 GB | Windows 10 (1909)

Better translations with: https://www.deepl.com/translator

Share this post


Link to post
Share on other sites

How many fonts do you have installed?

If you have a lot, then you'll probably get the same answer as given earlier in this topic: You need to either uninstall a bunch of fonts, or install a font manager to hide the ones you don't immediately need. Both AP and AD enumerate all the installed fonts during startup, which takes a significant amount of time when you have a lot of fonts installed.

I don't know whether the Affinity team regards that as a bug to be fixed someday, or whether they consider it "working as designed" for now but plan to try to improve it later.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.3.641 and 1.8.4.650 Beta   / Affinity Designer 1.8.3.641 and 1.8.4.650 Beta  / Affinity Publisher 1.8.3.641 and 1.8.4.651 Beta.

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

If you have a lot, then you'll probably get the same answer as given earlier in this topic: You need to either uninstall a bunch of fonts, or install a font manager to hide the ones you don't immediately need.

 

Unfortunately, it isn't really an "either/or". Windows allows you to hide fonts, but from previous discussions it's clear that this isn't enough to affect the enumeration process. You need to uninstall them, not just hide them: a font manager makes the task relatively quick and painless.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
On 29.4.2018 at 4:39 PM, walt.farrell said:

How many fonts do you have installed?
...

I understand the solution to fix it! But i don't understand why Serif don't use the Font Cache like other Programs e.g. Photoshop, Corel PSP?

 


System: AMD Ryzen 5 1600 - 16 GB DDR4 3000MHz - GTX 1060 6 GB | Windows 10 (1909)

Better translations with: https://www.deepl.com/translator

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.