Jump to content

Unable to save Preference + Blacked out document view on Second Screen

Recommended Posts

Hi, love your product, and I think it works fine except for two specific problems I seem to be having:

1. The first is that I am unable to save my preferences in both Affinity Photo and Affinity Designer even with program restart or macbook restart. I can edit the values in preferences but and when closing the preferences pane it prompts me to restart the program but upon restarting Affinity all of the preferences have been reset to default.

2. Solving the preferences problem would likely solve my second problem, which is that when using Photo/Designer on a second screen (Duet Display Pro on iPad Pro) the document editor view is blank and only shows the cursor but no frame to work within. The launch popup and "open new document" modular view before entering a workspace render just fine. But once you have actually opened or started a new document the editor is blank. Bringing the screens back from the second display to the main monitor does not solve the issue, yet any document opened or started on the main monitor does work as expected.





* Note that in the screenshots attached the document editor view is white, but on Duet display itself when taking these screenshots it was full black.

Now, I have read in a different post on this forum that changing the render setting to "Metal" supposedly solves this issue for use with Duet / second screens, but since I can't actually save that setting, I can't test out whether it actually solves this rendering issue or not.

Any advice or steps I can try to take to solve either of these issues would be greatly appreciated, thanks!
PS. If it is purely Duet causing the second issue, then I can make my peace with it, but I would still like to be able to update my settings in Photo/Designer.

- Affinity Photo 1.6.7

- Affinity Designer 1.6.1
- Duet Pro

System specs:



iPad Details:
- Version 11.2.5 (15D60)
- iPad Pro 12.9"


(seems like High Sierra recognizes Duet on my iPad Pro as a second built in display)


Share this post

Link to post
Share on other sites

When regular uninstalling and re-installing didn't seem to fix it, I tried uninstalling and then going to my "Library" folder in Finder and deleted everything seriflabs or affinity related. After re-install, I could now actually edit my preferences and switch to rendering with 'Metal', this solved both my issues.

I'll leave the post and comment on the forum for anyone else having a similar problem.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now