Jump to content
TaigaAlive

Disable the magnifier while using the node tool?

Recommended Posts

I use the node tool to adjust vectors a lot. The last update made it so that a magnified circle pops up blocking the view of the line if I try to make smaller or slower adjustments. I think this is the long pressing with Apple Pencil mentioned in the 1.6.7 change list. I haven't been able to find a way to disable this. Is there a way, or a workaround I could use?

Share this post


Link to post
Share on other sites

Hello and thank you.

 

As far as I can tell this isn't triggered by pressure, only time and movement. It will still pop up even when using my finger. I have noticed that when using brush tools the colour picker only pops up if I'm not moving, which works perfectly for me. The magnifier with the node tool and a few others, however, pops up even if I am moving.

 

I have enabled canvas rotation in all tools so that it's easier to move the line out of the way if the magnifier pops up over it. This is still somewhat annoying, but definitely usable.

Share this post


Link to post
Share on other sites

It’s a useful feature when using a finger to modify curves, but with Apple Pencil it blocks the view and makes the task actually harder. Please consider adding an option of switching the magnifying glass off.

Share this post


Link to post
Share on other sites

Even using my finger the magnifying glass gets in the way. It really does need to be an option that can be turned off. I can zoom in if I need to see more.

Share this post


Link to post
Share on other sites
On 6/8/2019 at 11:27 PM, Mobileflea said:

Hi, also seems as though magnifier tool disables node tools function to select multiple nodes? Anyone else

No there’s a new method for node selection. You tap first with the pencil, then hold down two fingers, then draw with a lasso, then let go of your fingers, then let go of the pencil. Very frustrating and unintuitive.

Share this post


Link to post
Share on other sites
11 hours ago, DesignConor said:

No there’s a new method for node selection. You tap first with the pencil, then hold down two fingers, then draw with a lasso, then let go of your fingers, then let go of the pencil. Very frustrating and unintuitive.

+1

Share this post


Link to post
Share on other sites

it would appear that when using two fingers and the apple pencil, it randomly switches between lasso select and polygon select modes.  i really cant figure out what determines which of these two selection methods is invoked. very frustrating.

Share this post


Link to post
Share on other sites
3 hours ago, dangerweenie said:

it would appear that when using two fingers and the apple pencil, it randomly switches between lasso select and polygon select modes.  i really cant figure out what determines which of these two selection methods is invoked. very frustrating.

After holding down the two finger modifier, if your next action is interpreted as a tap, you get polygon selection. If your next action is interpreted as contact-and-dragging, you get lasso selection. Need to be sure your Pencil doesn't bounce or your finger isn't tentative.

I must admit I prefer the on-screen keys:

Preferences > Interface > On-screen modifier keys: On > Done.

  • Select the object first with the Move tool then change to the Node tool, or alternatively select the object by tapping it with the Node tool.
  • Click the little arrow to the right of the context-specific options at the bottom of the screen (I'm using a Mini, so possibly on larger screens this might not be necessary) - it reveals the Constrain and Ignore Snapping on-screen keys. When no nodes are selected, they have selection functions instead.
  • For Lasso selection, hold a finger on the Ignore Snapping key and then drag a lasso selection with the Apple Pencil or your finger.
  • Raise the Pencil or finger first (tends to be moderately intuitive as you've finished drawing your selection), then take your finger off the Ignore Snapping key.

Notes: The Constrain key allows multiple cumulative rectangle node selection areas. Once you have dragged your selection, the keys do what their labels suggest.

Share this post


Link to post
Share on other sites

Has there been any fix on this magnification when selecting nodes? For some reason it happens more for me in the new 1.7 version. Thanks in advance for any help. I don't know how necessary this is since we have almost infinite zoom. I agree that this is frustrating! Nice to know that other people are struggling with this. I hope a fix comes :)

Thanks so much!

Stephen:)

Share this post


Link to post
Share on other sites

@Adiarte

Welcome to the Serif Affinity forums :)

to all recent participants of this thread, if you are referring to the magnifier that appears using the apple pencil, the 1.7.1 patch released yesterday resolves this we believe.


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.