Mark Ingram

Affinity Photo Customer Beta - 1.6.3.100

47 posts in this topic

Click here to download the latest beta

 

Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, (issued if Affinity Photo was purchased from Affinity Store).

As this is a beta it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing, including the total loss of any documents. 

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed Surface Pro pen UI failures (installer now ships with .NET 4.7.1)

  • Fixed documents disappearing behind main window when clicking on tools

  • Fixed memory corruption with Soft Proof

  • Fixed Vector export print and print preview differing from on-screen

  • Fixed lens auto correction for camera variants that have different model names but the same mount identifier

  • Fixed sporadic crash in Tone Map

  • Fixed crash with multiple documents open when using pixel selections

  • Fixed performance of Healing Brush

  • Added more devices for auto lens correction (via lensfun update)

  • Fixed memory leak during tool draw

  • Fixed vector export so clipped-out transparencies will draw as transparent

  • Fixed PDF export of embedded uncommon fonts

  • Fixed OpenType MarkToLigature rendering incorrectly

  • Fixed OpenType Contextual Alternatives displaying incorrectly with Levandria font

  • Fixed crash in GlyphBrowser when fonts don't have a cmap table

  • Fixed Type1 fonts being incorrectly embedded in PDFs

  • Fixed failure to load some .afpalette files

  • Fixed alignment of some context bar items

  • Extended Develop Exposure range to +5/-5

  • Fixed custom Export Presets not being remembered correctly

  • Improved performance of Brush Editor dialog

  • Fixed panels to allow expansion anywhere on the header, not just on the expansion arrow

 

Known issues

  • Dragging export file path variables will close the popup

Burny, Max N, proshot69 and 9 others like this

Share this post


Link to post
Share on other sites
 

Extended Develop Exposure range to +5/-5

Very good news!

The first tests are very pleased! Keep it up!

 

Dave Quail likes this

Share this post


Link to post
Share on other sites

Hello everybody,
thanks for the new beta.
The installation went without problems.
After the start program, the welcome screen will appear as usual,
Unfortunately, no action can be performed, after a click on the welcome screen, the program closes.

A deinstallation and reinstallation was performed.

 

Log.txt


Affinity Photo (1.6.1.93, beta 1.6.3.99) Affinity Designer (1.6.1.93, beta 1.6.3.99) : Windows 10 Pro  ( version  1709)

 

Share this post


Link to post
Share on other sites
14 minutes ago, Gnobelix said:

Hello everybody,
thanks for the new beta.
The installation went without problems.
After the start program, the welcome screen will appear as usual,
Unfortunately, no action can be performed, after a click on the welcome screen, the program closes.

A deinstallation and reinstallation was performed.

 

Log.txt

 

This version includes a new .NET 4.7.1 installer, so it might be worth attempting an uninstall and reinstall of .NET 4.7.1 to see whether there is a problem there.

Share this post


Link to post
Share on other sites

My installation 1.6.3.100 is ok - no special updates of .NET performed before update process.


Win10 x64 1907, 16G RAM, Core i7 + Wacom Cintiq 12WX Interactive Pen Display
Win10 - Affinity Photo 1.6.2.97 + beta 1.6.3.98, Adobe Photosop CS6, Corel Draw X7, ArtCAM 2015 R2
iOS 11.2.1, iPad Pro 10.5, 64GB + Apple Pencil
iOS 11.2.1 - Procreate 4.0.8, Affinity Photo beta 1.6.7.74 RC1

Share this post


Link to post
Share on other sites

Hi Mark, great the lens correction with the Lumix FZ1000 works again.
Exposure + -5, top.
Thanks for the good work. My installation is ok.
Dieter

Mark Ingram likes this

Germany, Affinity WIN 1.6 , LR6, WIN7-64

Share this post


Link to post
Share on other sites

What about updating engine for previewing brushes? Instead of rounds it show octagons, smaller ones look coarse. I change hardness from 100% defaults (right picture) to the 99% (left picture). And appearance much nicer. So still further improvements here are welcome )))

2018-02-14-13.05.jpg


Win10 x64 1907, 16G RAM, Core i7 + Wacom Cintiq 12WX Interactive Pen Display
Win10 - Affinity Photo 1.6.2.97 + beta 1.6.3.98, Adobe Photosop CS6, Corel Draw X7, ArtCAM 2015 R2
iOS 11.2.1, iPad Pro 10.5, 64GB + Apple Pencil
iOS 11.2.1 - Procreate 4.0.8, Affinity Photo beta 1.6.7.74 RC1

Share this post


Link to post
Share on other sites

Perspective tool is working again

live-filter-perspective still crashes the program

 

_Hans

Share this post


Link to post
Share on other sites

Thanks again for you good work.

Installed without problem. Here, Live Perspective Filter works fine, no problem at all so far.

 

Share this post


Link to post
Share on other sites

Agree with AlainP...Live Perspective Filter not crashing anymore. Installation went well. Startup in my case still very quick. Well done!

Share this post


Link to post
Share on other sites

Installed perfectly and loads a couple of sec faster.

Thanks

 

 

ps No change in RAF loading  Affinity 42sec Darktable 3 sec?


Asus Laptop i5-3337u | 8gb | SSD | Win 10 Pro 64

Share this post


Link to post
Share on other sites

I seem to having a similar problem to Gnobelix.
Install went like every other beta installation (I've installed the vast majority of them)
Program opened and I was able to open a photo by dragging it onto the screen, but any further button presses result in a crash.
File/Open cannot be tried as a crash occurs when pressing File.

Attempted the .NET suggestion, but as .NET 4.7.1 is already installed, it cannot be uninstalled in order to attempt a reinstall.
Attempted to repair the install - no joy. 

Uninstalled and reinstalled - no joy.
Uninstalled again, downloaded again, installed again - no joy.
Numerous computer restarts (just for something to try) - no joy.

If anyone has experienced this and found a solution, I'd be grateful if they could post their findiings

 

Share this post


Link to post
Share on other sites
Quote

Extended Develop Exposure range to +5/-5

Thank GOD for this!!! YEAH!!! :)

Share this post


Link to post
Share on other sites

Apologies, my earlier remark on the Live Perspective Filter Layer was incorrect. It is in fact still causing AP to crash out.

Share this post


Link to post
Share on other sites

.NET 4.7.1 cannot be installed on Windows 8.0 hence this beta update fails

( You may have to update the system requirements page if this .NET 4.7.1 requirement is needed in the next released version )

Chris J likes this

Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites

The Tip from Mark did not help.
NET 4.7.1 cannot be installed on Windows 10,
the uninstalling NET 4.7.1 also fails.
I would be grateful for useful tips.


Affinity Photo (1.6.1.93, beta 1.6.3.99) Affinity Designer (1.6.1.93, beta 1.6.3.99) : Windows 10 Pro  ( version  1709)

 

Share this post


Link to post
Share on other sites
4 minutes ago, Gnobelix said:

The Tip from Mark did not help.
NET 4.7.1 cannot be installed on Windows 10,
the uninstalling NET 4.7.1 also fails.
I would be grateful for useful tips.

 

Which version of Windows 10 do you have? 10.0? 10 November update?

Share this post


Link to post
Share on other sites

I think the version is  includes the November update
Windows 10  Pro Version 1709, Build 16299.248


Affinity Photo (1.6.1.93, beta 1.6.3.99) Affinity Designer (1.6.1.93, beta 1.6.3.99) : Windows 10 Pro  ( version  1709)

 

Share this post


Link to post
Share on other sites
56 minutes ago, Dave Quail said:

Apologies, my earlier remark on the Live Perspective Filter Layer was incorrect. It is in fact still causing AP to crash out.

So do I... Live Perspective Filter worked the first time I started the Beta. The second time it also worked, but when I double clicked on it and tried to modifiy it, APh crashed suddenly, no error message. 

I restarted it and this time, as soon as I cliked on "Preserve Alpha" Aph closed. I retried again and after moving the right node the computer became sluggish and the fan was running faster. CPU usage went up to a little over 85% and then APh crashed. 

Now, I just started APh, loaded an image and clicked on Live Perspective Filter. I did not use it or touch anything else. I was just making sure the Check Box was titled "Preserve Alpha". I went back to my browser to finish this message and after a few seconds APh disppearead, no error message.

I restarted APh, opened an image and wait, CPU usage was 0-1%. Click on "Live Perspective Filter" and just watched the CPU usage, it went up to 98% (just for APh). As soon as I reopenned it and clicked on a node APh crashed.

Hoping this can help....

 

Share this post


Link to post
Share on other sites
3 minutes ago, Gnobelix said:

I think the version is  includes the November update
Windows 10  Pro Version 1709, Build 16299.248

 

According to here - https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements - The November update doesn't support 4.7.1, so we're going to look at fixing this.

 

Did you not get an error during the installation? We've just tried this on a clean Windows 10 VM, and there is an error during installation.

Share this post


Link to post
Share on other sites

no error message during installation


Affinity Photo (1.6.1.93, beta 1.6.3.99) Affinity Designer (1.6.1.93, beta 1.6.3.99) : Windows 10 Pro  ( version  1709)

 

Share this post


Link to post
Share on other sites
55 minutes ago, Gnobelix said:

I think the version is  includes the November update
Windows 10  Pro Version 1709, Build 16299.248

 

10 minutes ago, J a n said:

Windows 10 version 1709
Installation without problems.

 

1709 is the Fall Creator's Update, the latest version of Windows. Which comes with .NET 4.7.1 already installed.

Share this post


Link to post
Share on other sites

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.
msiexec_2018-02-14_20-55-18.png.1394e79088ec282da6bab478b21dc81f.png

Windows 10, version 1709

Share this post


Link to post
Share on other sites
1 minute ago, mesbahworld said:

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package.
msiexec_2018-02-14_20-55-18.png.1394e79088ec282da6bab478b21dc81f.png

Windows 10, version 1709

 

Have you tried downloading it again?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.