Jump to content

Recommended Posts

Hi All,

I am happy about recent upgrades to designer and photo and have installed the last round of updates. Since the last install, I have run into a few issues.

1. the selection and copy feature now requires me to select the item, then select the big arrow to copy. No issues. I can work with that. It may have been user error all along. I was always used to select-then copy - then paste and the image selected would copy. Now i have to take the extra steps of select  image area-select the big arrow- copy - then paste.

2. It appears to be issues with the selection tools: (code?)
When I go into effects and select the color overlay feature: or use the color select eyedropper I get the big circle that shows me the colors i am wanting to select. Hurray!  but then I cannot select  the colors. :(

Seems the mouse click NEVER completes the action...Well, I have to tell you I have  had a ton of fun with this new feature..!!!!

I get the big circle following my mouse all around the screen, other programs, even my browser. I can click links, close browser windows, ALL the while seeing the BIG BEAUTIFUL COLOR SELECTOR!  :)   It does get a bit difficult at times as the BIG CIRCLE covers everything and I have guestimate the actual button or link I am trying click or close.  I then have to go and kill the affinity process before I can use the program again. The program works fine if I don't want color changes!.. I am sort of in a quandary about that- I mean I really like colors... but it is really becoming a bit of a hassle with the big circle thing....and i even tried selecting the BIG arrow..it doesn't turn it off.  Any Help suggestions as to what is causing this latest issue?  Don't get me wrong-- I really like games and puzzles and stuff-  I just need to get some work done. :)

(BTW.. it is a hit and miss thing.. It will work for a while then suddenly,, wham bang! there it is!!! :()

 

Share this post


Link to post
Share on other sites

Hi snowite

 

1. I'm afraid you are going to have to expand on this as I;m no sure what you mean. Can you provide any screenshots demonstrating what your issue is here?

 

2. The loupe seems to be disappearing on mouse up for me here. What version of Windows are you using? Do you have any background apps that manage mouse clicks running? again are you able to provide any screenshots or video of what you are seeing here so I can look at what possibly causes this

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Hi Chris,

Thanks for the quick response.  The problem does come and go which is frustrating. I am using windows 10, Affinity Designer latest version of upgrade. As you can see in  the screen shot the big round selection circle the comes up when the eyedropper is selected. This morning so far, everything is working fine, however, at times when it chooses, if I select the eyedropper, i will get the big circle and no matter how many times I try to click INSIDE AD, it will not release on mouse click. 

If I have a browser window FF latest version open. The big circle remains on the screen and then I have to guesstimate where the links are and buttons to close windows. It will allow mouse clicks on EVERY other program except AD. With the big circle still appearing on screen I then have to open the task manager and try to select the right process to close. Not an easy task with a big circle covering everything :)

Once I use the task manager to close the AD program, I can re-open the program and may not have the issue for an hour, a day, or even a couple of days and then all of a sudden it's back again.  I am using the same tools daily when I have AD open: Firefox (latest version) usually 2 to 4 windows, media player (comes with win 10) which plays just one long file to drown out the dogs barking all day long- no playlists, Gmail, Shopify web browser page. Sometimes, rarely a VPN (VPN was not open yesterday) . and I have Comodo Internet and antivirus installed. Have had that for years and this was never an issue with AD. The only other thing open on the PC is maybe a file folder or two for dragging and dropping needed files.

I don't have any mouse stopping program or tweaking software installed on the machine. I do have Affinity Photo also, but I do not open at the same time nor was it open when the issues happen. I don't remember if I had opened it all yesterday when / before the issue took place.  I may have, but I honestly don't remember. I jump back and forth between FF, file folders and AD as I am working on opening an online pet shop.

This issue has happened more than once, and has happened a lot more in the last 2 months than previous months. I had a few crashing and freezing moments of AD and AP, over the last few months, but with software that tends to happen and you just restart the program. This now, is only happening with selection tools, I have noticed it tends to happen more if I am using FX and then using the selection tool. I have been importing brushes into AD that were designed for PS.  Brushes appear to work fine.  I have also been using vector files(from Freepik and Presenter Media) ,and just copy and paste and arranging from them into a set image.

Nothing I am doing is wild and crazy. I have made a few groups. some shapes. some brushes. Nothing hard or memory consuming. So I am sure it's not a memory issue. I now save after EVERY change because I never know when the big circle will re-appear. :(    I keep all software updated to the latest and greatest.

If you need any more info, please feel free to contact me.

Katrina (Snowite)

 

 

 

jjhj.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×