Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

Hello,

I have an image of a subject with a green screen behind him. To isolate the subject I used the "Select sampled color tool" and adjusted the tolerance until the selection is around the subject. The problem is when I remove the green screen the subject also loses opacity and becomes slightly transparent. How do I fix this ? 

And is there a better way to isolate the subject from the green screen ?

 

Thank you.

Link to comment
Share on other sites

Hello Aaela, and welcome to the Affinity forums.

 

The tool cannot always work 100% depending on the difference of contrast between the green screen and the subject. You should use that tool only as a way to start off, and then switch to something like the Selection Brush Tool. Losing part of a subject is normal behavior for chroma keying.

 

However, I did catch an issue, and it might be a bug. I used an example green screen image and once I deleted a selection, there was still green visible.

 

ScreenRecorderProject1.mp4

The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Link to comment
Share on other sites

Thank you for your reply. I saw the video, thank you for sharing it. But In my case the problem was the subject losing opacity. (The subject became somewhat transparent when I deleted in the chroma). This only happens when I use the "Select sampled color tool" if I do it with any other selection tool the subject's opacity is not reduced. So I suppose it has something to do with the tool selecting some range of color from the subject in addition to the green screen. Is there a way to avoid this or is this another bug ?

Link to comment
Share on other sites

59 minutes ago, aaela said:

So I suppose it has something to do with the tool selecting some range of color from the subject in addition to the green screen.

Yes. "green screen fails" are not the result of software bugs.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

1 hour ago, aaela said:

(The subject became somewhat transparent when I deleted in the chroma).

 

Just to confirm, do you mean you had no part of the subject in the selection? In my example, you will see I did not select the background entirely because that would also select areas of the subject. That's why I moved to a different tool to continue to select the rest of the background without the subject being touched.

 

30 minutes ago, R C-R said:

Yes. "green screen fails" are not the result of software bugs.

 

For those of us unfamiliar of green screen fails, I assumed that as long as a sampled color gets put in a selection entirely, then deleting it will remove it entirely. Is that not the case?

The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Link to comment
Share on other sites

13 minutes ago, Bri-Toon said:

For those of us unfamiliar of green screen fails, I assumed that as long as a sampled color gets put in a selection entirely, then deleting it will remove it entirely. Is that not the case?

Yes, that is what happens.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

1 minute ago, R C-R said:

Yes, that is what happens.

 

Well while I am waiting for Aaela's response to see what was done differently, this wasn't the case in the ending result of my video. I had all of the green selected, but after deletion, there was still remaining green within that selection.

The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Link to comment
Share on other sites

Sorry for the typo. Yes the subject was not in the selection. I only selected the chroma . I also tried to select a chroma in an image I got online, the opacity issue did not occur. But the chroma in that image was all one color grade as opposed to my image where the chroma has different shades of green. I don't know if this has any effect. But the strange thing is that (in my original image) although the subject was not in the selection, the opacity decreased when I removed the chroma. This did not happen at the edges of the subject only but all of the subject lost opacity.

I have uploaded two images one before deleting the chroma and one after. You can see how the subject loses opacity. I also put a black bar behind the subject to make it clearer. And the issue you experienced concerning the remains of the green screen also happened as you can see.

 

Thanks or your help.5a776a7348ab9_ScreenShot2018-02-04at9_56_51PM.thumb.png.f4c17f7f9add40a14ca393380bc682b7.png5a776a2b55f76_ScreenShot2018-02-04at9_58_28PM.thumb.png.42b0f27318c812ac7cdd528bd414c73e.png

Link to comment
Share on other sites

1 hour ago, aaela said:

Sorry for the typo. Yes the subject was not in the selection. I only selected the chroma . I also tried to select a chroma in an image I got online, the opacity issue did not occur. But the chroma in that image was all one color grade as opposed to my image where the chroma has different shades of green. I don't know if this has any effect. But the strange thing is that (in my original image) although the subject was not in the selection, the opacity decreased when I removed the chroma. This did not happen at the edges of the subject only but all of the subject lost opacity...

"Select sampled color" selects everything related to the choosen color and the applied tolerance setting in the whole image. Even if you explicitely exclude certain parts from the selection, it often fails here and strangely also removes pixels which have been excluded. It's pretty much like certain afterwards tweaks of a finetuned selection, even shown as been deselected are internally still among the set of the pixel selection range. - So what you tried here does not work always absolute bug free. One of the reasons why I would use masks here for such tasks, which you then can still finetune/adjust afterwards the wanted way.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

12 hours ago, v_kyr said:

"Select sampled color" selects everything related to the choosen color and the applied tolerance setting in the whole image. Even if you explicitely exclude certain parts from the selection, it often fails here and strangely also removes pixels which have been excluded.

From what I can tell, "Select sampled color" & the tone, color, & alpha selectors in the same part of the Select menu ignore/replace any prior selections or exclusions, but once these selections have been made from the menu exclusions can be created with any of the selection tools that have a subtract mode.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Out of the box thinking but I wonder if the subject doesn't have some reflected chrome colour, so before removing the green you select the subject and remove any green casting? worth a shot.

 

Also maybe duplicate the layer after chroma removal to flatten both layers?

iMac 27" 2019 Somona 14.3.1, iMac 27" Affinity Designer, Photo & Publisher V1 & V2, Adobe, Inkscape, Vectorstyler, Blender, C4D, Sketchup + more... XP-Pen Artist-22E, - iPad Pro 12.9  B| (Please refrain from licking the screen while using this forum)

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to comment
Share on other sites

Hello Firstdefence,

 

Thank you for your reply.

 

Quote

Out of the box thinking but I wonder if the subject doesn't have some reflected chrome colour, so before removing the green you select the subject and remove any green casting? worth a shot.

Can you elaborate more on how I can accomplish that ?

 

Regards,

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.