Jump to content
tyrabobo

Crashes when using refine tool

Recommended Posts

Me too...

 


They might not need me—yet they might— I’ll let my heart be just in sight—
A smile so small as mine might be

Precisely their necessity

 

iMac 27" 32GB RAM, MacBook Pro 15" 16GB RAM, iPad Pro 12.9", iPad Pro 9.7", Apple Pencil

Software tools of my trade: Affinity Designer  |  Affinity Photo  |  Astropad  |  Amaziograph  |  PDF Expert  |  Drafts  |  Editorial  |  Things 3

Share this post


Link to post
Share on other sites

I think this happens when lots of layers or the iPads available ram is getting low. Did you try closing the project (this performs a Save in AP). Then reopen and retry. If still crashing, try doing a hard reset on the iPad. This releases ram. Press and hold power and home buttons until you see the Apple symbol on screen. Around 10 seconds.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

I have the same issue and also upon exporting. I have already been doing the "work around". Problem is, I'm having to do it just about every other export. That's is not a fix. That is a headache that we shouldn't have to be doing every other export. 

 

iPad Pro 12.9 2nd edition

Share this post


Link to post
Share on other sites

Which version of Photo are you using? Since moving to beta, I can't recall crashing after using refine too. Other minor problems but refine seems fine.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites
On 2/5/2018 at 8:04 PM, DM1 said:

Which version of Photo are you using? Since moving to beta, I can't recall crashing after using refine too. Other minor problems but refine seems fine.

 

I'm not on the beta, but would love to be. My Affinty v. 1.6.5

Share this post


Link to post
Share on other sites

Had this happen too. Doing refine selection to change sky. Locked up twice. Had to shut down iPad Pro (12.9, 512gb), new, so I’m thinking Ram not an issue.  Was able to do refine work in small sections, so perhaps it locks when doing a large area? I was going end to end with a wall photo, so not overly complex. Not a beta tester, just new to AP and iPad Pro.

Share this post


Link to post
Share on other sites
On 15/02/2018 at 3:26 AM, BlueBoxPhotos said:

 

I'm not on the beta, but would love to be. My Affinty v. 1.6.5

You can apply here :)

Devs are up to 1.6.7 rel candidate 2. I suspect a new store version is not too far off as most bugs identified in earlier betas appear to be resolved. :D


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

I was told this was an issue with the old version. They say the new version fixes this.... it doesn’t work even with just the original one layer...

Happens when the pencil leaves the edge of the picture. Normally doing a tiny section.

Share this post


Link to post
Share on other sites

Still same problem and unable to upload problem file. Getting error message which says “the operation can’t be completed” couldn’t communicate with helper application.

Export also does not work to save to Drive but I can “share” to Drive. 

 

Any my help would be appreciated.

 

Oldnickj :)

Share this post


Link to post
Share on other sites

Unfortunately I can’t upload the picture I was working on as it was for a friend.  However I have tried it again on loads of other images and it doesn’t go wrong.

 

i will have to try to find other people with white shirts and white backgrounds.

thank you 

 

Share this post


Link to post
Share on other sites
On 28/03/2018 at 11:22 AM, Oldnickj said:

Any my help would be appreciated.

Sometimes the file can get corrupted. Try saving your file without the history using menu/Save a Copy. Delete the file from the project screen (3bars menu and Close) then Open the Save a Copy version.

 


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

When I try to export to google drive I get this error and I’ve tried several files. The error doesn’t give any clue if the problem is with affinity or apple.

9A58F591-E13E-47FA-A89A-269ED6153F73.png

Share this post


Link to post
Share on other sites

@OldnickjI seem to recall the current release has some sort of bug working with google drive. See here....

 


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

This happens to me almost everyday. 

 

I would suggest for dev to replicate, try having a document with many layers and the following conditions:

 

For me at least... when I have around 15 - 20 layers, working about through each one, jumping out of one, into the other type of workflow, and accumulated hours (5-6 straight) this scenario, the OP expresses starts appearing for me.

 

It doesn’t not come alone. I also get the marching ant line starts to disappear while it’s up. I have exit the file, then re-enter, and then there goes my marching ant line. 

 

These two two occur together hand in hand with me, if one occurs before the other - it’s already established, the other will pop up, just a matter of time. 

 

Running iPad Pro 10.5 (2017 model)

latest public release iOS 11.2.6

Share this post


Link to post
Share on other sites

I left the beta just now because of so many crashing issues. Now I'm on latest public version and same crashing issues over and over. Wondering if this could be caused by iOS 11.3 beta

Share this post


Link to post
Share on other sites

I'm on 11.2.6 and not experiencing any issues in AP. IOS beta is most likely the problem.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

iOS 11.3 has now been released. Not sure whether it is wise to update if the betas were causing issues.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

I’m still experiencing crash after crash even after I deleted AP and all docs related to it. So I started with a blank unused AP public release and still crashing. I cannot rely on AP to edit at all right now. But there is nothing that can beat it in the App Store. Any thoughts?

Thanks, Michael

Share this post


Link to post
Share on other sites

That's unusual Michael. My AP app hasn't crashed for ages, but I have not updated to iOS 11.3 yet.

What version of iOS are you running on the iPad? You previously mentioned iOS 11.3 beta. Are you still on the beta or the new 11.3 public release?


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×