Jump to content
BeB

Affinity Designer > resizing artboard started flipping and threw everything around

Recommended Posts

I was doing a simple illustration, though using 50+ layers and was spendig about 2 hrs when the software flipped out as soon as I resized my single art board. I have recorded a video of this happening which I will attach to this topic.

 

I'm not entirely sure of the steps to reproduce this bug. What I can remember is this:

 

- This file is a "save as" from a previous file.

- I also created a new a4 horizontal document in which I drew a component

- I copy/pasted this new vector component onto my "saved as" file and started reworking all existing elements.

- A lot of tiny curves were grouped and 'nested' within an existing object (using the rightmost button in the toolbar)

- Some objects were cropped using the vector crop tool.

- Everything in the file is basically vectors. No pixels.

- After a while I wanted to resize the art board. Upon sliding the corner point outwards, the software immediately threw all of my objects around. (see video attached)

* layers were retained in their z-index (if I can call it that)

* everything was thrown around with each mouse movement. Even far outside the artboard

* Most objects were resized

 

-> At this point I made a screen recording.

 

After the recording, I tried "save as", saved the "damaged file" hoping it was just a visual glitch. I kept the software open, clicked on the tab of the other file I had open (the object I created on a blank canvas) and tried resizing that artboard: Everything was fine in that other file. Which leads me to believe the software had an issue with that single file causing something to flip out.

 

After restarting the software, I opened up the damaged file. It was saved without error and I could open it fine. But it has all objects messed up (so, like I saved it) so I had to start over.

 

Further details:

- Win10 x64 intel i7 8700K / nvidia gtx 980ti / 32 GB RAM

- Affinity designer for Windows, latest version

- No plugins, I use the software exclusively. I do have the included UI kit and brushes imported, as well as Frankentoon Nomad pack.

- Other apps running at the time were Google Chrome (about 6 tabs open), Steam, Google Backup and Sync

- No error messages were given, no real crash occurred. CPU did not spike and memory usage seemed ok (though I have quite some memory)

 

afdesbug.mp4

Share this post


Link to post
Share on other sites

Hi BeB,

Unfortunately this is a known issue that is with development to be fixed. It is caused by having a clipped layer on an Artboard - which in your case is the Lens Filter Adjustment. If you unclip that and put it inside the artboard you should have no issues, but unfortunately that is a bit too late. :(:(

 

I will get this bumped with development!

Share this post


Link to post
Share on other sites

Hi Sean,

 

Thanks for your quick reply and the explanation! No worries about the lost file. I managed to redraw everything in a new file within 20 mins.

 

I'm very glad to hear that you guys know the issue, the culprit and that it's in the backlog :)

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.