Jump to content
swirler

Macro issue when opening from library

Recommended Posts

Hi, I’m trying to use some macros that I’ve created in AP but when I launch them from library window, it won’t start until I click on the macro several times, but the problem is that then AP applies 2 or 3 times the macro. It doesnt matter if the background layer is selected or not. Also tried with beta of AP but same issue is still present. The only way to make macros work is right click, select “edit macro” and then play it from macro window. Then it works. No matter the complexity of the macro, all custom macros have the same issue. 

Finally I’ve noticed that free macros pack from Affinity, doesn’t habe that issue. I was wondering if it’s my fault while recording a macro, but after looking tutorials and reading a lot of information I can’t figure out why is it happening. 

Hope anyone knows a solution.

 

Thanks!

 

 

PS: Using with MacBook Pro 13” late 2011 and iMac 27” late 2011 with High Sierra installed.

Share this post


Link to post
Share on other sites

Hello Meb,

On my iMac I‘m using a magic mouse and a wacom bamboo pen tablet. On my MacBook Pro 13“ I‘m using a magic mouse only.

Share this post


Link to post
Share on other sites

Hard to tell without trying out and knowing how you recorded that macro. I suggest best is here to provide an example of one of those macros, so people can try and see if they can reproduce that behavior and look inside it.


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Just realized that the macro works fine when using the MacBook Pro trackpad O.o

Could be an issue with magic mouse? I am using two different magic mouse with both mac's by the way...

Share this post


Link to post
Share on other sites
41 minutes ago, swirler said:

Here is one example of a macro with frequency separation layers which doesn't launch properly.

Retouch.afmacros

Works fine for me with the magic mouse, as usual just one click and the macro is executed as expected. But with a wacom bamboo tablet it only works as expected when it's touch mode is used, if you use instead the Wacom pen for clicking (trying to execute the macro by pen tap) nothing happens. - So I assume this has to do more with the Wacom pen tap recognition here.


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites
1 hour ago, swirler said:

Just realized that the macro works fine when using the MacBook Pro trackpad O.o

Could be an issue with magic mouse? I am using two different magic mouse with both mac's by the way...

Maybe, you have to try by exclusion method here if it may be a problem due to that. Also try out how other apps behave here with that mixed mice usage scenario.


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Hi,

I'm having the same problem with the library functionality. 

Wacom Cintiq pen won't work in the panel, using touch on the Wacom does.

 

Seems to me like a singularity, because the pen works otherwise fine.

Any suggestions? 

 

Share this post


Link to post
Share on other sites

Hi,

i have the same issue.

Macros triggers from the mouse works, but clicking with the Wacom pencil it do nothing.

that`s the same problem. 

Hope you can find the error.

Share this post


Link to post
Share on other sites

I have the same issue. But even with the mouse (magic mouse) its still usually requires at least 3 clicks before my custom macros load. Sometimes it will require up to 10 mouse clicks or more before the marco loads. And when it does it usually preforms the operation like two times.

I also can't get them to load at all clicking with the wacom tablet. It hightlights (turns blue when clicked) but nothing happens.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×