Jump to content
hperticarati

Affinity Designer crashes and recovery file also crashes (symbols + constraints)

Recommended Posts

This is not the first, second or third time that I'm in the middle of a design process and suddenly (apparently when dragging some layers) Affinity Designer Crashes. When I open it again, it displays the dialog asking me if I want to use a recovery file. If I choose yes, Affinity crashes again. When this happens, I get all my work lost, there's no way to recover it.

 

This happens always that I'm using symbols (I'm not even nesting symbols inside symbols, because I know this just won't work in Designer) and constraints. If I create a structure where a symbol has constraints within it, and the symbol itself is inside another constraints group, you can be sure that suddenly Affinity Designer will crash.

 

I'm so frustrated right now...

 

File attached, for reference. Please, could anyone open it and check if it's ok in your machines? I'm using a Mac OS X 10.13.3 Beta (this used to happen before the beta too).

New Inkscape - 06.afdesign

Share this post


Link to post
Share on other sites

I downloaded your file and it caused my AD to crash instantly too. I couldn't even see what you had. I have 16 gig of ram so should have enough memory. When I do very complicated designs I make use of PNGs (I believe you can also 'save as flattened'. That combines the work but you can't then go back and rework that file). So once I have a more or less finished design I turn whatever I can into a png open another file and import what I have to that file. I can still go back to the original file to work on it if need be. My experience is that my computer can't cope with long periods of heavy design work so I 'save as' and restart the computer on a regular basis. If you look at the design I have uploaded each flower is a png. The software just couldn't cope with that amount of data. I notice you're using the term 'Inkscape'. Are you using Inkscape and then importing files into AD? 

1a Valentine calla lilly copy.jpg

Share this post


Link to post
Share on other sites

Thank you for your effort on this psocretes!

 

Well, I'm pretty sure memory isn't an issue. I have too 16gb of ram and Affinity Designer was running smoothly, with no lag.

As I said, the crash happened after I reordered a layer... It looks like a symbols+constraints issue for me.

 

Anyway, my workaround was... Google Drive! Since all my work is synced to Google Drive, I opened the web version of it, right clicked on the file, selected the "manage versions" option and downloaded a previous version of the same file. Turned out I could recover most of my work.

 

Oh, for the Inkscape on the name of the file: the file was create in AD and all the work was done inside it, nothing was imported or appended from Inkscape. I'm actually trying an Inkscape redesign :)

Share this post


Link to post
Share on other sites

Thank you Chris_K!

 

One other thing: I don't know if you read my last post to this thread, but my workaround was to download an earlier version of the same file from Google Drive versioning system. That helped me to recover a version with little loss of work.

 

But surprisingly, only in this recovered file, I just can't add new symbols! I can use any symbol of my library, edit it, and the changes will replicate in realtime to the other instances. However, if I select a shape or a group, and press the "Create" button in the symbols panel, it just deselects the shape and nothing happens. I'm attaching the file for analysis.

 

On 1/19/2018 at 6:56 AM, Chris_K said:

Hi hperticarati

 

I've passed your file over to the dev team to see if they can get this crash sorted

 

Thanks

 

New Inkscape - 09.afdesign

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×