Jump to content
Schocksal

Add symbols into symbols and detach symbol which contains symbols

Recommended Posts

Heyo guys :) 

there are a couple of symbols in my project. I have combined a few of them into a group and created out of this group a new symbol (let’s call it symbolgroup).

I want to add a new object into this symbolgroup. For example I create an rectangle and move this rectangle object in the layer panel into the symbolgroup – that work’s fine and every instance of the symbol group is updated properly.

Now this new object I want to add is a symbol itself. When I move it in the symbolgroup the new symbol appears with unlinked attributes and no other instance of this symbolgroup is updated with the added symbol.

Is there any way to do that, so that the added symbol has no unlinked attributes and every instance of the symbolgroup is updated?

Because that didn’t worked the way I needed it, I tried to detach the symbolgroup, add the new symbol to the normal group and create out of this group a symbol again. But when I try to detach the symbolgroup every symbol in this group is also detached.

So, is there a way to detach only the ‘parent’ symbol and none of the ‘child’-symbols?

I have attached a file which illustrates the problem.

Thank you guys for any help! :) 

Cheers!

Symbol Test File.afdesign

Share this post


Link to post
Share on other sites

You have to move the curve into the symbol group not the actual symbol.

2018-01-10 15-58-35.flv


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Dell Inspiron 17 5767 i7 Laptop Windows 10 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Deco 03 Pen Tablet, XP-Pen Artist12, 5 pages on LaunchPad - iPad2 iOS 9.35 B|  Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites

Wow, thank you for creating a video! 

But the problem is still present. In your video, you have extracted the curve out of the symbol. So that's comparable to creating a new object and move it into the group.

6 hours ago, Schocksal said:

For example I create an rectangle and move this rectangle object in the layer panel into the symbolgroup – that work’s fine and every instance of the symbol group is updated properly. 

If you look at the curve that you moved into the symbol group, you can see, that it's no longer a symbol and so it won't be updated if the old symbol changes. And by dragging out the curve of the symbol, you somehow smashed this symbol too :10_wink:

Other ideas to solve that? :)

Share this post


Link to post
Share on other sites

Well I've tried several ways and there doesn't appear to be a way to have groups of symbols with each sub symbol adjustable. If you add to a symbol group it looks like it breaks the link and you have to ungroup all symbols, then group then back together to create a new symbol. The fact you can't edit the edit from the symbol panel shows its quite a basic symbol creation tool, even transforms don't sync.


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Dell Inspiron 17 5767 i7 Laptop Windows 10 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Deco 03 Pen Tablet, XP-Pen Artist12, 5 pages on LaunchPad - iPad2 iOS 9.35 B|  Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites

The problem is, if I ungroup the symbolgroup every symbol in this group turns into a normal object and looses its sync to the original symbol. It would be great if all symbols in this group would stay symbols if the symbolgroup is detached or ungrouped.

Share this post


Link to post
Share on other sites

I can create symbols, add those symbols to the work area, group symbols and ungroup those grouped symbols and they are still editable.

I've pretty much exhausted all ways to do this and there is no way to add a symbol to a group of symbols without ungrouping and then grouping them effectively breaking the link to all instances of the initial symbol group.

I Think I may have sorted it. I noticed that when a symbol is added after the initial grouping of the symbols to form the symbol group, the symbol added after the fact does not have group status, if you right-click on the added symbol and select Group it adds it to the symbol group and updates the symbol group in the symbol panel, you can even do this outside of the symbol group and then drag it into the symbol group as seen in my short video.

To detach the symbol, just right click on an instance of that symbol and select Release.

Add symbol to a symbol group.flv


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Dell Inspiron 17 5767 i7 Laptop Windows 10 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Deco 03 Pen Tablet, XP-Pen Artist12, 5 pages on LaunchPad - iPad2 iOS 9.35 B|  Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites
14 hours ago, firstdefence said:

Well I've tried several ways and there doesn't appear to be a way to have groups of symbols with each sub symbol adjustable.

More often than not, if I try to make one symbol part of another one (regardless of the method) this eventually leads to Affinity Designer crashing. I don't know why that happens but since it so often does, I try to avoid doing that!


Affinity Photo 1.6.7 & Affinity Designer 1.6.1; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.6.9.81 & Affinity Designer 1.6..2.24 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.0

Share this post


Link to post
Share on other sites

Another thing is the handling of symbols inside the symbol panel itself in relation to a visable indication of selected one and sync/unsync etc. Since symbols on that panel here don't visually indicate which one is in use and the associated one from the canvas, it is sometimes difficult to differentiate them at all here. This is a problem if you use a bunch of similar looking ones in the symbol panel.


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

@R C-R @v_kyr Yes its very messy but I'd got a 'bee in my bonnet' about it so I went 'heath robinson' on the task. It kinda works, whether Schocksal can make it work is another thing but its as near as I can get to his query. Other than doing some serious asset, symbol, layer and group naming, its a close pitch :S

 


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Dell Inspiron 17 5767 i7 Laptop Windows 10 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Deco 03 Pen Tablet, XP-Pen Artist12, 5 pages on LaunchPad - iPad2 iOS 9.35 B|  Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites
6 hours ago, firstdefence said:

... if you right-click on the added symbol and select Group it adds it to the symbol group and updates the symbol group in the symbol panel, you can even do this outside of the symbol group and then drag it into the symbol group as seen in my short video.

Haha, nice, that works, although it's not that intuitive ^_^ 

But thank you, that helps me a lot!!

3 hours ago, v_kyr said:

Another thing is the handling of symbols inside the symbol panel itself in relation to a visable indication of selected one and sync/unsync etc. Since symbols on that panel here don't visually indicate which one is in use and the associated one from the canvas, it is sometimes difficult to differentiate them at all here. This is a problem if you use a bunch of similar looking ones in the symbol panel.

Yeah, you're totally right. I love that symbol feature, it's actually great. But the use of them is still a bit bulky. Hopefully they will get some attention in the next updates.

4 hours ago, R C-R said:

More often than not, if I try to make one symbol part of another one (regardless of the method) this eventually leads to Affinity Designer crashing. I don't know why that happens but since it so often does, I try to avoid doing that!

I tried to place a symbol into a group of symbols with the "insert into selection' feature. While I have dragged the new symbol it has been rendered thousands of times at random places on the screen and after that affinity crashed.

Share this post


Link to post
Share on other sites

@firstdefence In your video: to add the green drop works perfectly the way you have done it. But try now to add a second instance of that symbol with the same method. The first drop simply disappears at the moment when you group the new drop symbol. 

If you group one or a number of symbols all instances of these symbols in existing symbol groups are completely deleted. And the best: Undo isn't working if that happens.

So at the moment I should just avoid working with symbol groups, that's too buggy.

Share this post


Link to post
Share on other sites
14 hours ago, Schocksal said:

@firstdefence In your video: to add the green drop works perfectly the way you have done it. But try now to add a second instance of that symbol with the same method. The first drop simply disappears at the moment when you group the new drop symbol. 

If you group one or a number of symbols all instances of these symbols in existing symbol groups are completely deleted. 

So at the moment I should just avoid working with symbol groups, that's too buggy.

Bugger O.o so close -_-


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Dell Inspiron 17 5767 i7 Laptop Windows 10 - Affinity Designer/Photo, Publisher Beta 1.7.0.140, Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Deco 03 Pen Tablet, XP-Pen Artist12, 5 pages on LaunchPad - iPad2 iOS 9.35 B|  Instagram & Flickr - Affinity Designer (ADe) Tutorials - Affinity Photo (APh) Tutorials - Public Domain Images

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×