Jump to content
Anon223029

Affinity Designer 1.6.0 (MAS) memory leak?!

Recommended Posts

Update:

I figured after using OpenGL for the rendering, that Affinity Designer doesn't show the mentioned behaviour. 

Metal seems to be therefore our 'problem' - I'm curious, any ideas why? - a Metal specific quirk or maybe really just a memory leak?

 

Share this post


Link to post
Share on other sites

Hi Anon223029

Apple changed metal before release giving it quirks. For some actions it tends to store messages before releasing them making some action slower which is what may be causing your memory to be taken up. This is why we implemented a second openGL setting for 1.6 which seems to be working better for you

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.