Jump to content
JanHelbig

Display problems on second screen

Recommended Posts

I am using Affinity Designer 1.6.0 on a MacBook Pro (Retina, 15-inch, Mid 2014) running MacOS 10.13.2. I have a second screen on the left of my main screen which I have tried to use with AD for the first time. While the document size is displayed correctly, the content of my document is roughly half the size it should be and partially outside of the document (upper left). When scrolling my document so that it is partially outside of the display area and back, the formerly hidden areas are first redrawn correctly, then erased and the smaller clipped version is drawn again.This happens in window mode and full screen mode. A minor problem is that some dialogs appear on the main screen even though I have used the menu on the 2nd screen to open them, e.g. Glyph Browser, About

Share this post


Link to post
Share on other sites

Same here. I don't remember to have this issue before 1.6.

Some times the file content just disappear. 

In my case, the problem happens after I drag the file window to my second screen, maximize that screen and use the shortcut to zoom to the page.

I have the same problem with Affiniy Photo.

 

Vídeo: 

 


__________________________________________

Affinity Desinger & Photo | Macbook Pro 13" Early 2015 | macOS Sierra 10.12.6 | Intel Core i5 2.7GHz | 8GB RAM | Intel Graphics 6100 1536MB

Share this post


Link to post
Share on other sites
2 hours ago, Strandbummler said:

Hey, i had the same issue and i fixed it by switching to Metal for Display Rendering. You find it under Setting / Performance / Display.

 

I had OpenGL selected previously. So, maybe this helps.

Affinity Rendering Bug OpenGL.png

Perfect Strandbummler!

 

Problem solved for Affinity Designer and Photo.

 

Thank you


__________________________________________

Affinity Desinger & Photo | Macbook Pro 13" Early 2015 | macOS Sierra 10.12.6 | Intel Core i5 2.7GHz | 8GB RAM | Intel Graphics 6100 1536MB

Share this post


Link to post
Share on other sites

I had similar issues, my UI would also become very pixelated when i switched between my laptop screen and my external 27" Dell (1080p). I can confirm switching to Metal solved all the rendering issues I had experienced.

Edited by sumodevelopment
markup changes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×