Jump to content
uNNatuRaLtm

No pressure sensitivity, auto switch to eraser

Recommended Posts

Using Huion Q11K, now it works fine in the Huion calibration program, but there is no pressure sensitivity in Photo. I have set the brush property to depend on pressure and tried fiddling with the curves too. Even with default x=y there is no sensitivity. Velocity kinda works sometimes.

 

Further, any click (even after selecting another tool, say, hand,) instantly changes it to the eraser. The same click works normally otherwise the rest of the time.

 

Any help appreciated. 

 

(AP 1.6.6 on macOS 10.13.1) 

Share this post


Link to post
Share on other sites

Hi uNNatuRaLtm,
 

Unfortunately we haven't got a Huion Q11K to try this, but we do have a Huion H58L which functions correctly when using the Brush pressure settings or enabling 'Force Pressure' on the context toolbar. As for the brush switching are either of the Pen buttons set to use E? This is the shortcut key for the eraser so if you are pressing that it will trigger key E (or Eraser).


Have you tried installing the latest Huion drivers at all?

Share this post


Link to post
Share on other sites

Hi, I got the Huion Q11K last week and just got around to using it. Enabling 'Force Pressure' on the context toolbar worked for me.

On a side note, the hotkey buttons on the Huion Q11K do not work for me.

Share this post


Link to post
Share on other sites

Just got a Huion GT 191 today, and I can confirm the same issue with the latest Mac Store version of Affinity Photo.

 

Pressure sensitivity is extremely low and I tried all pressure related brush settings. Sensitivity does not change or improve in the slightest, no matter how I adjust the sliders or curves. I have to press hard in order to make line strokes appear.

That problem does not exist in other painting applications I tested. The Huion driver also comes with a test area for tuning the pressure sensitivity and it easily recognizes the lightest touches. So I doubt it's anything to do with the hardware or the pen not being fully charged.

 

I also have the exact same problem with the automatic switch to the eraser tool. It is triggered by using the "brush swap" button, which is one of the two buttons on the Huion pen. I'm not 100% what the technical nature is but I believe it changes the pen so the tip switches to eraser mode. Another click switches it back to brush mode. The tool change (after click) is supposed to happen when the tip gets close to the screen. That seems to be throwing Affinity off. Only the automatic switch to eraser mode works, but clicking the switch button and getting close to the screen does not switch back to the brush tool. Other drawing apps like Rebelle 2 do not have that issue. Both pressure sensitivity and the tool switch button work fine.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.