Jump to content
MonsieurMey

Text export to pdf problem

Recommended Posts

Hello ,

I have realised a problem while exporting text in PDF.
When I use some fonts (e.g. Asap Regular), the text is not exported correctly. I have already tried the different PDF-export options and I am still having problems.
In the images you can see how the text looks like in Affinity Designer and how it is exported. I have this issue since Affinity Designer version 1.6.

Thank you very much!
Kind regards,
MonsieurMey

Text-Settings.PNG

Text-export-problem.PNG

Share this post


Link to post
Share on other sites

Hi MonsieurMey,

Unfortunately I'm still not able to reproduce this. Are you able to post a screenshot of the export settings you are using (including those listed under 'More'? Also what PDF viewer are you using to view the file?

Share this post


Link to post
Share on other sites

Hi Sean,

I think I found the problem. For some reason the Affinity Designer font cache has some fonts included multiple times.
The export problem just shows up when I use fonts that are multiple times in the font cache, e.g. Asap Regular or Montserrat Bold. For all others it works fine. I checked in my C/Windows/Fonts/Asap which font weights are installed and how many times. There were multiple times the regular weight, so I uninstalled the duplicates. But in C/Windows/Fonts/Montserrat are no duplicates of the Montserrat Bold that I could uninstall. Unfortunately, I sometimes have to rewrite my Windows fonts. It seems to me that a problem occurs when I reinstall the fonts.

Regarding your question: I attached the screenshot with the export settings. My PDF viewer is Adobe Reader XI (Version 11.0.23). The same problem occurs when I use PDF X-Change Editor (Version 6.0 - Build 322.7).

PDF settings.PNG

Share this post


Link to post
Share on other sites

Hi Sean P,

additional info: I checked in NexusFont whether there are duplicates and it displays some twice, but I still can't find the duplicate of the Montserrat Bold in the Windows font folder.

Share this post


Link to post
Share on other sites

The duplicates may only exist in the Windows font cache and/or the registry. The font cache can be deleted and it will be rebuilt upon a system restart. 

 

The registry could still confuse things.

 

Google how to delete the Windows font cache. 

Share this post


Link to post
Share on other sites

Hi

I have the same problem even if i clear the font cache.

And the the png files do not render correctly ( at the right the jpeg file, good render, left the bad)

 

1.jpg

2.jpg

 

3.jpg

Share this post


Link to post
Share on other sites

Hi Vilber,

did you restart your Computer after deleting the FNTCACHE.DAT?
I still had some duplicates afterwards aswell and I can recommend you to use the free tool NexusFont. There you can find duplicates and delete them.

Share this post


Link to post
Share on other sites

Thanks you!

it's work with nexusfont, I can't delet all duplicate font but i can delete the dupicate font who create the problem.

But still have the probleme with the png file.

 

Share this post


Link to post
Share on other sites

This problem occurs to me too every once in a while  with different fonts. Maybe a solution from Serif would be the best.

Deleting the font cache did not help for me either.


Branding, Identity Design, UI/UX Design.    |    https://whitex.design

Share this post


Link to post
Share on other sites

I also had many times problem with Fonts in PDF-Documents, generated from Affinity Designer (Version 1.6.4 / Windows-10). Even if I choose in the menu, that all Fonts should be included, it didn't work correctly.

Further more, the alternative solution to convert text in curves also didn't work correctly. The vertical lines in letters looks like bolt-type (e.g. I=I), the curves in letters displayed normal and correct.

I real like Affinity Designer, but please solve this problems soon, because if I can not be shure, that I get after hours of work a correct PDF with correct fonts, I can not use it in a proper way.

Share this post


Link to post
Share on other sites

Hi Pete2,
Welcome to Affinity Forums :)
We are looking into the reported fonts issues. It would help if you fill a report for specific cases you are having trouble with for us to see/reproduce.
Regarding the vertical lines looking like bolded text this may be due to an option in Adobe Acrobat which i believe you are using to check the files: go to Acrobat Preferences, Page Display section and untick Enhance thin lines. Let me know if it fixed this issue for you.

Share this post


Link to post
Share on other sites

Hi MEB,

thank's for your reply.

Because of the bolded vertical lines: Yes I can solve this problem by changing the Acrobat Preferences, but I could't find a solution, to implement this view attitude in the document, so everyone get displayed the document with this view. Is there a possibility to implement this?

The problem with export PDF's including fonts, I will fill a separate report for you.

Share this post


Link to post
Share on other sites

I am having this same problem with certain weights of the Roboto font family on Affinity for Windows 1.6.5.135. I've tried removing duplicate fonts and clearing the Windows font cache without any resolution. Is it possible that this was not a problem on earlier versions? If so, is it possible to install an older version that works? Or is there anything else I should try?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.