Jump to content
trippalhealicks

RAW files from RX1RM2 - All white?

Recommended Posts

Good morning, folks

Recently, I downloaded the Affinity Photo trial for Windows as I loved the app on my iPad and wanted to see if the desktop version could replace a Photoshop CC subscription.  

 

Unfortunately, the program opens RAW files from my new camera (Sony RX1R II) as almost all white.   I see 2 images (I assume a before and live "after processing" preview) but both are all white.  Is this normal behavior?  On one of the images I imported, I could see *some* details, but it was mostly all white.  Another image I tested last night was literally all white.  Just a giant white image.

 

Any thoughts?  If needed, I may be able to install the trial on my work laptop to get a screenshot.

 

Share this post


Link to post
Share on other sites

Uploading now.  I think this may be a problem with my desktop, specifically.

When I simply double-click the ARW file and try to open it through Windows Photos, It shows the image for a second and then pops up and error stating it can't read the file.  I do NOT have this issue when opening the file in the same manner on my work PC (also Windows 10).

 

It should also be noted the file opens fine in Affinity Photo for iPad.

 

Share this post


Link to post
Share on other sites

Well, I re-installed Windows 10 completely and it now opens the RX1RM2’s ARW files in the Windows Photos app just fine, although it still doesn’t work in Affinity Photo (same behavior as before), of which I was able to re-install a trial version.  Note that neither Photoshop nor Lightroom have had any issues with opening these, even when Windows Photos couldn’t.

 

Here is a screenshot of the behavior:

 

https://imgur.com/uvpyqu1

 

Share this post


Link to post
Share on other sites

Hi,

I've had to pass that onto the developers to look in to.  Did you use any sort of compressed raw format?


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites
On 12/4/2017 at 11:00 AM, pauls said:

Hi,

I've had to pass that onto the developers to look in to.  Did you use any sort of compressed raw format?

Not that I know of.  Quality setting "RAW" on the camera.  Would you like me to collect settings from the camera or logs from the Affinity Photo application?  I've recently transitioned from Photoshop / Lightroom to Affinity Photo on my iPad and PC and I ordered the Workbook.  Trying to support this fantastic product as much as possible and I'd like to help the devs get this resolved. :)

Let me know if there is anything else I can provide to help the process!

Share this post


Link to post
Share on other sites

We think it is  a compressed format causing the issue - but don't have  a resolution at this time. The camera has a compressed RAW format and an Uncompressed RAW format  maybe you have the compressed version selected ?

 


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

Actually, now that you mention it, I did find a mode earlier that is "uncompressed".....I used it once and the files were coming out at ~88mb each, so I turned it off.  I'm going to try an uncompressed ARW file when I get home this evening.


Thank you for the reply!

 

Share this post


Link to post
Share on other sites

Just checking back in on this....are there any plans to fix/implement this feature/capability?  Or, is there a valid workaround that doesn't include installing Lightroom?  I really don't want to use that software any longer. 

 

Thanks!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×