Jump to content

ABR files loading textures wrong

Recommended Posts

Excuse the duplicate topic, I've only found one thread with no recent activity.  

I'm having a problem loading .abr files into Affinity on my ipad pro.  I've tried multiple brushes from different authors and I get (usually) the same results.  The textures, more often than not, load and display at about the top third of the texture window, the rest is black.  This results in the brush only being useable in the top portion of the canvas...anything below it paints a solid with no texture.  I've snooped around and tried to find a fix to no success.  Has anybody ran into this problem?  I feel like it might be a problem translating from a pattern based texture in photoshop (but still wrapped in an ABR file) to Affinity needing a full texture image.  Any thoughts would be awesome.


Using an iPad Pro 10.5" with the latest ios 11 update as of Nov 27,  2017








File Nov 27, 4 32 39 PM.jpeg

File Nov 27, 4 34 51 PM.jpeg

Share this post

Link to post
Share on other sites

Further to Kyle's topic, I get exactly the same issue with ABR files.


My original post (for which I never received any help) is here displaying what I see in Affinity Photo, very similar to what Kyle gets:

To save clicking through these are my images:



Share this post

Link to post
Share on other sites

I decided to bump this thread instead of making a new one.

I also experienced the incorrect texture loading issue on both the ipad version of affinity photo and designer, although I initially encounter it on my windows version of affinity. So, this bug actually exist on ios and windows version of photo and designer, not sure about mac though.

I think it is the same problem that both @highrise and @GarethB experienced, I have attached a screenshot below.

However, it could be that the abr files that experience this issue was from the newer version of Photoshop, therefore requiring more time in order to make it work properly in Photo and Designer. I searched for this issue and only encounter two posts about this and both were from November last year, there are no more updates to these threads. I think there were a couple of updates to Photo and Designer since then but so far none seemed to resolve this issue. I figure that I need to bump this thread just to let it be know that this issue still persists.

I enjoyed using both Photo and Designer and I think that they are excellent alternatives to Photoshop. One of the reason I decided to use them was their ability to import abr brushes and I kept thinking about this issue. Artstudio Pro on Ipad is able to import this brushes without any textures issue but it is only available on Ios. I really hope that this issue will be fixed soon and I would like to thank Serif for developing such great apps.




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.