Jump to content
km.au

Stuck on panning mode

Recommended Posts

Hi, anyone else use Affinity photo and quite often the canvas locks onto the mouse and follows it everywhere as if pan mode is permanently on? 

 

The only fix is to close the program down and open it again. I haven't been able to reproduce but it seems to happen when saving and the spacebar is pressed while the save occurs. Again though, it's not a 100% reproducible bug. 

 

Windows 10. 

Share this post


Link to post
Share on other sites

Hey km.au, 

 

Are you just using a standard keyboard and mouse? Do you have a tablet or anything like that plugged in? I haven't seen this so I'm wondering if it could be hardware related. 

Share this post


Link to post
Share on other sites

Hi, 

 

Just a standard keyboard and mouse. This issue happens quite often in working with the program during the day. 

I don't think it's hardware related as it happens on a custom built workstation at home and a HPZ440 at work. 

 

It seems to reproduce while the save dialogue box is present. 

Share this post


Link to post
Share on other sites

Hey km.au,


I can trigger this if I am panning and then do a Ctrl+S to bring up the Save As dialog. When the dialog is closed, the canvas is stuck to the pointer until I left-click. I can't get it to become stuck permanently though. Leave it with me as I'll try it on a few setups and see if my colleagues have seen it. The fact I can get it to grip the canvas when the Save As dialog appears might be enough for development to find a fix for you. 

Share this post


Link to post
Share on other sites

That would be most excellent. 

 

I too think it occurs mostly when panning with the Ctrl + S dialogue. 

 

Although for me it gets stuck until the program is closed. Even minimizing,  or any other manner of keys won't fix it. I'll give the left click a try though. 

 

Thank you Chris. 

Share this post


Link to post
Share on other sites

Hi

 

I was able to recreate this problem. I am running on a Microsoft surface 6. It happens when I hold control and then I try to click (use the stylus in my case) on the canvas area. This locks the pointer action in pan command, another way to fix it other than closing the software is to close the file and then re-open, no need to close the software. Let me know if there is a fix, I found myself doing this, because of the CTRL-Z undo command is easier than erase command.

 

Hope this helps.

Share this post


Link to post
Share on other sites

Hey emi_vin, welcome to the Affinity Forums.

Does this happen every time? I've been trying it with our Surface Pro 4 for a good ten minutes and I cannot reproduce it by holding the Ctrl key.

Share this post


Link to post
Share on other sites

Happens to me as well (when panning the viewport with SPACE key cursor changes to the HAND tool, that's natural - but quite often it doesn't switch back, clicking different tools or using hotkeys to switch the tools doesn't work at all), in most cases, switching to another persona, then switching back mostly fixes the issue for me.

 

Share this post


Link to post
Share on other sites

Hey CLC,

This doesn't happen for me—at all. The app is mostly the same for everyone (of course we have customisations within Preferences) so I would really like to figure out what is triggering this! 

It could be anything from another app to a simple setting in Affinity. Have you ever modified any keyboard shortcuts? Do you recall changing any preference options? Can you reproduce it on a new Windows user account? 

Share this post


Link to post
Share on other sites
1 hour ago, Chris B said:

Hey CLC,

This doesn't happen for me—at all. The app is mostly the same for everyone (of course we have customisations within Preferences) so I would really like to figure out what is triggering this! 

It could be anything from another app to a simple setting in Affinity. Have you ever modified any keyboard shortcuts? Do you recall changing any preference options? Can you reproduce it on a new Windows user account? 

Hi Chris B, I've changed many of the config options for Tools and UI (see the screenshots).
For keyboard shortcuts, I just changed a few, three or so (because I had issues with disappearing icons from Toolbar on upgrade to 1.7, I did reset the settings - all three first checkboxes on app CTRL+start, I've decided to stop tuning keyboard shortcuts for good, configuring it all again would be quite a pain).
It happens to me on both of my Windows computers (both setup one by one, not by copying any configs) so yes, I can reproduce on another Windows account (even on another Windows install).
I believe it never happened to me on any of my Mac's though.

It happens randomly, mostly when I'm working zoomed in, working with Inpainting Brush Tool, panning across the image with SPACEBAR+mouse.
It just sometimes doesn't switch back to the tool I was working with.

This is why it's hard to record such an issue, but once it happens again, I'll shoot up my screen recorder to provide a recording and will be back.

photo-tools.jpg.f3b456e56c0fdaef7166904b77cb57b8.jpg

photo-ui-settings.jpg.94956ba340b3185125a5f62f69b967f2.jpg

Share this post


Link to post
Share on other sites

Hi @Chris B so it happened again and I was even able to make screen recording.

What I've noticed is that it nearly always happens when I'm doing inpating with the inpainting tool and panning around with space.

Trying to switch the tools - nothing works - but after a while, it somehow went alive and started working again (that never happened to me before).

In 99 per cent of the cases I have to close Photo and start it again to get access to the tools.

Cheers

 

hand-tool-stuck.gif

Share this post


Link to post
Share on other sites

Hi @Chris B - nope, I don't use spacebar+alt at all.

I'm just inpaiting with inpainting brush and when I need to pan, I use space.

Happened to me again just now...

This time it's stuck that way for 10 minutes already, no matter what I do.

hand-tool-stuck-no3.gif.7576b54eaa6177f9d2b0b9eb45604381.gif

 

Share this post


Link to post
Share on other sites

Nope, nothing does.

Sometimes, it starts switching tools after a while again (first two screencasts) but in most cases it doesn't and the only fix is to restart Photo (as you can see in the last screencast)...

Share this post


Link to post
Share on other sites

Nope, I'm using both mouse and keyboard, in most cases switching tools with their hot keys, but for those screen casts, I wanted to show you that I'm actually clicking the toolbar icons also.

The keyboard or mouse isn't stuck, I bought a new pair to check out if it's not a keyboard or mouse issue...

Share this post


Link to post
Share on other sites

There has to be something unique to your machine and the other few users reporting this. Do you use any software that managed keyboard shortcuts or assists with any form of input? 

Share this post


Link to post
Share on other sites

Weird.

Happens to me on both my Windows 10 boxes, both clean installs of Win 10, configured manually.
No special software installed, just Affinity trinity, Adobe stuff, browsers, Thunderbird.

Both of my Macs are fine and nothing like this ever happened there.

Share this post


Link to post
Share on other sites

And nope. It's a classic HP computer, bought in a store. The other one is nearly the same, just bought online.

Classic USB keyboard, USB mouse. No special hardware, no tablet, no software for clipboard handling, no additional utilities (except for FontBase font manager).

If you'd like me to PM you list of software, hardware etc., just ask.

Share this post


Link to post
Share on other sites

I’m using multiple keyboard layouts though - some standard western ones, some central european ones, Russian and Hebrew (the only rtl layout on my system).

Switching layouts frequently (nearly every minute at least one layout switch).

Share this post


Link to post
Share on other sites

Hey!

I've just downloaded Affinity Photo to try before buy. Then i ran in this error also. For me the space+ctrl zoom style activates it. Finally i stuck to the hand icon and three things happen: 

1. i can not use other tools properly (like the crop canvas)

2. i can't pan the canvas anymore

3. i can't zoom dynamically like before, just with clicking

I have to restart the program, but save every document and reload is a pain. :( 
With this behavior, i won't buy. If you fix it, then i will. 

Share this post


Link to post
Share on other sites

Hey jay27flow, welcome to the Affinity Forums.

If you aren't using spacebar + alt (a known trigger), do you have any clues as to when this happens? 

@CLC - sorry I seemed to have missed your last few replies :( If you want to PM me a list of your 3rd party software I would appreciate it.

Share this post


Link to post
Share on other sites

We have made fixes/improvements to this area (Hand cursor gets stuck after panning) of the program in the latest release.

The fixes and how to update are described in these forum posts.

We would appreciate you checking that this issue has now been resolved for you.


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.