Jump to content
schmuttah

No camera data when opening RAW

Recommended Posts

Hi guys,

I am fairly new to photo editing in general and Affinity photo in particular.
However, I have used affinity photo since the last release and now I am using the 1.6.0.89 build.
I like it a lot, but I have experienced one bug so far. It is a little annoying bug. I have startet to take pictures in RAW, as I have a Nikon camera the file format is .NEF.
When I load the RAW image in Affinity photo I do not get any camera data. It just says "no camera data" at the top. I am missing my used optics settings etc.
If I check the properties of the files in Windows, I see all the information that I want to be shown in Affinity. If I open the files in Nikons program Capture NX-D, I can also see the information.
At first I thought there were some kind of problem with the .NEF files so I opened the files in Capture NX-D, exported them to .Tiff files and then opened them in Affinity, but I still couldn't see the camera data.
So there seems to be a problem with camera data information for RAW files in general for Affinity photo.
Does anybody else have the same problem as me ?
Is this something you can adress in the next release ?

Other than this bug I am very happy with my purchase so far and I want to say thanks to Serif for a good photo editing software ! :)
 

Share this post


Link to post
Share on other sites

Thanks for the files. I've both loaded them in Photo 1.6.0.89 and the EXIF info is displaying correctly. It sounds like you could have might have an antivirus program might be blocking exifitool.exe from running.

To retrieve EXIF data from an application a small program called exiftool.exe which is temporarily placed in %temp%. We've had issues where antivirus programs are flagging this as malicious and stop if from running. 

Share this post


Link to post
Share on other sites


I have updated to 1.6.1.93 and I still have the problem.

Tried to exclude exifitool.exe in my antivirus as well, there were 3 copies of the program, two in different temp-folders and one in the affinity folder. I excluded them all in the antivirus program but still can't see the camera info.

Is it really important to only use english ASCII-type letters ?

As I do not use an english version of Windows, my Temp-folder is located in subfolders where there are some "ä" and "_". While both of them are ASCII-type, they are not english.

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Mark Ingram said:

With 1.6.1.93 there is no longer a restriction on non-ASCII characters in usernames. Exiftool should now run from the %PROGRAMDATA% folder.

Hmmm....I have no exiftool.exe in my programdata folder. Is it possible to copy/paste it from one of the other folders I have it in, to the correct path in the programdata folder ?

Share this post


Link to post
Share on other sites

Just to clarify, when I open up .JPG which had been developed in the camera I get information about what kind of camera and what kind of objective I took the photograph with. But not my settings on the camera.

When I open up .NEF I get no information what so ever.
 

Share this post


Link to post
Share on other sites
On 11/21/2017 at 2:08 PM, Vladislav said:

it was already done before. My %temp% variable is c:\WinTEMP

 

What about %TMP%? You would need to change that too (in 1.6.0)

ExifTool in 1.6.1 should work regardless of any non-ANSI characters in your user name or TEMP/TMP path. However, it may still fail if you have installed Photo to a non-ANSI path. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.