Jump to content
Focus9

Affinity Photo 1.6.6 and High Sierra 10.13.1 Affinity does not launch anymore

Recommended Posts

Hi affinity team.

 

I upgraded my MacBook Pro (2017) to High Sierra 10.13.1. Have Affinity 1.6.6 installed.  Since the upgrade Affinity Photo does not launch anymore.

 

Process:               Affinity Photo [1132]
Path:                  /Applications/Affinity Photo.app/Contents/MacOS/Affinity Photo
Identifier:            com.seriflabs.affinityphoto
Version:               1.6.6 (1.6.6)
App Item ID:           824183456
App External ID:       824080612
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Affinity Photo [1132]
User ID:               501

Date/Time:             2017-11-15 15:08:43.632 +0100
OS Version:            Mac OS X 10.13.1 (17B48)

 

Termination Signal:    Illegal instruction: 4
Termination Reason:    Namespace SIGNAL, Code 0x4
Terminating Process:   exc handler [0]

 

 

Please let me know what to do.

 

Cheers,

- hendrik 

Share this post


Link to post
Share on other sites

Hi Focus9

 

Are you able to copy the full report and stick it in a text file and attach it here. then can you try deleting and re-downloading the app to see if this sorts it for you. if not do you have any background apps running like font managers or clipboard managers? If you open the app by double clicking on a file does the app open for you then?

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Chris, It seems to be working now....No idea what happened.  The issue I have now is that the resizing of the Canvas does not work.  When I anchor in the center only the left, right and bottom get a border.  The top does not.  Know issue?

Share this post


Link to post
Share on other sites

Ah, well. let's try here shall we?

 

Posted 5 November:

 

No crashes as such but having upgraded to 1.6 means useless program now. Tried Lens Blur on one of three Layers and after ten minutes watching the progress bar come up again and again I gave up and hit the Esc key. No use at all. Couldn't close the program down either. Shut down my MBP altogether. Gave it another chance, this time on just one layer. Same waste of time.

Thank you Affinity, back to Photoshop and not happy at having wasted my money either.

 

 

Five days later ... I'll chip in with Earlio and also say "A reply would be nice". (Now 18 days, thank you Affinity ...)

Share this post


Link to post
Share on other sites

@m3photo, this seems a common way of getting rid of crashes as recommended by Serif, did you try this?

 

Launch the app with (control) held down until a Clear User Data dialog appears. Remove the ticks for Don't restore window and documents and Reset Studio. Leave only Clear User Defaults checked then press Clear. This should fix the crash issue.


Affinity Photo 1.6.7 and Designer 1.6.1 on MAC Mojave 10.4 Beta, Affinity Photo 1.6.9 and Designer 1.6.3 on iPad Pro 9.7" IOS 12.1 beta 5, Affinity Photo 1.6.4 on Windows 10

 

 

Share this post


Link to post
Share on other sites

Hi Paul. I'd given up on this program so hadn't returned to the forum. I appreciate your effort in answering but I was piggybacking on the OP's initial query, hence my initial "no crashes as such ...".

I even tried uninstalling it altogether but tried using it again yesterday and see it's still extremely slow at doing anything at all. Oh well, I suppose I'm another fool for parting with my money hoping to find an alternative to Photoshop, which incidentally does work at comfortable speed on the same computer. The people at Serif are obviously happy at what they're selling so not bothering much with those who can't do anything with it. Ho hum ...

Share this post


Link to post
Share on other sites

Hi m3photo,

Welcome to Affinity Forums :)

I'm sorry nobody answered your question. Sometimes a couple ones falls off the radar. My apologies for the delay.

Is this happening with any file or just a specific one? If just one can you please upload/share a link so we can take a look please.

If not try to reset the app: launch the app with (ctrl) held down until a Clear User Data dialog appears. Keep the ticks for the first three checkboxes and press Clear. Did it fix the slowdowns?

Share this post


Link to post
Share on other sites

Hi MEB,

 

This was happening to any file I was trying.

I've reset the app as per instructions and it has made it more responsive. I'll keep using it a while to get used to the new method of working.

 

Muito obrigado.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×