Jump to content
michno

Affinity Designer 1.6.0.89 - CMYK color bug

Recommended Posts

Hi,

 

I have a problem with Affinity Designer (v. 1.6.0.89). Today, I recived PDF (v.1.4) from my client with some book cover, created with Adobe InDesign CS3 (5.0.4). Document with CMYK colors don't have assignated color profile, so I assigned profile with Coated FOGRA39.

 

When I tried to change some color values on the one of the rectangles, CMYK sliders in Fill box increased maximum values from 100 to 255 (like it was in RGB). I closed and re-opened document, but this don't helped, so I closed and re-run Affinity Designer with clearing user data. This has been resolved problem partly - now maximum vaules in CMYK sliders are 100, but color preview is still like from RGB sliders.

 

I made a video with this bug: 

 

 

 

Reinstallation doesn't change anything. My OS: Windows 7 with Service Pack 1

 

So, is it a bug, or I made something wrong?

 

Cheers, 

michno

 

Share this post


Link to post
Share on other sites

Hi Michno,
It sounds like you originally have CMYK colours set to 8bit values instead of Percentages. For future reference this can be changed from the Colour Panel by clicking Panel Preferences and selecting Sliders and then CMYK from the dropdown. From there click Panel Preferences again and change the value from 8bit to Percentage.

The issue regarding the CMYK sliders in the flyout appearing as RGB has been reported to development. If you switch the Colour Panel to CMYK sliders that should display the correct value.

CMYKPercentage.png

Share this post


Link to post
Share on other sites

As for the sliders, using the hamburger menu at the top of the Color Panel, select the Sliders. Select CMYK. Then pop it down again and select Percentage. Should stick.

 

As for the other issue, I believe that the appearance of the context toolbar has been noted, but thanks for bringing it up again.


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

Sean, the context toolbar is still wrong...Make a rectangle, fill it with 100% Cyan and look at the display on the toolbar...


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

Thank you guys for quick reply! 

 

Changing option from 8-bit to Percentage in hamburger menu in Colour window partly fixed this issue. Window now display correct value, but like @MikeW said, there is still wrong color in Fill context box.

 

At this moment this solution fits to me, but frankly I get used to change color values from Fill window in context box :P

 

Cheers,

michno

Share this post


Link to post
Share on other sites

 

1 minute ago, michno said:

but like @MikeW said, there is still wrong color in Fill context box.


This is part of the same issue that has been reported to development. That Fill box and the flyout on the context toolbar are being rendered incorrectly as RGB

Share this post


Link to post
Share on other sites

OK, I understood. I hope it will be fixed in the next release of this awesome software ;) 

 

Once again, thank you for help! 

 

Cheers,

michno

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×