Jump to content
AmapThom

[Fixed] Continuous slice export regularly un-ticked

Recommended Posts

Hello,

 

I have an issue where the export persona slice export "Continuous" option is automatically unticked without apparent reason.

 

Some context: I have an Affinity Designer file composed of many artboards. I would like to export all the artboards automatically when I save (so that I can regularly drag-top the generated .png files to Invision).

In the export persona, "Slices" toolbox, I have exported the slices, and ticked the "Continuous" option. However, I regularly notice that the .png files stop being generated. Every time, I see the "Continuous" option has been disabled. So regularly, I need to re-export manually, and then tick the "Continuous" option again.

 

I haven't tried to isolate the problem, but I suspect it may be related to the creation of new artboards (I typically copy paste existing artboards to create a new one, then rename one of the copies). Not sure if that's the actual reason, though.

 

AmapThom

Share this post


Link to post
Share on other sites

Hi AmapThom

I've tried this myself, but have been unable to reproduce it. Are you able to use QuickTime to do a screen recording showing this occuring please? Ideally showing the continous export enabled and then not. This will help us get an idea as to what might be happening to try and reproduce the issue.

Share this post


Link to post
Share on other sites

Hi Sean P

 

I tried to reproduce it, but I am not sure why: the behaviour on artboard duplicated seemed to change recently (I upgraded from 1.5.5 to 1.6 last week). Before, I remember distinctly that when I duplicated and renamed an artboard in the Draw persona, I didn't have to create a new slice for it in the export persona: a slice would be created eventually ready for me to export.

 

In my recent test using 1.6, I duplicated and renamed an artboard, and I couldn't see any slice created for it.

 

I am really confused, and my best guess would be that this behaviour changed between 1.5.5 and 1.6, but can't say for sure.

Share this post


Link to post
Share on other sites
47 minutes ago, AmapThom said:

Hi Sean P

 

I tried to reproduce it, but I am not sure why: the behaviour on artboard duplicated seemed to change recently (I upgraded from 1.5.5 to 1.6 last week). Before, I remember distinctly that when I duplicated and renamed an artboard in the Draw persona, I didn't have to create a new slice for it in the export persona: a slice would be created eventually ready for me to export.

 

In my recent test using 1.6, I duplicated and renamed an artboard, and I couldn't see any slice created for it.

 

I am really confused, and my best guess would be that this behaviour changed between 1.5.5 and 1.6, but can't say for sure.

This is an intentional change made by development - it has thrown a number of people off! Matt has said he may well change it back! I'll add your comments to the issue.

Share this post


Link to post
Share on other sites

I just also noticed that, as I move an artboard around, the associated slice will not move along anymore. This is a pity, that feature was really useful, as far as I'm concerned.

Share this post


Link to post
Share on other sites
5 minutes ago, AmapThom said:

I just also noticed that, as I move an artboard around, the associated slice will not move along anymore. This is a pity, that feature was really useful, as far as I'm concerned.

If you have just draw the slice and snapped it to the Artboard then it will not move. However if you've selected the Artboard in the Layers Panel and then clicked 'Create Slice' it will create a 'Slice (From Layer)' which will follow the artboard around when it is moved.

Whilst I personally cannot bring the feature back I've passed your comments onto development.

Share this post


Link to post
Share on other sites

Thanks Sean,

 

That could help - at least I could create my new artboards that way. However, I am not able to find this option. I am in the Draw persona, and I have selected my artboard in the layers panel. As much as I looked, I can't find it neither in the layer panel itself (I hovered on all buttons, and also right-clicked), the 2 main top panels, nor the menus. Am I missing anything?

Share this post


Link to post
Share on other sites
7 minutes ago, AmapThom said:

Thanks Sean,

 

That could help - at least I could create my new artboards that way. However, I am not able to find this option. I am in the Draw persona, and I have selected my artboard in the layers panel. As much as I looked, I can't find it neither in the layer panel itself (I hovered on all buttons, and also right-clicked), the 2 main top panels, nor the menus. Am I missing anything?

 

Never mind, I found it in the export persona.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×