Jump to content
Dmitri Rabounski

Affinity Photo crashes when launching FilmPack 5

Recommended Posts

On 08/11/2017 at 9:32 PM, Dmitri Rabounski said:

Affinity Photo 1.6.0.89 crashes when launching DxO FilmPack 5 as a filter (it was added via Preferences => Photoshop Plugins).

Windows 10 Home 64-bit.

 

P.S. Gift license for DxO FilmPack 5 can be achieved from DxO from the following link, for your testing purposes to see the bug I just reported.

 

Can you try the latest customer beta (1.6.1.90) and see whether this has been fixed. I have improved Photoshop plugin support in that version.

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

Can you try the latest customer beta (1.6.1.90) and see whether this has been fixed. I have improved Photoshop plugin support in that version.

 

I tried to launch FilmPack 5 from APhoto beta 1.6.1.90 as you said. (Before installing the beta version, the previous version of Affinity Photo was uninstalled.)

The same bug: AffinityPhoto crashes just FilmPack launched. But in the case of the new beta, an error window appeared. It is below, attached.

I added FilmPack via the path shown on the other attached screenshot.

 

By the way, this distribution of FilmPack works well from my Photoshop CS6.

So, there is something conflicting with FilmPack within Affinity Photo...

Windows 10 Home, 64 bit.

 

I have moved from Photoshop to Affinity Photo, and would thank you very much if you improve this bug, please. Just because FilmPack is the one of my main applications I use (along with PhotoWiz plugins that works very well under Affinity Photo).

 

DxO.thumb.jpg.d0ed18e4209eb7b3c2d1e4f309b69c2e.jpg

Path.thumb.jpg.bd2549118885677be0dcb809e90eba24.jpg

Share this post


Link to post
Share on other sites

I hate to revive a dead topic, but has any progress been made on this? DXO Film Pack 5 still crashes 1.6.5 and the 1.7 Beta.  It would definitely be a workflow improvement if we didn't have to use Film Pack separately.

Share this post


Link to post
Share on other sites

Yes, the PlugIn Support in Affinity Photo is the only thing which s.... :|

I also tried to use DXO Film Pack 5 with every new Affinity Photo Version with no luck.

Share this post


Link to post
Share on other sites

Same here, I have DxO FilmPack 5 photoshop plugin & Affinity Photo 1.6.5.135

The software crashes upon launch of DxO module.

I would have sent the dump file in the CrashReports folder but somehow it's not recorded & its size is 0.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×