Jump to content
footof

Designer: Expand stroke is completely broken

Recommended Posts

1 hour ago, SteveMose said:

I think they are more concerned about launching tablet versions than actually fixing their main product. You cannot tout UI software which fails in a primary requirement for UI design. The auto-response from moderators is very disheartening. 

Absolutely. The marketing is very misleading, that's my biggest issue. 

Share this post


Link to post
Share on other sites

It's been almost half a year passed since last comment and still no results. Just purchased AD few days ago and on v1.6.1 I've faced with same issue.  I'm shocked with such irresponsibility.

I'm going to ask a money back because for me it's not a vector editor without such working feature as expand stroke.

Share this post


Link to post
Share on other sites

Hi!

What's the current status? As an icon designer myself, this is the kind of bug that unfortunately keeps me going back to Adobe Illustrator.


Please give us any update on this. Thanks.

Share this post


Link to post
Share on other sites

This a piece of crap. iTunes support rejected me in refund request. They told me that I need to ask for a help on this forum. But they don't know you guys just don't f**n care. I've wasted 50 bucks on this and I really regret.

Screen Shot 2019-01-28 at 18.02.37.png

Share this post


Link to post
Share on other sites
On 28. Januar 2019 at 5:07 PM, Evanre said:

I've wasted 50 bucks on this and I really regret.

You are not alone. Because Serif did not tell us the current status after those patiently endured years, drop them an email at affinity@serif.com and/or report the bug again or again.

Or email AffinityReturns@serif.com within 14 days of purchase.

HTH

Share this post


Link to post
Share on other sites

2019... the issue persists. It's sad. I'm considering other alternatives seriously. I'm not gonna spend another $50 on a software update 2.xx with slow bugs fixing phases.
There was an issue with the Transparency Tools that crashed the program. I had to spend days, weeks, months until many versions later, it was "fixed".

Now I found this huge bug.   Had to create a duplicate of my object, then resize it to cover the stroke, then remove the stroke, then use the Subtract Pathfinder. Just to simulate a stroke that is not a stroke, but a curves that can be added with other curves with the Add Pathfinder.

Share this post


Link to post
Share on other sites

I've had the same problem on several projects and it can be frustrating. The 'increasing the size' remedy doesn't seem to work for me. However, I'll tell you what I did as a workaround. First you will need a piece of vectorizing software (I use Image Vectorizer' on my Mac. It's the simplest and best I've tried so far and it's not costly.) I isolate the bits that need to be expanded and copy and paste into a new doc which I then I export as a jpg and vectorize the file. Then bring it back in to the project doc. Not exactly, 'Hey Presto!" but it worked for me.

It'll be great when this gets sorted.



 


Using: Mac OSX El Capitan 10.11.6  on a Mac Mini (late 2014). Wacom Bamboo. Mouse. 

 

Kevin McSherry: Creative. Art  :  Illustration  :  Design
The Studio, 17 Aideen Avenue, Terenure, Dublin 6W.  Ireland
+353 (0)86 247 0737   www.mcsherry.ie

160604_35%2Bicon%2Baffinity.jpg

Share this post


Link to post
Share on other sites
35 minutes ago, kevinmcsherry said:

what I did as a workaround

We think it is a much easier / precise workaround to do the “Expand Stroke” in a(n open source) vector graphics editor.

Share this post


Link to post
Share on other sites

Simplicity itself! Why didn't I think of that? Which one do you think is best?


Using: Mac OSX El Capitan 10.11.6  on a Mac Mini (late 2014). Wacom Bamboo. Mouse. 

 

Kevin McSherry: Creative. Art  :  Illustration  :  Design
The Studio, 17 Aideen Avenue, Terenure, Dublin 6W.  Ireland
+353 (0)86 247 0737   www.mcsherry.ie

160604_35%2Bicon%2Baffinity.jpg

Share this post


Link to post
Share on other sites

Indeed you're right. I was thinking of an online vectorizer. I'm happy enough with my clunky process -it's reasonably straightforward.


Using: Mac OSX El Capitan 10.11.6  on a Mac Mini (late 2014). Wacom Bamboo. Mouse. 

 

Kevin McSherry: Creative. Art  :  Illustration  :  Design
The Studio, 17 Aideen Avenue, Terenure, Dublin 6W.  Ireland
+353 (0)86 247 0737   www.mcsherry.ie

160604_35%2Bicon%2Baffinity.jpg

Share this post


Link to post
Share on other sites
1 hour ago, kevinmcsherry said:

right

So you did not read the white text on the blue graphic?! You even can make it easier with a macro to get it into the other app and (expanded) back into AD with one command.

Share this post


Link to post
Share on other sites

Jesus, my eyesight. I'm rushing around so much today I didn't even cop that there was a link...

Thanks for your help, O. Kevin


Using: Mac OSX El Capitan 10.11.6  on a Mac Mini (late 2014). Wacom Bamboo. Mouse. 

 

Kevin McSherry: Creative. Art  :  Illustration  :  Design
The Studio, 17 Aideen Avenue, Terenure, Dublin 6W.  Ireland
+353 (0)86 247 0737   www.mcsherry.ie

160604_35%2Bicon%2Baffinity.jpg

Share this post


Link to post
Share on other sites
1 hour ago, kevinmcsherry said:

that there was a link

The whole life is a quiz (Hape Kerkeling). :-)

Share this post


Link to post
Share on other sites

if i build a icon set. I can't work with AD because of this problem. We are now at 1.7 and there is no improvements. 

Put this problem on top of our list and fix this, please

Share this post


Link to post
Share on other sites

I don't think this will ever get fixed. I think it was reported over 2 years ago and has literally been ignored completely.

Share this post


Link to post
Share on other sites

Hi raglet,
This hasn't been ignored. The dev team is well aware of this issue however they have been extremely busy with all changes required to ensure compatibility with the upcoming Affinity Publisher and with the Publisher's development itself. As soon as Publisher is released, eventual/initial issues resolved and the app stabilised we should get back to our usual pace and focus on fixing bugs like these which are not easy and require some effort and time to get right. Please bear with us.
 

Share this post


Link to post
Share on other sites

I can't wait to finally being able to ditch Adobe products! This stroke issue is the last thing keeping me using Adobe stuff. Please fix it!

Share this post


Link to post
Share on other sites
On 6/13/2019 at 11:36 AM, MEB said:

Hi raglet,
This hasn't been ignored. The dev team is well aware of this issue however they have been extremely busy with all changes required to ensure compatibility with the upcoming Affinity Publisher and with the Publisher's development itself. As soon as Publisher is released, eventual/initial issues resolved and the app stabilised we should get back to our usual pace and focus on fixing bugs like these which are not easy and require some effort and time to get right. Please bear with us.

A few bad apples don't necessarily ruin the whole basket. Besides, Rome wasn't built in a day, and that's why it's so beautiful. Good progress takes time.


The website is still a work in progress. The "Comics" and "Shop" sections are not yet ready. Feel free to connect with me and let me know what you like or what can be improved. You can contact me here, on my contact page, YouTube channel, or Twitter account. Thanks and have a great day!

Share this post


Link to post
Share on other sites

 Hello

I have the same problem since I update the Affinity.

As you can see I made the same operation and only mirroring the same perfect circle and ellipse.  I tried it with converting to curve, and with out, same problem. It is a big issue. 

Capture.JPG

Share this post


Link to post
Share on other sites
On 14. Juni 2019 at 8:14 PM, Bri-Toon said:

A few bad apples don't necessarily ruin the whole basket.

They do after so long time and bad PR is no help.

Share this post


Link to post
Share on other sites
On 6/13/2019 at 6:36 PM, MEB said:

Hi raglet,
This hasn't been ignored. The dev team is well aware of this issue however they have been extremely busy with all changes required to ensure compatibility with the upcoming Affinity Publisher and with the Publisher's development itself. As soon as Publisher is released, eventual/initial issues resolved and the app stabilised we should get back to our usual pace and focus on fixing bugs like these which are not easy and require some effort and time to get right. Please bear with us.
 

>Back to our usual pace
The "usual pace" that was before Publisher was announced/released was to also postpone this bugfix indefinitely.

How can a vector tool have its main vector function broken for so much time and yet still be kept under low priority?

Edit: wanted to make it clear, my current frustration is directed at whoever is managing the priority list, not you, a forum moderator, Meb.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×