Jump to content
MEB

Free Content included with 1.6 ('Till 16th November)

Recommended Posts

1 minute ago, Patrick Connor said:

That is strange, what is your default browser, and could you (temporarily) try a different one as your default perhaps?

I use Safari.  I can try something else.

Share this post


Link to post
Share on other sites
6 minutes ago, imdawat said:

Thanks but that did not help.

Please wait and we will try to address the lack of a feed this end tomorrow, by looking at the calls to the server and seeing which are not formatted as we would expect. I expect this to be sorted by tomorrow afternoon. In the mean time enjoy 1.6 and we will sort this as soon as we can. Sorry.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
Just now, darcik said:

I use Safari.  I can try something else.

Do you have any other browsers already installed, if not this may be tricky. Safari should be fine, so perhaps it is not that and installing a browser just for this seems like overkill. Please log out of the Affinity Store and try again, it may not like you being logged in.


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
3 hours ago, MEB said:

Hi brebro, MacGueurle,

Welcome to Affinity Forums :)

You're totally right. It's necessary to create an account for Mac users. Windows users just need to login with their existing account. I wasn't aware of these changes. My apologies for the mistake.

 

I'm correcting previous posts to avoid more confusion.

Where can i make an account ???  my existing is not working ??? 

can you give me an hyperlink ....  for the site.

thanks,

Share this post


Link to post
Share on other sites
10 minutes ago, Patrick Connor said:

Do you have any other browsers already installed, if not this may be tricky. Safari should be fine, so perhaps it is not that and installing a browser just for this seems like overkill. Please log out of the Affinity Store and try again, it may not like you being logged in.

No, I don't have another browser installed.  I've tried logging out, clearing my cache and closing/reopening Safari.  It keeps redirecting me to the home page.  

Share this post


Link to post
Share on other sites
1 minute ago, darcik said:

No, I don't have another browser installed.  I've tried logging out, clearing my cache and closing/reopening Safari.  It keeps redirecting me to the home page.  

Would you please make a new thread in Bugs on Mac as your issue may need some 1:2:1 support and is not what most users are experiencing. Hope that is OK


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites

Hi, everyone.

Installed the 1.6 version (in french), went to the welcome screen, clicked on "Free content/Obtenir" and...everything was OK.

Is it normal ?!!

Sorry for kidding ! But I wasn't obliged to change the language.

Share this post


Link to post
Share on other sites
3 hours ago, MacGueurle said:

I seem to be having problems getting the freebie stuff.

 

Problem is I receive updates via the Mac App Store but receive newsletters and have signed up to these forums using another email addie.

 

Tried both entering info from my Mac App Store login and forum login for the downloads, no go.

 

I then tried to reset my password but have yet to receive an email back on how to go about it. So, unless you guys are swamped in resetting passwords requests, I am wondering, do I have to create yet another Affinity account with a different password, entirely different from my Mac App Store, and Affinity forum ones?

 

Confused, I am...

i'm having the same issue - sudddenly my loggin not working & had to request a reset 2 hrs ago & but still no email to reset & unable to request reset again.  have never had trouble with my password before.   keep trying both Mac desktop & Mac laptop but A app telling me to read my email... that  i never got.....  and not seeing the option to download the freebies on iPad app......???? whats up??? :(

Share this post


Link to post
Share on other sites
8 minutes ago, Patrick Connor said:

Would you please make a new thread in Bugs on Mac as your issue may need some 1:2:1 support and is not what most users are experiencing. Hope that is OK

Yes, I'll do that.  Thank you.

Share this post


Link to post
Share on other sites
4 hours ago, Freek said:

Hi guys!

Thanks for the amazing update and the freebies. I also seem to be unable to access the free content though. My welcome screen is not showing the updated screen. And I am connected to the internet because I just posted this message ;)

 

Do I need to reboot or something?

 

You probably turned off the welcome screen (thats what I did).   just got to HELP menu and select Welcome.    Mine popped up after a second.   

Share this post


Link to post
Share on other sites

I tried it on my laptop with windows 10 and downloaded free content .... on pc with win 7 pro no ..... i would not know the reason honestly

Share this post


Link to post
Share on other sites
4 hours ago, MacGueurle said:

I seem to be having problems getting the freebie stuff.

 

Problem is I receive updates via the Mac App Store but receive newsletters and have signed up to these forums using another email addie.

 

Tried both entering info from my Mac App Store login and forum login for the downloads, no go.

 

I then tried to reset my password but have yet to receive an email back on how to go about it. So, unless you guys are swamped in resetting passwords requests, I am wondering, do I have to create yet another Affinity account with a different password, entirely different from my Mac App Store, and Affinity forum ones?

 

Confused, I am...

 

I was just as confused as you were but I got help. It looks like we old customers on the Mac, are regarded as new customers in this case. It is only Windows-users who have such an account from earlier. Perhaps it would be an idea with a little info about that somewhere?

 

Share this post


Link to post
Share on other sites
20 minutes ago, Joeri Lodders said:

Where can i make an account ???  my existing is not working ??? 

can you give me an hyperlink ....  for the site.

thanks,

 

Hi Joeri Lodders,

Please check the first post on this thread for details. It should clear things up. Let me know if you still have trouble then.

 

@Wilfred Hildonen

We have just posted detailed info here.

Share this post


Link to post
Share on other sites

Hi, hadn't been here in awhile but when I logged in, saw there was an update. So I opened AP (Mac).

 

No update dialog when I opened Affinity so I went to system prefs on my computer and checked for updates there (I noticed I had 'automatically update apps' unchecked) - it found the Affinity update, downloaded and installed. I then opened Affinity Photo and the free offer was there in the 'Welcome' area. Downloaded, success.

Share this post


Link to post
Share on other sites
2 hours ago, MEB said:

Hi darcik,

Welcome to Affinity Forums :)

If you have bought the apps thought the Mac App Store there's no way to link them to the Affinity Store account (we only sell the Windows versions there). To get the free extras just login in the Affinity Store with the e-mail/password you used to create the account then click your name in the top righ of the interface and select Downloads & Product Keys. You will find the links to the extras there.

I'm definitely confused. I own Affinity 1.5. I purchased my current Affinity photo and the designer applications through Mac App Store  since I'm a MAC user.

1st question - Do I get the upgrade to 1.6 for free or do I have to purchase this as a new program from the Mac App Store? The Photo was purchased in September 2015 but the Designer was just recently purchased June 2017.

2nd question - you mention that we need to create an account on Affinity website? How?

Thank you for any clarification you can offer.

Skitterbug

 

Additional info and success! After I asked my rather dumb question, I went back to the app store and took a good hard look at what I should do. I discovered that I only needed to hit the little command button and tell it to update my app. Then I hit open and my did that and the screen to the freebies opened. That's where I created my account and then I was able to download my content. This worked for both Photo and Designer. So thank you very much Affinity for developing an excellent program. I am anxious to see what the free stuff is. It downloaded to my computer and I still need to install it but I wanted to let the moderator know that I was successful!

Cheers ~ Skitterbug

 

Edited by Skitterbug
Added information to my post after successful updates

Share this post


Link to post
Share on other sites

Designer and Photo customer - MAC OS

After update, I am not able to see the offer on either app.  Is there a way I can activate the Startup Welcome screen manually?

 

Share this post


Link to post
Share on other sites
8 minutes ago, MEB said:

 

Hi Joeri Lodders,

Please check the first post on this thread for details. It should clear things up. Let me know if you still have trouble then.

 

@Wilfred Hildonen

We have just posted detailed info here.

 

Yes, I noticed it after I had already posted. Sorry about that but perhaps a good thing can't be said too often? :) I am a bit crosseyed and tired, but just one more thing: I have downloaded all the packs and then I tried to import the brushed into Designer, and there appeared popups saying they were added, but when I tried to check them out, I didn't see any new ones; neither new groups, nor new brushes in the existing groups.
I tried to install them again, just dropping them on the icon in Dock and again it looked like it worked - but I still can't see any new brushes. Now I have even updated the OS but nope. 

Perhaps I really am too tired, but this puzzles me. 

Share this post


Link to post
Share on other sites

Hi Wilfred Hildonen,

Affinity Designer has two brush engines. One vector based used in Draw Persona and the other raster based used in Pixel Persona (this last one also used in Affinity Photo). The brushes you are importing are probably raster based brushes and were added to the Brushes panel in Pixel Persona. Check there at end of the list.

Share this post


Link to post
Share on other sites

I just updated to Affinity Photo 1.6 and do not see the free bonus. I have disabled Antivirus etc., changed languages, and none of those solutions work.

Dan

Share this post


Link to post
Share on other sites

Same problem after updating Affinity Photo 1.6, none of the suggestions help. My first reply got into the wrong forum section, sorry about that.

 

Thanks,

Dan

Share this post


Link to post
Share on other sites

The problem is related to Internet Explorer 8 at least in my case on Windows 7. Everyone not seeing the offer go to Help(F1) and check if u are getting outdated browser message. If that's the case update Internet Explorer 8 to 11 thru Windows Update , etc. After that it can be again disabled thru Control Panel > Programs and Features > Turn Windows features on or off

 

screenshot.1509652782.png

Share this post


Link to post
Share on other sites

Good morning.

i got affinity photo since 10/08/17, i just updated to 1.6 but I dont see the "claim" button to download the free content, i tried the language workaround but didnt work, tried to add the startup panel but nothing, there is only the standard image with links to sample and tutorials.

Hope there will be an update about it. thx.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×