Jump to content
MEB

Free Content included with 1.6 ('Till 16th November)

Recommended Posts

3 minutes ago, Patrick Connor said:

Correct Alfred, I already modified point 5 while you were writing that. Although you are technically correct about the "existing user" option, choosing "New to Affinity" works for existing users too, after checking with the customer that they meant to use the existing account 

 

Thanks, Patrick. As noted elsewhere, the wording “New to Affinity” is less than ideal, since many Mac users have never used the Affinity Store but have used the Affinity apps since they were first launched.

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites
1 minute ago, Alfred said:

 

Thanks, Patrick. As noted elsewhere, the wording “New to Affinity” is less than ideal, since many Mac users have never used the Affinity Store but have used the Affinity apps since they were first launched.

 

Quite, I am asking for this to be changed 


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
1 hour ago, pleased2help said:

3)         Scroll along the top bar to HELP and then welcome, tick show on start up.

To clarify a bit, choosing "Welcome..." from the Help menu just displays the Welcome window if it has previously been set not appear on startup. The "Show this Panel on Startup" checkbox appears at the bottom of the Welcome window. You do not need to check it unless you want it to do that. You can always open the window at any time from the Help menu.

 

1 hour ago, pleased2help said:

6)         You should receive an email from Affinity store with the download links in. DON’T down load them from here

The order confirmation email will be sent after your order has been placed on the store checkout page. You should be able to download the freebies directly from the store page that should appear after you click the green "Place Order" button. If everything is working as it should you do not have to wait for the email confirmation to appear in your mailbox.

 

2 hours ago, pleased2help said:

10)       When you are signed in Click on your name at the top right, go to Downloads and product keys  and down loads should be there.

As far as I know, the Downloads & Product Keys page will not show your freebies order(s) unless & until you have successfully placed your order on the store checkout page, nor can you order them directly from that or any other page besides the one that appears after you click the green "Place Order" button.


Affinity Photo 1.7.2, Affinity Designer 1.7.2, Affinity Publisher 1.7.2; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.2.153 & Affinity Designer 1.7.2.6 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites

Doesn't seem to work for me. (on a mac, purchased through the app-store) – No "claim bundle" in the welcome-splash (changing the language-setting didn't help), no way to register (there's no "new to affinity")-link, it's a bit of a "no nothing" :-(

Thanks for helping one more lost soul... ;)

david

Share this post


Link to post
Share on other sites
27 minutes ago, davery said:

Doesn't seem to work for me. (on a mac, purchased through the app-store) – No "claim bundle" in the welcome-splash (changing the language-setting didn't help), no way to register (there's no "new to affinity")-link, it's a bit of a "no nothing" :-(

The splash screen that appears during the launch of the app is not the same as the Welcome window. If you do not see that window after the app has launched, try going to the Help menu & selecting the "Welcome..." item on it.

 

In that window there should be a large scrolling panel on the left, with one of its 3 slides showing a "Claim" button. If that area just shows an Affinity app icon on a black background, it usually means something is blocking the connection to the Affinity servers that provide the content of these slides dynamically to the app.


Affinity Photo 1.7.2, Affinity Designer 1.7.2, Affinity Publisher 1.7.2; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.2.153 & Affinity Designer 1.7.2.6 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
5 minutes ago, R C-R said:

The splash screen that appears during the launch of the app is not the same as the Welcome window. If you do not see that window after the app has launched, try going to the Help menu & selecting the "Welcome..." item on it.

 

In that window there should be a large scrolling panel on the left, with one of its 3 slides showing a "Claim" button. If that area just shows an Affinity app icon on a black background, it usually means something is blocking the connection to the Affinity servers that provide the content of these slides dynamically to the app.

 

R C-R, thanks for the reply, but...

I have the Welcome-Window, with 3 panels, in front of me. None of them display a "Claim"-btn. There are just the usual "praise"-slogans (so no black screen due to blocked content either).

But – I'm on a MacBook Pro 17' running Mac OS 10.11.6, and Affinity Photo is 1.5.2, no update available. is _this_ the problem?

 

thx

 

davery

Screenshot 2017-11-05 14.53.17.png

Screenshot 2017-11-05 14.53.37.png

Screenshot 2017-11-05 14.53.55.png

Share this post


Link to post
Share on other sites
Just now, davery said:

But – I'm on a MacBook Pro 17' running Mac OS 10.11.6, and Affinity Photo is 1.5.2, no update available. is _this_ the problem?

Yes, that is the problem. You must update to the 1.6.6 version first. To do that, open the App Store from the Apple menu, click on the "Updates" tab, & you should see Affinity Photo listed with a button next to it that will update your version to the new one.

 

If you do not see this, make sure you are signed into the Mac App Store with the same Apple ID you used when you bought Affinity Photo.


Affinity Photo 1.7.2, Affinity Designer 1.7.2, Affinity Publisher 1.7.2; macOS High Sierra 10.13.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 1.7.2.153 & Affinity Designer 1.7.2.6 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iOS 12.3.1

Share this post


Link to post
Share on other sites
18 minutes ago, R C-R said:

Yes, that is the problem. You must update to the 1.6.6 version first. To do that, open the App Store from the Apple menu, click on the "Updates" tab, & you should see Affinity Photo listed with a button next to it that will update your version to the new one.

 

If you do not see this, make sure you are signed into the Mac App Store with the same Apple ID you used when you bought Affinity Photo.

 

Aah, finally, all is fine! For some obscure reason, app-store.app didn't display the "update", so I assumed I already did it.

Thanks, and sorry for bothering you!

best

davery

Share this post


Link to post
Share on other sites

I'm confused as hell too. Got 1.6 from the App Store (Mac). No welcome screen links (I have the welcome screen), so I created a store account which was confusing as you can't actually do that without seemingly buying something. I obviously cancelled my order before hitting confirm hoping the account I created would still work. It seems so however there is nothing showing in my downloads section in my newly created account?!

 

It was a pain in the ass claiming the brushes last time round. What gives guys? :(

 

 

Share this post


Link to post
Share on other sites

I was able to register and get the access page to download the updates and freebies. The updates worked fine, but the freebies, after a long period downloading, give me "Download Error" when I try to open them. Suggestions?

 

OK now. I had gone to preferences to add English language as other posts instructed. So I'm good now!

 

Edited by matherjcan
Solved problem

Share this post


Link to post
Share on other sites

Hi Meb, all the problems made the firewall even in the off state. Reinstalling W7 helped me not only with this problem. Thanks Meb for your effort to help. Good evening for everyone. ))

Share this post


Link to post
Share on other sites

I thanked the person who posted a direct link to the store.

The link solution worked for me but I keep getting mail everytime anyone posts in this thread and see no way to disable all these unecessary emails.

I guess you can only do that with a new post. So that's what this is.

 

Share this post


Link to post
Share on other sites
10 minutes ago, drdancm said:

I keep getting mail everytime anyone posts in this thread and see no way to disable all these unecessary emails.

 

Click on your username in the top right-hand corner of this page, and then click on 'Account Settings' in the menu that drops down. On the Settings page, go to the 'Other Settings' pane on the right and click on the Notification Settings link. After adjusting the settings as you wish, press the 'Save' button.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

I purchased both programs from the app store.  After reading the comments, I have uninstalled and reinstalled both Designer and Photo but do not see the link for free content.  I am running OS X 10.7.5 with Safari 6.1.6 and cannot install the latest version of Chrome.  Also, my computer is not capable of running Firefox.  Does running an older version of OS matter?  Are there any alternatives for me to obtain the free content? 

 

Thanks in advance for any assistance provided. 

Share this post


Link to post
Share on other sites
1 hour ago, Penthief said:

I purchased both programs from the app store.  After reading the comments, I have uninstalled and reinstalled both Designer and Photo but do not see the link for free content.  I am running OS X 10.7.5 with Safari 6.1.6 and cannot install the latest version of Chrome.  Also, my computer is not capable of running Firefox.  Does running an older version of OS matter?  Are there any alternatives for me to obtain the free content? 

 

Thanks in advance for any assistance provided. 

Hi Penthief,
I'm running 10.8.5 and having similar issues. When reading through this posts here, it seems that older OS X versions as 10.7 or 10.8 having this kind of issues. I have also Firefox installed besides Safari 6.2.8. I already updated the apps, deleted and re-installed them, made sure, the firewall is deactivated - but the start-up screens are not updating.
I think we have to wait until Affinity solved that problem...


☛ Affinity Designer 1.6.1 ◆ Affinity Photo 1.6.7 ◆ Affinity Publisher Beta 1.7.0.192 ◆ OSX Yosemite

Share this post


Link to post
Share on other sites
1 minute ago, Penthief said:

Hopefully, they can address it before the free content is gone.

 

Since the problem is of their own making, one would hope that the offer will be extended.

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hey guys, congrats on 1.6 and thanks for the freebies! :D

However, the chalky fonts and textures are downloading reeeeaaaally slow (like 9kb/s) while Steam is downloading normally at 5mb/s, so it's not something on my side. Donno if it's something you can fix at all, just wanted to let you know.

 

Thanks!

Share this post


Link to post
Share on other sites

I've purchased Designer from the Apple Store and I didn't receive the update or the free content. I open the firewall to the (Designer) program with no luck. How do I receive the update and free content?

Screen Shot 2017-11-05 at 7.16.39 PM.png

Share this post


Link to post
Share on other sites

Hallo there Affinity team,

I have updated to Affinity 1.6.0; have the Welcome screen open when Affinity start up but it only partially starts up. 

I am running Internet Explorer 10, please help!

 

Welcome screen.jpg

Share this post


Link to post
Share on other sites

Hello everybody,

 

I have found this solution to get the free content : completely uninstall Affinity for mac (with "CleanMyMac"). Then, at the "first launch" I have seen the welcome screen with the link.

 

Bye from Paris...
 

Eltigrou.

Share this post


Link to post
Share on other sites
18 hours ago, MacHolgi said:

Hi Penthief,
I'm running 10.8.5 and having similar issues. When reading through this posts here, it seems that older OS X versions as 10.7 or 10.8 having this kind of issues. I have also Firefox installed besides Safari 6.2.8. I already updated the apps, deleted and re-installed them, made sure, the firewall is deactivated - but the start-up screens are not updating.
I think we have to wait until Affinity solved that problem...

 

19 hours ago, Penthief said:

I purchased both programs from the app store.  After reading the comments, I have uninstalled and reinstalled both Designer and Photo but do not see the link for free content.  I am running OS X 10.7.5 with Safari 6.1.6 and cannot install the latest version of Chrome.  Also, my computer is not capable of running Firefox.  Does running an older version of OS matter?  Are there any alternatives for me to obtain the free content? 

 

Thanks in advance for any assistance provided. 

 

It would appear that the feed does not appear on Lion or Mountain Lion, as it requires TLS 1.1 and 1.2 which is only supported be default from Safari 7 onwards.

I do not think that the feed can be made to show for you, sorry.

 

Please can you Email AffinitySupport@serif.com directly and we will sort the content out for you directly.  Please reference your post in this thread and explain which Mac OS you are using and that it has Safari 6. 

 

To other readers of this thread with Internet Explorer 8 on ie7, rather than update to a later Internet Explorer, you can turn on TLS 1.1 and TLS 1.2 support in Internet Explorer's "Advanced Settings" and the feed will appear next time you start Affinity.


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
1 hour ago, pixelschubsen said:

Hi Guys,

 

my downloads of the freebies broke - and when I try to reload the cart says its is already in use...

 

cheers px

 

pixelschubsen,

 

Welcome to the Serif Affinity Forum. 

There is no need to claim again. Simply redownload from your account downloads page.

 

https://affinity.store/account/downloads


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×