Jump to content
fixme12

Affinity Designer Print Bug (second time print, same file)

Recommended Posts

I've got a problem when printing same file.

first time i do the print (second picture) menu >> File >> Print (and i see the preview of what's going to print), no problem it print like it have to print
second time (first picture) i'll do the same steps again, menu >> File >> Print (there is a white preview) now when i start print i only get some miniatures of the print on the page and the scale is completly wrong

(i changed no settings at all!)

affinity_bad.jpg

affinity_good.jpg

Share this post


Link to post
Share on other sites

Hi fixme12

 

In your screenshot with the blank preview, the paper size has change to custom 0x0mm. changing this back to be defined by driver will probably let it print properly again. I'm not sure why it would have changed to this though are you able to provide the file for us to look into at all?

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites
On 30-10-2017 at 11:12 AM, Chris_K said:

Hi fixme12

 

In your screenshot with the blank preview, the paper size has change to custom 0x0mm. changing this back to be defined by driver will probably let it print properly again. I'm not sure why it would have changed to this though are you able to provide the file for us to look into at all?

 

Cheers

 

Hi, here is the file i've got printing. First time no problem. Second time same steps, nothing of settings changed.

So it automaticly changes the paper size as i don't touch anything as menu  file >> print and press ok to print.

OK_paint_HERMA-9642-40x40.afdesign

Share this post


Link to post
Share on other sites

Hi fixme12

 

Thanks for the file. This seems to be working fine for me here though. This may perhaps be something with your printer driver and our app. 1.6 has just been released, can you download that and give it another try to see if it solves your issue?

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

I have a very similar problem which is still present on Vn 1.6.  First print is fine, second shrinks the whole page into the top left quarter (and yes, page size has gone to zero).  Happens with three different print drivers (Dell 1320c, Ricoh Aficio, and PDF24), I can reproduce it simply and repeatably by starting AfD, New A4 document, drawing a rectangle to cover most of the page, File/Print Select driver, OK. Now repeat File/Print, DO NOT reselect driver (leave it unchanged).  Settings have changed to 0 x 0 mm, preview is blank, but will print in top quarter of page.

Share this post


Link to post
Share on other sites

This bug has been present in 1.5.0, 1.5.1, 1.5.2, 1.5.3, and is still present in 1.6.0.89.  I first reported it months ago but had absolutely no response, and the report seems to have dropped off the radar.  A couple of weeks ago I added confirmation (above) that it is still present, and gave a simple way to reproduce it. (I am using Win 7 by the way).  I seem to have been ignored again.  Is anybody reading what I have posted??  Just to know that you've seen it, even if you don't have a fix in view would still make it a lot less frustrating.  Thanks.

Share this post


Link to post
Share on other sites

Hi Keith.M,

This issue has been logged to be looked into. Looks like we missed your original post on the main release thread. For the best response please log issues in their own thread as this makes it easier to track for us.


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

If it helps, I see the same thing happening with AP Beta 1.6.1.93.

It does not matter what image or images are used. The first time I print an image from AP the print operation works fine. The second (3rd, etc.) time I print in the same AP session, whether I print the same image or a different one, the print dialog's Layout section has changed to a custom paper size with width 0px and height 0px.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

" This issue has been logged to be looked into " - Wow, I just feel so much better now.  I'm sure you'll sort it, it was just the silence that was hard to put up with.  Thank you.  PS - apart from this I love the Affinity programs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×