Jump to content
dna.x

Affinity just deleted or corrupted my image

Recommended Posts

I am under deadline to get a dozen images finished. I worked for hours on this image, until the wee hours of the morning. I just finished with a mask, I had several layers of background textures with different blend modes and opacity that I was finally happy with. I was minutes away from finishing, I may only have added a subtle vignette and something happened that closed my document and brought me back to the project group I had been working in. The image I had been working on was now showing in the thumbnails as the original image, without the background and mask (i.e. without all the hours of work I had done). When I clicked on it to load it up and continue working now I get this "failed to load" error (see screenshot of the thumbnails within my project, the corrupted image is the one of the top row right-most image, it should have a textured background behind it, that is gone and the image is corrupted). The odd thing is that the thumbnail for this image is now appearing both inside and outside the project (it was only inside the project before). In both cases I get the same error message. I don't think I have to explain to anyone how incredibly frustrating and stressful that is!

 

I'm not sure exactly what happened. I had just finished the mask I had been working on. I was zoomed in to work on the mask, very fine detail to include bits of hair sticking out. I tapped twice with two fingers to zoom out. I saw the contextual menu flash onscreen and then disappear. The only thing I can think is that it flashed onscreen and on my second tap my fingers must have landed on the delete button. If that is what happened, the fact that hours of work, your entire image, can be deleted in a nanosecond, in the brief lagtime it took Affinity to respond is frightening.

 

I have never done a delete through the contextual menu that pops up over the image, so I don't know how it normally responds. If I was working on a mask, that was the active layer, and if I were to click that delete button, would it delete the entire affinity document and close down that document I was working on? It looks like Affinity Photo corrupted this document, and lost all my work. I have just tried selecting a mask in another similar image that I duplicated, tapping to get the contextual menu, and intentionally pressed the delete button. It just simply deletes the mask layer, leaving everything else untouched and fine. So... it looks like Affinity Photo just corrupted my image and completely lost it. 

 

Bad, bad user experience! This happened literally in the blink of an eye. It's scary that Affinity can lose hours of work in a split second.

 

Is there any way this image can be recovered? I am not using iCloud on my iPad, for a number of reasons it does not work for me, so there is no backup there. There is no way I remember all the texture layers I used (I experimented with adding and deleting some), not to mention the blend modes and opacity on each. 

 

This is such a bad experience it makes me question whether the app is production quality. I really don't want to have to complicate my workflow and make things confusing with having to close the image and create a duplicate all throughout the process so at least I can recover part of the work I did if this happens again.

 

A second, far less dangerous bug I have been noticing is that when I use the clone tool where I have to select the source, it pops up the circle that acts like a loupe, zooming into the area you have just selected. As you can see from the other screenshot I attached, this circle/loupe stays even when I move to a different tool. I think I even went into different personas trying to get rid of it. Closed and opened the image. I had to quit the app and relaunch it to finally get rid of that. This has happened to me previously too. 

IMG_0359.PNG

IMG_0415.PNG

Share this post


Link to post
Share on other sites

Hey dna.x,

 

Usually when you get that error message, exiting the app and loading it up again will recover the document. Is that not the case here? I'm not entirely sure why it would have done that though.

 

I put an improvement in to move the context toolbar from a 2-finger tap slightly out the way because I have also accidentally done a double 2-finger tap and caught the Delete button. This is recovered from the History Panel or an Undo, usually. 

 

We know about the circle getting stuck on the document. It's easy to reproduce and I believe we've had this fixed for the main desktop apps so this should make its way to the iPad version soon.

Share this post


Link to post
Share on other sites

Hi Chris, thanks for your reply.  Nope, quitting the app and loading it again I still had the same issue. However I found that if I duplicate the file, the duplicate is fine and has all the layers and masks.  So that was a HUGE relief. I'm glad I had that intuition to try it in order to see what happened! I almost deleted the corrupt file, but thought I would just try duplicating it first. I'm glad I did. I hope anyone else who has the problem manages to find out that they can recover from it this way, or like you say quitting and relaunching the app. 

 

This has also happened to me a second time, just today. Again I duplicated the file and was able to open that and all the layers and work I had done were there. So this time I know for certain that I did not accidentally click on anything in the contextual menu. The menu didn't appear this time. Again it happened when I was trying to double-tap with two fingers to zoom out (or in, I can't remember). 

 

That's great that the circle getting stuck bug fix is on it's way. A small thing but it's really annoying, and a bit confusing for someone relatively new to the app like me. And of course, if it happens to be over an area that you are trying to work on it's more than just annoying. 

 

Thanks for your reply, and please let people know that if they experience the corrupt file and quitting and relaunching doesn't help, try duplicating the file and opening the duplicate.

Share this post


Link to post
Share on other sites

The duplicated file opening is extremely odd... I think I need to speak with dev about this as I've been speaking to another user who had the same message but duplicating it didn't work. We obviously need to figure out why these files are becoming corrupt in the first place. There was a discussion about adding a feature that allows users to send their documents to development when they become corrupt.

 

I'll fire an email over with this thread and the other one and see what can be done to prevent or help this type of situation. 


Thanks :)

Share this post


Link to post
Share on other sites

I'm having the same issue.

Random image open failures. 

I tried to open a file I haven't worked on for a couple days and got a "Loading Failed" message.

Duplicating the image a couple times produced the same result.

This is quite disappointing.

 

Version 1.6.5.61 on an 12.9" iPad Pro with 512gigs. iOS version 11.0.3.

 

I would also like to know how to recover the image.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.