Jump to content
Birder

AP keeps selecting the eraser tool on my Huion GT221

Recommended Posts

anyone ever find a fix for this?
I have a hunion gt191 and only get this issue with Affinity Photo and no otehr software.
Seems like this issue has bee n happening for a couple years and yet no fix?
Very frustrating and annoying.
If we cant get fixes for things like that then adobe will always win with their stupid prices because people NEED software that works.
Currently having to go back to Photoshop to actually be able to do work because i cant use affinity with my tablet any more.

Share this post


Link to post
Share on other sites

Hey just wanted to make an update. 

Nothing currently works for this. I thought I had fixed the issue by reinstalling the drivers but it ALWAYS reverts. I HOPE Affinity can fix this issue. Please look into it guys. Just use a 191 or a 221 and move the pen far off of the tablet and back on and it will automatically choose the eraser tool.

Share this post


Link to post
Share on other sites

I too was experiencing this issue, but with an XP-Pen Deco Pro, using the latest driver on macOS Mojave. The tool would switch from brush to eraser, in Affinity Photo and Designer without explanation, and drove me bananas!

My solution was to reset the pen barrel buttons back to default settings using the XP Pentabletsetting app, and that seems to have fixed it. Not had any issues since. Might be worth trying.

 

 

Share this post


Link to post
Share on other sites

TL-DR: solution is in the button settings of the tablet - problem is caused by the definition of the Pen/Eraser toggle

I got a XP-Pen Artist 13.3 Pro as a birthday present and boyohboy, was I happy! Until my brushes and other tools in Affinity Designer mysteriously kept on changing to Eraser. This behaviour came and went, but it seemed pretty unpredictable.

I’m using Affinity Designer 1.7.3 on a 2018 MacBook Pro, but after a bit of googling I found out that Windows 10 users and Huion tablet users and Affinity Photo users also have this problem. I tried a few things an this was NOT helping: removing and reinstalling drivers, removing Wacom drivers (although that did solve other problems), messing with all kinds of keyboard shortcuts and switched in the AD menus, banging my head on my laptop.

I carefully observed what was going on.

In AD’s Pixel Persona:

Unwanted behaviour: removing the pen away from the screen in any tool mode (brush, hand, smudge, etc) and moving back to the screen results in changing to the eraser tool when the pen is about 2 cm away from the screen.

In AD’s Designer Persona:

Unwanted behaviour: removing the pen away from the screen in any tool mode (pen, rectangle, text frame, etc) and moving back to the screen results in adding a mask layer when the pen is about 2 cm away from the screen.

At some point I found a foolproof way of starting and stopping the unwanted behaviour. The unwanted behaviour starts by pressing the second barrel button of the pen, putting the tablet in Eraser Mode. By default the setting of the second barrel button is Pen/Eraser, as defined in the PenTabletSetting application of my XP-pen tablet. Let’s call this Tablet Eraser Mode, to distinguis from Application Eraser Mode, that is when you use the eraser from the tools section in Affinity Designer.

Tablet Eraser Mode also activates Application Eraser Mode. Now if I switch to another mode in the application, for instance to the brush, I leave Application Eraser mode, but stay in Tablet Eraser Mode. As long as I’m in Tablet Eraser Mode, whenever the pen tip connects to the tablet surface again (at about 2 cm from the surface), this signals Affinity Designer to go into Application Eraser Mode.

The unwanted behaviour stops when I press the second barrel button again, leaving Tablet Eraser Mode and going into Tablet Pen Mode. Now when the pen tip connects to the tablet surface again nothing happens.

The documentation of my tablet says: ”Pen/Eraser Toggle - With the stylus in range of the Artist12 Pro, 13.3 Pro & 15.6 Pro’s working area, press the assigned barrel button to toggle between pen and eraser modes in compatible drawing software. The current mode will briefly be displayed on your monitor.”

OK, what is compatible drawing software? That’s Photoshop. Now Photoshop has a funny way of toggling between brush and eraser: when you’re using the brush you can erase by holding the E key. On releasing the E you’re back with the brush again.

This got me thinking that the Pen/Eraser setting of the second barrel button might do just that: when in Eraser Mode it emulates holding the E. So whenever the pen reconnects: EEEEEEEE, driving me and many others nuts by selecting the eraser in the Pixel Persona again and again.

Now if this is Photoshop’s way of handling that toggle, Huion might have implemented the same setting. Since tables aren’t that different from each other, technically being part screen and part keyboard, it’s not that strange to have the same unwanted behaviour in both XP-Pen and Huion. Since this is all on the tablet side, it’s not that strange it affects Mac and Windows users alike.

This solution seems to work for me: in Affinity Designer I pressed the second barrel button until I was sure I was no longer in Tablet Eraser Mode (testing it by selecting other tools and repeatedly lifting and putting my pen to the tablet again. Then I changed the setting of the second barrel button to No Action in the PenTabletSettings application.

Changing the setting of the second barrel button to No Action when the tablet is still in Tablet Eraser Mode does not help. The tablet is then stuck in endless Tablet Eraser Mode.

I do hope this does help others and this provides the Affinity devs with enough information to think of a fix.

Share this post


Link to post
Share on other sites

Wow. Really useful, thanks a lot, AnnieW (wacom user not having a XP-PEN, but not discarding purchasing one of their tablets at some point). Alternative brands should reward these researches somehow (I've done sth of the kind on the past... anyway, it's nice to solve problems :D , even without payment --er, apart from some talks with Parblo and Dell which did not reach farther--, hehe). In the past, brands like these most typically would all use a same hardware base, yes, better said, re-branded from UC-Logic or dunno what. Not sure how it's done today, though, as every model seems to behave very differently in reviews and serious tests. 


AD, AP and APub.  Ryzen 9 3900X, 32 GB RAM, GTX 1650 4GB, 500GB m.2 SSD, 1TB HDD 7200rpm. Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites
On 7/20/2019 at 3:10 PM, markentingh said:

I have an XP-PEN 22e Pro and I've noticed that whenever I move my pen away from the screen, then bring the pen back towards the screen to the point that the screen can detect the pen movement, Affinity Designer switches to the eraser tool. There is no way to fix this issue it seems.

I have and XP -Pen device tablet as well and mine reacts exactly the same way.  Other members with other devices seem to be having the same issue.  I've tried several suggestions and it seems that none of them are fixing the issue.  It would be great if we could get this fixed.

Share this post


Link to post
Share on other sites

In the end I returned my XP-Pen Deco Pro as it was within the return window, and instead purchased a Wacom One, which works the way it's expected to. My previous tablets have all been Wacom, so it looks like I'm sticking with this!

Share this post


Link to post
Share on other sites

Just bought an XP PEN DECO 01 V2. Same issue of defaulting to eraser.

If there's still no solution, I'll return it. Sad that this is hanging out there after all this time.

Share this post


Link to post
Share on other sites

Solution to the Brush->Eraser issue, with assistance from XP Pen Chat: In System Preferences/Security & Privacy/Accessibility,  one needs to install both PenTabletSetting.app and PenTabletDriverUX.app to control your computer. I only had the first. Instructions here- https://drive.google.com/file/d/11D3K122abipu3FlUGo5gXZJ_gu-nPSi-/view

though I'm not certain I did it this way. I hope this works for others as well.

Share this post


Link to post
Share on other sites

Amazing, thanks.  :)


AD, AP and APub.  Ryzen 9 3900X, 32 GB RAM, GTX 1650 4GB, 500GB m.2 SSD, 1TB HDD 7200rpm. Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.