Jump to content
Mark Ingram

Affinity Photo Customer Beta - 1.6.0.86

Recommended Posts

Click here to download the latest beta

 

Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, issued when Windows Affinity Photo version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed batch processing failing to complete parallel jobs 
  • Fixed Swatches 'Set as default for' not working properly
  • Fixed Quick Mask 'Show as Transparent' not showing the mask
  • Fixed Slices Panel not updating when ticking/unticking slices
  • Fixed missing Copy cursor when dragging Macro between categories 
  • Fixed anchor point box moves when clicking Flip Vertical 
  • Added SVG import of CDATA text
  • Fixed Focus Merge discarding images and producing poor results
  • Fixed Text nodes clipping against its curves when output to PDF if it has a live filter applied to it
  • Fixed raster brush nozzle being barely visible in preview from a tablet device 
  • Fixed live filters not printing flattened when applied to vector objects
  • Fixed Refine Selection  undo then brushing results in lag
  • Fixed Refine Selection undo doesn't work when used for a second time
  • Fixed Selection Refinement preview for when the reference image is an image (not a pixel layer)
  • Fixed Selection Refinement preview to be more like the result of applying
  • Fixed brush dynamic for Direction being inverted 
  • Fixed pixel layers copy/paste pasting to the top-left of the node, rather than any active selection area 
  • Fixed incorrect background colour after closing a document
  • Improved performance of waterfall colour choosers
  • Fixed sporadic crash in tone mapping (affects HDR Merge, etc)
  • Fixed Develop Persona Chromatic aberration interfering with noise reduction
  • Fixed crash creating 1 x ( > 1024) pixel document 
  • Fixed Hard edges appearing in Depth of Field filter
  • Fixed RAF images opening distorted and cropped
  • Fixed Develop Persona presets not working for non-basic panels 

Share this post


Link to post
Share on other sites
14 minutes ago, Mark Ingram said:

Fixes

  • Fixed pixel layers copy/paste pasting to the top-left of the node, rather than any active selection area 

Bless you!

 

_Thanks Set 2.GIF

_Thanks Set 1 (1).gif


Affinity Designer 1.7.1.404 & beta 1.8.0.486   Affinity Photo 1.7.1.404 beta  1.8.0.486 Affinity Publisher 1.7.0.422 beta  1.7.2.458

Windows 10 Pro 64-bit 1709

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites
On 10/20/2017 at 5:54 PM, Pojal said:

Hello
In beta version 1.6 RAW files open slightly  faster but editing them is slower and processor load is bigger

Confirm.Editing process now is a pain.

PS. Deleted Affinity Photo folder in %AppData% and now lags while editing are almost gone. But it seems previous beta version worked better anyway.

Share this post


Link to post
Share on other sites

Thank you!  The FilterMeister preview issue seems to have been fixed.  :12_slight_smile:

An error still pops up when a filter is reopened:  Aborting X86_call_fmf1 -- code not valid.  But the filter proceeds to work.  I understand that it has to do with initializing variables; will have upgrades available soon.

—Russell

http://www.russellcottrell.com/RCFilters/index.htm

Share this post


Link to post
Share on other sites

just finished an edit session and also re-edited a couple of images I had a lot of stability issues with using .85. Very happy, this version feels like a release candidate

Regards

Share this post


Link to post
Share on other sites
developing raw files Canon 1D X.
Snapshots at the opening look underexposed.

 

The problem with the transfer of blue.

an example of a real image.

IMG_315.thumb.JPG.23004daaf3e4409b4941e1700dd28851.JPG

Share this post


Link to post
Share on other sites

Sadly plugin  Filter Forge6 still does not work in this beta version.  John


Please be aware that NSA/GCHQ are probably admiring my sent images

Share this post


Link to post
Share on other sites

Selecting a Lens Filter, clicking on the filter colour and having the setting on "Tint" the sliders always return to their initial setting. (Tint slider as well as noise slider).
I guess it's a bug ...


iCore i7-3770, 3.50GHz, 32GB RAM, SSD, NVIDIA GeForce GTX 1660 Ti, Windows 10 Pro - AP, AD and APublisher latest final & beta
http://www.timobierbaum.com

Share this post


Link to post
Share on other sites

Opening a new RAW file and switching to the Tone Mapping Persona takes over 30 seconds to process ... and to be able to continue working.


iCore i7-3770, 3.50GHz, 32GB RAM, SSD, NVIDIA GeForce GTX 1660 Ti, Windows 10 Pro - AP, AD and APublisher latest final & beta
http://www.timobierbaum.com

Share this post


Link to post
Share on other sites

Performance of the healing brush when using "Current layer & Below" is still unbearable.

Shadows & Highlighs live filter still reverts Shadows Range to 50 %.

New: The Blend Ranges dialogue is flawed, as soon as there are 3 or more points to define a custom blend range the corresponding values cannot be entered manually as the boxes for the input and output values are greyed out (screenshots attached).

Blend_Range_2_Points.png

Blend_Range_3_Points.png

Share this post


Link to post
Share on other sites

Found that guides are invisible on the edge of the opened document or outside of it. Move tool can grab it and move. But what to do with outer guides? It would be much easier to navigate if guides were visible.

Screenshot from 2017-10-25 15-03-24.png

Share this post


Link to post
Share on other sites
Wacom. The cursor of the tool of clarification and darkening brakes even if you do not press. The tool brush does not brake the brush. If you use it, then everything is OK, and if the tablet, then very strong brakes. When I work with AP, I put the tablet aside :(

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

 

It's already available in the current beta.

Thanks! Couldn't find it in the release notes but maybe I didn't look hard enough... :)

Share this post


Link to post
Share on other sites
On 24/10/2017 at 1:40 PM, DarkClown said:

Selecting a Lens Filter, clicking on the filter colour and having the setting on "Tint" the sliders always return to their initial setting. (Tint slider as well as noise slider).
I guess it's a bug ...

I'm not convinced Tint should be there. It's either broken on Windows or missing from the Mac version. I'll pass this to dev though. Thanks DarkClown :)

Share this post


Link to post
Share on other sites

Beta 1.6.0.86 - Still there is no rotate (clock/anticlock) function in desktop :(
I do hope that concentrating on Affinity Photo for iPad you will not forget about desktop... ;)


Affinity Photo 1.7.2.471;
GIMP 2.10.8, RawTherapee 5.5, Darktable 2.6.2;

Win10Pro (v. 10.0.17763), IntelCore i7-4790-3.60GHz, ram 8GB, , ssd 256GB, Huion new 1060plus;
Monitor 2D FHD LG 1920 x 1080 px, Onboard Intel Graphics HD 4600.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.