Jump to content

Recommended Posts

Hi peterdanckwerts,

Welcome to Affinity Forums :)

I never saw this before. Does this happen consistently with the same RAW files (or files from a specific camera) or it's random?

Can you upload the RAW shown in the screenshot above using this link for us to try to reproduce this here?

Link to post
Share on other sites
  • 3 months later...

I'm experiencing this too (High Sierra, Fuji X100F RAWs). For me, this seems to be associated with using the Apple RAW engine (selected via the "Assistant" menu in the Develop persona). It went away when I switched back to the Serif engine, though that might be co-incidence. 

 

The image opens fine for me via OSX's quick look feature, as well as in the Preview app. I've also seen the doubling change for the same image (eg. I had one occurrence where the image was duplicated into the top left corner, and another one where the bottom half was repeated one on top of the other). So I suspect this isn't a case of file corruption.

Link to post
Share on other sites

Thanks. From the info above this seems to happen on High Sierra using the Apple (Core Image RAW) with some cameras (Fuji X100F, Fuji X-T2, Panasonic DMC-TZ100 at least). Has anyone checked or is running the latest Photo Beta? Is this happening there too? I will try to reproduce it here and fill a bug report.

Link to post
Share on other sites
  • 3 weeks later...

I first saw this issue last fall, I believe - unsure what version I was on then.  It has been very hit or miss for me. Sometimes restarting my MacBook works for awhile, sometimes not.  Not every RAW file fails.  I have never seen it with the Serif RAW engine, though. 

 

I made some some posts at that time, I will search for them. 

 

Hope this helps - and glad to hear it was logged, though I thought this had already occurred. 

 

B.

Link to post
Share on other sites

I am also having this problem with .ORF files from an Olympus TG-4. Running Affinity Photo 1.6.7 on High Sierra 10.13.3. Restarting AP and restarting Mac makes no difference. Using Serif to process raw rather than Apple seems to "solve" the problem but I prefer the Apple algorithm, so it would be awesome if this could be fixed. Happy to provide any further details and sample files that might help. Thanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.