Jump to content

Export Slices @ 2x Freezes Affinity

Recommended Posts

High Sierra:10.13 (17A405)

iMac (Retina 5K, 27-inch, 2017), 16Gb

Affinity: 1.5.5


This happens seemingly randomly and sadly I can't find a reason for it.

Some Affinity projects will freeze the app with the beachball when you go to export slices.

It only happens if the slices contain a @2x  scale factor and a Force Quit is required when this happens.

I would attach a crash report but sadly there are none from Affinity in my logs folder yet.


I'm seeing this quite often with several different new Affinity projects since High Sierra was installed on my machine.


Share this post

Link to post
Share on other sites

Hey ParanoidAndroid,


I've had a go this morning and it seems okay, but like you said it seems random. Because we can't find a recipe, I'd recommend either waiting for 1.6 to be released on the Mac App Store or grab the beta and work with that. If you decide to do the latter, just make sure to keep regular backups, especially for client work. 

If you can reproduce it on 1.6 then we need to take another look. 

Share this post

Link to post
Share on other sites

Thanks for getting back, it's happening so often now Affinity it's getting impossible to export slices in multiple resolutions. 

Complete beachball spinlock freeze after selecting a location to save the slice and pressing the save button. 

Worse than that, after force quitting Affinity it sometimes leaves a ghost window on screen.

Still no crash logs, I think it's because I have to force quit Affinity before it gets to finish exiting.


Some observations

- it seems related to the size of the artboard. I'm mainly using iPad Pro device size ( 1732 x 2048 ) @ 144 dpi.

- it seems to occur more often when saving groups of small icon sized slices from this large art board.

- it only happens if there is @2x slices in the group being exported.


I'll take a look at that beta ..  ( if I can find where to download it )  ... [edit] Found it, downloaded will give it go.. :)


thanks again


Share this post

Link to post
Share on other sites

Update :)


So the same problem in the beta.

But I've found the cause, or at least the combination of causes. 

On my system I often run the PathFinder app by CocoaTech  ( v7.6.1 )

When path finder runs it totally replaces the standard Finder. 

I use it because I'm a developer and I find it very useful.

However it seems Affinity is doing something during the save process that causes it to freeze if Pathfinder is running. 

( Or if the Finder is not running )

This is very odd as, as I've mentioned, it only happens when @2x slices are being exported. 

So, for now I can remember to quit PathFinder when I'm using Affinity :)


It would be cool if you could replicate and fix this :)






Share this post

Link to post
Share on other sites

I've just installed the trial and tried exporting @2x as well as the other available options and it is fine. I've set the Path Finder Preferences to 'Quit Finder when Path Finder launches' (which it does) and it still seems to export. I'll leave it running for a few days and see what happens. 

Share this post

Link to post
Share on other sites


I've been using a Affinity a lot  today, I've deliberately tested working with PathFinder and without,

when PathFinder is not running I don't seem to have an issue.

when it is running the freeze occurs most times I export slices with @2x resolutions. 

I wonder what else could be interfering!  ...  


Share this post

Link to post
Share on other sites

Here's a screen shot of the ghost window that's left behind when Affinity freezes and has been force quit.


This white rectangle is where the Slice Export file system window was on screen. Basically I've just clicked the export button and it's frozen, you can't see the beachball cursor in the shot.


Here I'm attempting to export 5 small rectangles containing white images with transparent backgrounds from the main artboard which has several layers hidden from export.


The slices all have x1 and x2 options.



( I reduced the size because the original retina version was rejected by the forum software )  


Share this post

Link to post
Share on other sites

I had to uninstall it this morning (because for some reason, I wasn't able to resize the Open dialog after I made it too small). I've reinstalled it now and I'll just see what happens with general use. 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.