Jump to content
moonbase

SVG <symbol> element incorrectly handled

Recommended Posts

The <symbol> SVG element is being handled incorrectly. Below is the svg.

 

This imports to Affinity Designer as two mirrored rectangles in displaced locations. All other svg's with the <symbol> element are similarly garbled. I've included a screen shot and the .svg file.

 

This element should create a single rectangle in the Studio Symbols palette with an instance at the xlink coordinates, and named per the id="rectangle_symbol" which is not the same as the svg source file name.

 

Thanks!

 

<?xml version="1.0" encoding="iso-8859-1"?>
<!-- Generator: Adobe Illustrator 18.1.1, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
     viewBox="0 0 960 560" style="enable-background:new 0 0 960 560;" xml:space="preserve">
<symbol  id="rectangle_symbol" viewBox="-105.628 -67.808 211.256 135.615">
    <polygon style="fill:#FFFFFF;stroke:#000000;stroke-miterlimit:10;" points="105.128,-67.308 -105.128,-67.308 -105.128,67.308 
        105.128,67.308     "/>
</symbol>
<use xlink:href="#rectangle_symbol"  width="211.256" height="135.615" x="-105.628" y="-67.808" transform="matrix(1 0 0 -1 483.2564 233.0769)" style="overflow:visible;"/>
</svg>

rectangleSVGimport.tiff

rectangleSymbol.svg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×