Jump to content
Mark Ingram

Affinity Photo Customer Beta - 1.6.0.84

Recommended Posts

Click here to download the latest beta

 

Status: Customer Beta
Purpose: Stability
Requirements: A valid product key, issued when Windows Affinity Photo version 1.5 was purchased.

This is a beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it is considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that you may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

We hope you enjoy the latest build, and as always, if you've got any problems, please don't hesitate to post here and we'll get back to you as soon as we can. Thanks once again for your continued feedback.

If you have a general question about the software, please head over to the Questions Forum, or if you have any suggestions, please head over to the Feature Requests forum.

Fixes

  • Fixed PDF export rasterising embedded documents for PDF/X-1 if they don't need a transparency group
  • Fixed PDF export with Device Link colour profiles
  • Fixed crash when trying to create palette from TIFF
  • Fixed Curves Adjustment graph appearance in 32-bit mode
  • Fixed 'File Not Found' error when dragging files from 7zip
  • Fixed being unable to type in fill opacity 
  • Fixed being unable to mouse wheel scroll in the Typography panel
  • Fixed rendering documents at less than 100% zoom, when Windows Display Scale is set to 125% or less 
  • Fixed being unable to load multiple files at the same time
  • Fixed Library panel to scroll smoothly
  • Fixed brush random scatter not being random enough
  • Fixed Slice panel to synchronise with the selection
  • Fixed laggy Brush Editor dialog sliders

Share this post


Link to post
Share on other sites

Rock.gif


Affinity Designer 1.8.5 & beta 1.9.0.971   Affinity Photo 1.8.5 beta  1.9.0.971 Affinity Publisher 1.8.5 beta  1.9.0.967

Windows 10 Pro 64-bit 2004

CPU Intel Core i7 4770 @ 3.40GHz Haswell 22nm Technology

RAM 32.0 GB Dual-Channel DDR3 @ 798 MHz (11-11-11-28)

Motherboard Gigabyte Technology Co. Ltd. B85M-D3H (SOCKET 0)

Graphics Intel HD Graphics 4600 (Gigabyte)

yoda.png

Share this post


Link to post
Share on other sites

Hi Mark, while scrolling in the library with the mouse wheel remains the application.
Only Ctrl + Alt + Delete is possible. Always tried again. Is the same.
WIN7 64 16GB RAM
Greeting Dieter


Germany, Affinity Photo WIN 1.7 , LR6, WIN10

Share this post


Link to post
Share on other sites
On 02/10/2017 at 4:11 PM, affwin said:

Hi Mark, while scrolling in the library with the mouse wheel remains the application.
Only Ctrl + Alt + Delete is possible. Always tried again. Is the same.
WIN 10 64bit

 

+1 for me too.

Steve

Share this post


Link to post
Share on other sites

Hi, has any progress been made in 1.6 on assisting (permitting?) the astrophotography workflow whereby you;

create a stack of images / layers;

mask the foreground in image 1 leaving just the sky / stars visible

copy the mask to image 2,3,....

then ask Affinity to align selected layers. As the layers only have stars visible it should then do a good job of aligning them rather than being confused by the foreground. 

  

There are a number of forum posts on the topic (e.g.

), even some workarounds but the general answer seems to be "we're working on it". I just wondered if anything had made it into 1.6?

 

Thanks,

John 

Share this post


Link to post
Share on other sites

Using the latest beta I've encountered a few more problems but I cannot really tell if they are actually new and related to this particular version.

Healing brush: If used in a multi layered document the performance of this tool is so poor (meaning so slow) that it becomes literally unusable. Every brush stroke causes the program to become unresponsive for seconds and even after the brush stroke has been applied the program keeps lagging badly until I select another tool.

Shadows & Highlights Live Filter: It keeps resetting the shadow range to 50 % every time the corresponding file containing such live filter is opened. I consider this a major issue because this actually means that despite saving the document Affinity resets the changes made by this filter every time the document is opened.

HDR Merging: I tried to merge a 40 MP HDR panorama (5 exposures, each one consisting of 6 vertical shots stitched by PtGui). The first try ended with Affinity crashing while applying noise reduction. The second try (this time noise reduction was inactive) failed because after merging the exposures the performance of ghost removal was so poor, I had to wait minutes to simply take a look at the different sources in order to decide which one to use for removing a ghosted area.

By the way, my computer is fairly powerful (AMD FX-8350, Geforce 770 GTX, 32 GB Ram, OS and Affinity run on a Samsung SSD) and easily handles any image editing tasks including merging large HDR photos using tools like Photomatix.

Share this post


Link to post
Share on other sites

WHY IS THE LENS DATABASE STILL NOT UPDATED?

I added Sony RX100M5 support in MARCH.

This is October. It does not take 7 months to sync with upstream.

The performance is still bad, with big blocks. I'm waiting for this software to be ready so I can do work. I do not want to pay for Adobe subscription. But how many years is it going to take? It's been such a disappointment so far.

 

Share this post


Link to post
Share on other sites
4 hours ago, Jamon said:

WHY IS THE LENS DATABASE STILL NOT UPDATED?

I added Sony RX100M5 support in MARCH.

This is October. It does not take 7 months to sync with upstream.

The performance is still bad, with big blocks. I'm waiting for this software to be ready so I can do work. I do not want to pay for Adobe subscription. But how many years is it going to take? It's been such a disappointment so far.

 

 

We've just updated the lens database last week, so you'll see support for this coming in the next public beta (and in the 1.6 release officially). 

 

The big blocks you see are due to the asynchronous nature of our renderer. Rendering in tiles is much faster than trying to draw a whole screen at once (assuming you've got a decent multi-core machine). And the most important thing is, we don't cheat by rendering effects at the current zoom level, we render the effects using all the data.

Share this post


Link to post
Share on other sites

Hi,

for me, this Beta is quite nice, stable (no crashes). Overall I'm happy with this.

Issues i have spotted, but I was unable to reproduce:

1. Stuck renderer after few hours I was able to arrive at the point view was not re-drawn properly.

2. Stabilizer selection is different for paintbrush and inpaint brush tool.

3. When Working with selection brush tool, selection ants went haywire, had to zoom out to see what was selected (had something that looks like tv noise, memory corruption probably).

 


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Share this post


Link to post
Share on other sites
5 hours ago, Mark Ingram said:

The big blocks you see are due to the asynchronous nature of our renderer. Rendering in tiles is much faster than trying to draw a whole screen at once (assuming you've got a decent multi-core machine). And the most important thing is, we don't cheat by rendering effects at the current zoom level, we render the effects using all the data.

A tile-based rendering scheme being faster is pointless when the overall engine is so slow that you can see every tile being updated. I use a Xeon with Quadro M4000, and all other graphics software can perform smooth transients when adjusting basics like hue. Affinity cannot. The underlying reasons why don't change the fact that the user experience is a visual assault that makes working painful. It'd be like an audio engineer listening intently, and hearing blocky artifacts. The human senses prefer smooth gradients, not abrupt jagged squares with sharp corners flashing everywhere while focusing to make adjustments. A delay with a fading full canvas render would even be preferable to that.

https://forum.affinity.serif.com/applications/core/interface/file/attachment.php?id=26308

Share this post


Link to post
Share on other sites
On 10/7/2017 at 2:54 PM, Mark Ingram said:

we don't cheat by rendering effects at the current zoom level, we render the effects using all the data.

 

What would be the impact of this "cheat"?  Could here be an option for those with lower-end machines to toggle?

Share this post


Link to post
Share on other sites

.Hi thanks all for the awesome wok.

Last week I cancel my adobe creative suite subscription to go in deep with Afinity photo :).

I like to draw, paint and ink much of the time with my surface pro 3 and one weird behaivior I found using the surface pen is that I can't do pointillism or do smaill dots without applying a bit of pressure with the pen.

example

https://www.dropbox.com/s/rr100n6cmothvfr/brush dot.mov?dl=0

Maybe I missing an option or something. 

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.