Jump to content

Nik plug ins not working : says Trial has expired... please Buy or Exit

Recommended Posts

I cannot get Affinity 1.5.2 to accept the supposedly free Nik Software Bundle plugins from Google on my Mac (  Yosemite 10.10.5).  Some of the plug ins worked at first , but my favorite Color Efex 4 never did...the " global authorization" stonewall.  Now, NONE of them, work . I get a screen that says  my " Trial has expired". The choices are to Buy or Exit.  huh? ---these are free and I have a full Google account. I downloaded and installed the last version of the Niks from Google....Nik Collection Full version 1.2.11 .  I uninstalled , restarted the Mac, reinstalled the Niks into Affinity , but still get the balk " Trial has expired " yada yada.

Very frustrated. I certainly hope Serif gets the plug in issue resolved. I really Really REALLY need my Nik !   Don't make me use Photoshop CS5. The very same Nik plug ins all work great in Graphic Converter 10 .  All I had to do was copy the Nik plugins to Graphic Converter's plug ins folder , and voila!  they all work like a charm . Why can't it be that simple and effective with Affinity ?

What am I doing wrong here?

Share this post

Link to post
Share on other sites

UPDATE  from original poster :  I finally got ALL  the Nik software plugins to work in my Affinity Photo 1.5 on mac OSX Yosemite. All of them . Without the nagging window that said my Trial had expired.

What I did was first delete all the Affinity preferences in my Mac OSX system library ( one of those was a plist. for the Trial offer. )  Then I opened Affinity photo's own preferences and started over with  activating the Nik package. Deleted the Application Support Folders . I did NOT uninstall the Nik bundle apps as some suggested ... I also use Nik in Photoshop CS5 and GraphicConverter 10 ( where they work incredibly well! )  I  think the  success was due to the precise method of telling Affinity Photo to use the Mac's root system folder as the Application Support directory for AP+Nik .  You CANNOT just type in the name of that folder, or create a new directory . it has to be the User's own / root shystem directory . The   forward slash " / ".  You actually have to navigate to that folder using Mac Finder Menu--> Go--->  Cmd + Shift + G , and select  /  from there.  Then finish with the Allow Global . After an AP  restart , all the Niks were present.

I hope Serif can make future versions of Affinity Photo available from its own servers and not Apple's tyrannical App Store. Apple apparently does not allow Affinity to be downloaded if it isn't fully sandboxed  to disallow plugins.  Don't ask me why that is.

Affinity Photo with the addition of Nik is so much sweeter. Especially the DFine plugin. And Color Efex4.

Share this post

Link to post
Share on other sites

Zoli-  I do not recall how I navigated to the buried preferences, but it was likely done using a Spotlight search on my Mac  for anything " affinity" or " serif".  Or maybe something tagged as google  or googlesoftwareupdate.  The obvious crumbs to follow.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.