ShinKaiZen

View Tool sudden "jump" bug

8 posts in this topic

Hi,

 

I'm fairly new to Affinity products and I find it strange that no one raised this issue or I just couldn't find it.

 

Hand/View tool is one of designers' important tool to use in any design software. I attached a gif image for reference on what's happening. Basically i hold down SPACE key and click to move left and right. As you can see there's this sudden "jump" to a certain position rather than smooth flow like how Ai does. You can see the hand cursor is suddenly clipped to the left and right of my design when i started moving. Im not sure whats causing this.

 

I have also attached a gif on how it looks like in Ai, so that you can compare and see how it was supposed to work like.

 

P.S. Im using the Trial version.

bug.gif

illustrator.gif

Share this post


Link to post
Share on other sites

Im running macOS Sierra and its a fresh new installation. I haven't add any plugins yet.

 

additional info: 

Affinity Designer ver. 1.5.5 (Trial)

macOS Sierra v10.12.5

iMac 21.5 inch Late 2013

8GB 1600 RAM

I already started, the problem still persists.

Share this post


Link to post
Share on other sites

Hi ShinKaiZen

 

It's pretty smooth for me here, but the trial version is slightly older now. We have done some rendering improvements i our upcoming 1.6 release which will also have a trial made of it which may improve things for you

 

cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites
1 hour ago, Chris_K said:

Hi ShinKaiZen

 

It's pretty smooth for me here, but the trial version is slightly older now. We have done some rendering improvements i our upcoming 1.6 release which will also have a trial made of it which may improve things for you

 

cheers

 

Thanks, good to hear that! It was so annoying for this to happen and i already have doubts in the purchased version. Hopefully this thing wont happen in that one.

Share this post


Link to post
Share on other sites

Something similar (or same) happens for me.

 

When clicking and dragging ”too fast”, the canvas ”jumps”. When clicking and pause for a 1/4 second, it's ok. Booth Hand Tool and holding Space.

 

Switched between OpenGL (basic), OpenGL, Metal – no difference.

 

Designer 1.6, MacOS Sierra, iMac 5K 2017.

Share this post


Link to post
Share on other sites

Hi all,

 

I have figured out the culprit to this problem on my side. Do you have any Better Touch Tool or MagicPrefs enabled? Apparently, Adobe products doesnt get affected with this but Affinity does. I have to disable this while im working on Affinity softwares. Hope you guys can make it run smoothly with me turning it off.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now