vjsouza

BUG: Embedded vectors are rasterized at export to PDF

5 posts in this topic

Hello, Guys at SERIF.

 

I have some bad experiences with Affinity Designer.

 

When I embed a pure Affinity Designer vector file in a new project, Affinity rasterizes it in bitmap when exporting to PDF X1a

 

This does not happen when I copy and paste an art from one project to another.

 

Please review the 5 attached files and make the findings.

 

Please, guys, File / Place is fine, but I'd like it if there was File / Link also

card without embedded vectors file.afdesign

card without embedded vectors file.pdf

ASD Concret.afdesign

card with embedded vectors file.afdesign

card with embedded vectors file.pdf

Share this post


Link to post
Share on other sites

Hi vjsouza

 

I've tried exporting the card with embedded vectors file.afdesign to PDF for export in the latest 1.6 beta and it kept everything as vector when the resulting PDF was opened back in Designer so it looks like we might have already sorted this. You can try it out for yourself by downloading it form this thread

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Chris_K, I am using Beta 1.6.0.82, and it still rendering as BITMAP at export to PDF/X1a.

Please, try to open the "card with embedded vectors file.afdesign" and export it as PDF/X1a, and open on any PDF reader.
This is really a BUG of Affinity Designer.

Share this post


Link to post
Share on other sites
On 13/09/2017 at 0:22 PM, Chris_K said:

Hi vjsouza

 

I've tried exporting the card with embedded vectors file.afdesign to PDF for export in the latest 1.6 beta and it kept everything as vector when the resulting PDF was opened back in Designer so it looks like we might have already sorted this. You can try it out for yourself by downloading it form this thread

 

Cheers

You are wrong. The bug still happen. Try to export the file with embedded art to PDF/X1a and open it in any PDF reader and you will see only bitmaps.

Share this post


Link to post
Share on other sites

Ahh I see now, this may possible have something to to with how the X1a spec handles embedded documents but I have passed it on to the development team to look into and perhaps shed some more light on this

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now