Jump to content
pxin

Problems when opening svg and ai files in Affinity Designer

Recommended Posts

When I open an svg file created in Inkscape in Designer, some of the tools don't work.

 

For example: when I select the text elements in order to change them to a different font or size, they don't change.

 

The font is selected in the Character menu etc, but the fonts don't change in the file itself.

 

As the program exports svg files I figured there wasn't a compatibility issue with Inkscape files.

Is there a general compatibility issue between svg and Designer or is it to do with Inkscape?

 

And is there a solution?

 

I also can't open ai files created in Illustrator.

The file opens with no content except this text:

'saved without PDF Content. To Place or open this file in other applications, it should be re-saved from Adobe Illustrator with the "Create PDF Compatible File" option turned on. This option is in the Illustrator Native Format Options dialog box, which appears when saving an Adobe Illustrator file using the Save As command.'

 

Is there a solution to this too?


I love this program, but this kind of glitch makes updating previous work impossible now I have switched from Illustrator to Affinity Designer, which means it has to re-created from scratch.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Hi pxin,

Welcome to Affinity Forums :)

Can you attach a sample SVG file showing the text issues you are describing.

 

Regarding Ai, Affinity Designer/Photo is only able to access the PDF stream/data contained in the Ai file (the rest is proprietary). If the Ai file was saved from Illustrator without the option Create PDF Compatible File checked then there's no PDF stream on the file as there's nothing we can read/load from it (Affinity apps will display a blank document in that case and display the message you saw). There's nothing we can do about it.

Share this post


Link to post
Share on other sites

Hi MEB,

Thanks for your reply and welcome :)

Attaching an svg file that is doing what I describe.

Here's what happens when I open the svg file in Designer:

I select all 3 text objects with the Move tool

Then select the Text tool

Go to change the font/size via the toolbar or Character panel

The A changes but the B and C remain the same.

In case it's related, Designer is crashing every time I try and open an eps file.

Thanks for the info about the ai files thing, makes sense, good to know.

Thanks for your help.

testfile.svg

Share this post


Link to post
Share on other sites

Hi pxin,

You must select the text objects - not the groups they are contained within - to be able to change the font size. Check the screenshot below where i have selected one of them.

If you click once on one of them on the canvas you are simply selecting the group, not the text object. If you double click instead, Affinity will enter inside the group and select the text object for you. Then you can change the font size as you want.

 

text_object.png

 

Regarding the EPS, can you please attach it here so we can take a look? We can provide an upload link if you want/need to keep it private.

Share this post


Link to post
Share on other sites

Thanks. It'll be a bit slow and fiddly, but at least it can be done!

Are there plans to make this any quicker, or is just an issue with svg files in designer that has to be lived with?

Thanks again.

Share this post


Link to post
Share on other sites

You should be able to just select everything and ungroup. You would then be able to select the text directly. 


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites
5 hours ago, MEB said:

 

Regarding the EPS, can you please attach it here so we can take a look? We can provide an upload link if you want/need to keep it private.

Just noticed this bit of your earlier reply.

I've saved the testfile.svg as an eps (in Inkscape) and tried to open it in Designer and it opened fine.

Then tried to open an eps that crashed it earlier, also created in Inkscape, and the program crashed again.

Both files were created and saved in the same way. Attaching a screenshot of the eps save settings from Inkscape.

An upload link would be great, thanks again.

Am on an iMac, running 10.10.5 (Yosemite).

eps save settings.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×