Jump to content
LudoE

Red pixels on RAW files

Recommended Posts

Hello .

When i open some pictures in RAW ( .CR2 from Canon eos 70D ) in Affinity Photo, i have some red pixels on picture .

Nothing in Apple photo, nothing in Photoshop Elements ...

Same problem on my iMac and my MacBook Pro ... ( macOS 10.12.6 on each )

Any idea to solve the problem  ?

Thanks .

Capture d’écran Afinity.jpg

Capture d’écran 2Photoshop.jpg

Share this post


Link to post
Share on other sites

Hi LudoE

 

I've tried an image from the 70D here and I'm not getting any red pixels. Are you able to provide a link to the image you are getting this with. Is it on all images form your camera or just the one in your screenshots?

 

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

A start of solution, waiting for a real fix ...

The appearance of red pixel depends on the development engine used. With Apple Core Image Raw, no red pixels of visible.

If Serif Labs is used, I actually see red pixels.


The development engine "Serif Labs" does not seem to interpret some pixels as being "erroneous" and does not correct them ...

Capture d’écran 2017-09-05 à 17.30.54.jpg

Share this post


Link to post
Share on other sites

I too have had a problem with "erroneous" pixels. I use a Lumix GH4 with MFT lenses. When I shoot night images, I get scattered red pixels with the assistant set to "Serif Labs" and off-colored pixels when I set it to "Apple". The same image in Lightroom does not show these pixels. I was curious if this is something with my camera or if it is a computer/software issue. Attached are screenshots and the raw file (not that great, mirror-less does not like low light). Any help would be appreciated, I would love to stop using lightroom and make AP my primary (Maybe not for this imagery).

With_Lightroom.png

With_Serif_Lab .png

With Apple.png

With Apple C:U.png

_1160624.RW2

Share this post


Link to post
Share on other sites

So the official word from the development team is this is currently working as intended. The pixels are actually part of the initial raw file and we do not do fixes to hot pixels in our RAW develop currently. Not to say it is not something that we won't do in the future but that's the current state of play as I have been told

 

Thanks


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.