Andy Somerfield

Affinity Photo Customer Beta - 1.6.5 (Beta 5)

31 posts in this topic

Status: Beta Release

Purpose: New features, fixes

Requirements: Purchased Affinity Photo

Mac App Store: Not Submitted

Download: Here

 

This is the fifth beta of a substantial change to our codebase and as much as we have tried to ensure the quality of the code, it should be considered to be not suitable for production use. This means that you should not attempt to use it for commercial purposes or for any other activity that may be adversely affected by the application failing. In addition it is definitely worth noting that files created in Affinity 1.6 may not open in 1.5 so always make a copy of your important documents before opening them in 1.6 to ensure you do not accidentally overwrite them and are unable to open them in your 1.5 version.

 

To use this beta, simply download the file from the link given above and double-click on the file to open the installer. Follow the instructions to install the beta version. The beta sits alongside the Mac App Store version and will not interfere with it.

 

Thanks,

 

Affinity Photo Team :ph34r:

 

Changes this release

 

  • Build with macOS High Sierra SDK, Xcode 9.
  • Fixed panorama stitching when using Core Image RAW.
  • Further Light UI improvements.
  • Fixed problems with full colour brushes.
  • PDF import improvements.
  • Text Styles improvements.
  • Documents which have no changes don’t require saving.
  • Fixed floating windows in full screen mode.
  • The visibility of the left / right studio is now saved per persona.
  • Fixed some DNG loading regressions.
  • Fixed drag behaviour in the Curves tool.
  • Develop now has button to rotate the image.
  • Fix issue where documents could get stuck when loading.
  • Node tool now allows rotation of nodes.
  • Fixed many localisation truncations.
  • Fixed Shadows & Highlights filter artefacts.
  • Live Halftone filter UI improvements.
  • Selection brush was not remembering size between uses.
  • HSL adjustment now contributes per-channel adjustments to exported LUT.
  • Mitigated Live Perspective crashes.
  • Liquify now behaves correctly on rotated images.
  • Fixed occasional layer corruption under extreme load.
  • Stopped Liquify slightly blurring images (with Metal Compute enabled).
  • Numerous adjustment now do not pollute the K channel in CMYK (with Metal Compute enabled).
  • Fixed halftone filter in CMYK (with Metal Compute enabled).
  • Localisation improvements.
  • Numerous other small fixes and improvements.
  • Help improvements.

 

Changes since last App Store release

 

  • New “Live Halftone” filter.
  • Added noise reduction slider to “New HDR Merge” panel.
  • Added menu to layers panel with an “Auto-scroll” item (to quickly enable / disable).
  • Importing ASE files now supports spot colours.
  • Increased performance of Metal compute mode.
  • Increased the maximum size of the liquify brush tools.
  • Fixed some grid drag / drop issues.
  • Improved Metal compute acceleration of HDR merge.
  • Small SVG import improvements.
  • Further TIFF import improvements / fixes.
  • Better quality equirectangular projection previews if Metal compute enabled.
  • Fixed Diffuse Glow opacity slider.
  • “Always show brush crosshair” is more completely obeyed.
  • Fixed vignette artefacts.
  • Colour correction fixes for Metal view on AMD cards.
  • Fixed issues with the quick mask toolbar dropdown.
  • Fixed crashing on export / save.
  • Numerous other small fixes.
  • Improved localisation.

 

  • Selection refinement performance improvements.
  • Show progress when committing a refined selection.
  • Handle layers with 0 width / height more correctly.
  • Improved PDF / vector export.
  • Remember Align To settings between sessions.
  • Opening and saving document will now support macOS filesystem tags correctly.
  • Export panel also support tags correctly.
  • Improved RAW support - more cameras etc.
  • Further efforts to reduce the size of the application binary.
  • Improved TIFF loading correctness.
  • Fixed some “Effects” brushes looking wrong on masks / adjustments.
  • Prevent Tone Map being macro recorded (proper support for it will be reintroduced later).
  • The “Undo” brush should do nothing on masks / adjustments.
  • Fixed crash when using File -> New Batch Job in light UI mode.
  • Fixed crash when loading a document with an OCIO space which is no longer available.
  • Support malformed 8bit grayscale TIFFs (which were loading as sRGB).
  • Fixed some scroll bar panel issues in light UI.
  • Fixed Ctrl-reset startup crash in light UI.
  • Fixed some flickering issues with sliders.
  • Removed “Set as Default” for Pantone palettes.
  • Improved drag & drop in the Library page.
  • Numerous other small fixes.
  • Localisation improvements (especially Russian).

 

  • Metal compute acceleration.
  • Significant improvements to light UI.
  • Metal display acceleration.
  • Custom brush wet edges.
  • Outlier stacking mode.
  • Fixed Export LUT Red/Blue swapping bug.
  • Fixed inability to hold shift and click in brush tools to create a straight line.
  • Improved Photoshop Plugin support.
  • Fixed bad / crashing macros cause by recording a 32bit preview mode change.
  • Fixed B&C macro arguments issues.
  • Fixed info panel samplers not being drawn.
  • Fixed artefacts with Live Filters.
  • Improved Live Filters performance
  • Pasting pixel data should always past pixel-aligned.
  • Fixed inability to load Procreate PSD files.
  • Localisation improvements.
  • Numerous bug fixes and stability improvements

 

  • First and foremost, the 1.6 version is mainly about: Light UI! (go to Preferences->User Interface)
  • Improved view pan/zoom performance and new pixel-differencing pixel shader
  • Improved performance with large documents
  • New font chooser dropdown with recents, used fonts and favourites
  • New Glyph browser
  • Stroke stabiliser for all pencil and brush tools
  • Align to key items (first/last selected)
  • Text frame vertical alignment options
  • Fit frame to text (double-click on bottom centre handle).
  • Transform panel uses the rotation centre
  • Scale/shear can now be performed about rotation centre
  • Double-click now resets shape handles and rotate/shear handles
  • Many PDF export improvements including vector export of multi-stop gradients
  • Numerous bug fixes and stability improvements

Share this post


Link to post
Share on other sites
3 hours ago, Andy Somerfield said:

Mitigated Live Perspective crashes.

YAY! Awesome! :)

I suppose mitigated means they still happen, just with a lot less frequency?

Thanks!

Share this post


Link to post
Share on other sites
4 hours ago, LCamachoDesign said:

YAY! Awesome! :)

I suppose mitigated means they still happen, just with a lot less frequency?

Thanks!

did not crash as it used to

 

but has some new visual fx 

 

fx.thumb.png.32da2c082731bf57f9d181758bc40a03.png

 

and still some inconsistency

down.png.38da3d156f3b124aa48fd5656b76cd21.png598583c11dfef_notdown.png.76da5b6c5da7e07fe03e34362ca9bdbc.png

 

cheers

A_B_C likes this

Share this post


Link to post
Share on other sites

Refine mask is destructive on the original image.  Normally when removing a mask from an image, the image should appear as it was before.  However the issue is that Refine Mask affects the underlying image rather than just refining the mask.  Please see original image and same image with the mask removed. 

Screen Shot 2017-08-30 at 10.40.15 AM.png

Screen Shot 2017-08-30 at 10.40.04 AM.png

Share this post


Link to post
Share on other sites

Actually let me correct myself slightly - the issue is that I was selecting "mask with new layer" - a feature I thought would make a copy of the original layer and mask that, and deselect the original layer while selecting the new group mask.  Wow, wonderful.  However that is destructive on the original layers as shown above.  But if I go back to mask, not the new menu item "mask with new layers," then there is no issue and all works perfectly. 

Share this post


Link to post
Share on other sites

Metal compute under preferences - the new addition - is that for High Sierra (beta) Metal 2 users? It seems to work more slowly for me on Sierra (Radeon Pro 460) than with that feature checked off.  Some lag in pan/zoom.  But with it off it's rather speedy.

Share this post


Link to post
Share on other sites

@Andy Somerfield are linked layers deprecated for V1.x?

https://forum.affinity.serif.com/index.php?/topic/45521-v1xyz-no-linked-layers/

 

They are no longer on the roadmap but were said to appear in 1.5

"Layer linking will happen in 1.5 - at the moment it is currently not exposed in this beta. Look out for it soon though"

 

thanks 

Share this post


Link to post
Share on other sites

I have MacBook Pro 15" Retina mid 2012 OS X 10.9.5. I can´t see tool bar and when I try to go to Affinity´s preferences there there is no preferences window.

Also I can´t customize my tool bar. Any suggestions?

 

I trashed all my Affinity´s preferences by the way...

 

One more thing, I can´t create new documents, but can open old.

Share this post


Link to post
Share on other sites
3 hours ago, machawk said:

I have MacBook Pro 15" Retina mid 2012 OS X 10.9.5. I can´t see tool bar and when I try to go to Affinity´s preferences there there is no preferences window.

Also I can´t customize my tool bar. Any suggestions?

 

I trashed all my Affinity´s preferences by the way...

 

One more thing, I can´t create new documents, but can open old.

 

It sounds like the stored application data is corrupt. Have you tried starting the application up with Control key held down?

Share this post


Link to post
Share on other sites

Could someone please check this:

i selected 5 JPEG’s and drop them in the Dock over AP, 1.6 beta 5. Then the message is shown on top of AP, loading. And this does take a very long time, very long time, longer than opening all 5 individual. The files were about 70k. strange...

Share this post


Link to post
Share on other sites
1 hour ago, Andrew Tang said:

 

It sounds like the stored application data is corrupt. Have you tried starting the application up with Control key held down?

Yes I tried but no help.

Share this post


Link to post
Share on other sites

When l use other colorsystem then srgb eg adobergb, the using of nik filter gives extreme oversaturated colors after return in AP. This happens  with all version of affinity photo.

 

Share this post


Link to post
Share on other sites

Wow, all kinds of problems with this build, completely unusable. No tools, no Studio windows, no preferences access, splash screen never closes. Strange behaviors in AD beta too!

Just nothing works right. Mac OS Mavericks 10.9.5, Betas at least worked up to this point. - Timber

Screen Shot 2017-09-01 at 8.28.18 PM.png

Share this post


Link to post
Share on other sites

I experienced the same problem as machawk and also had no Studio windows after installing beta 5. I had been running the beta versions on an old macBook running MacOS Lion. I installed the beta 5 on a MBP with MacOS Sierra and all is fine with the toolbar and the Studio windows back where they should be. Perhaps this beta version is not compatible with machawk's 10.9.5.

 

I was disappointed to find that he problem with the selection tool subtract mode not functioning inside an existing selection, that I reported separately, is still not fixed. Is this on the to do list?

Share this post


Link to post
Share on other sites

I noticed a problem similar to the one in a previous Designer beta. When customizing the workspace, dragging a tab set causes the program to stop responding.

Share this post


Link to post
Share on other sites

I noticed something when using the Impainting Brush Tool. When i take the steps below, the tool doesn't do its work. Taking the same steps in the AppStore version does give the desired result (i.e. arm erased).

 

  • Add a pixel layer on top of the layer you'd like to retouch
  • Select the Impainting Brush Tool, take a Basic brush and select Current Layer & Below in the Options bar
  • Paint on the area you'd like to retouch.

I've added images of the result. One with all layers selected, one with just the pixel layer selected.

 

Anyone in the forum who can re-create this?

C-60.png

C-61.png

Share this post


Link to post
Share on other sites

Inpainting: As RNKLN has posted I am also seeing that there seems to be an issue with the Inpainting brush in beta 6, using on current layer works but using current layer & below doesn’t but appears instead to clone the area to the blank layer.

Share this post


Link to post
Share on other sites

The posts from RNKLN, Chriscam and TommyL don't really relate to my original post regarding the selection tool Delete mode but they do point to a serious issue. The Inpainting tool in Current Layer & Below always added an image to a blank layer and that could be handy if you inadvertently painted over an area by mistake as you could go to the blank layer and erase the mistake there. But it appears that beta 5 is creating the blank layer image but not actually achieving the inpainting.

Share this post


Link to post
Share on other sites

With the issue I reported, it looks like it is only caused by customizing the original workspace. Once I found the workspace I liked, I closed the program and reopened it. Now moving tab sets does not trigger a crash.

Share this post


Link to post
Share on other sites

I don't know if this has been addressed or not - but when using a soft edge brush on a mask layer the brush performs in certain areas of the mask as a hard edged mask.  This doesn't happen if I use a brush directly on a layer but only on a mask.  I noticed this when using a mask on a filter layer.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now