Jump to content
CaptNeo

Parts of UI Ignore Pen and Touch Input on Surface 4 Pro

Recommended Posts

4 hours ago, CaptNeo said:

In the mean time I managed to spend an evening with the Surface and Expression Design.During two hours of constant dooling and brush-switching I didn't experience any problems with the drop-down menus there.

 

Thanks for the feedback CaptNeo, that's really interesting. Is there any chance you could record a video of the problem for us? @sarahgould has already done one, but the more things we can examine, the better.

Share this post


Link to post
Share on other sites

Hello everyone, I've done some testing on this and may have reproduced it (or something very similar). I would be grateful if anyone with a Surface Pro could try this too. (It only happens on my Surface Pro).

 

Here's the steps:

 

1) Create 3 shapes and select them all

2) Bring up the alignment popup

3) Horizontal spacing mode

4) Untick 'auto'

5) Click arrow to show the slider

6) Slide back and forth for new values

7) Click the mouse directly on some empty UI space (e.g. the context bar or main toolbar) to dismiss the alignment popup.

8) Notice the menus have now stopped working altogether.

 

Cheers

Chris

 

Share this post


Link to post
Share on other sites

 

21 hours ago, Chris J said:

Hello everyone, I've done some testing on this and may have reproduced it (or something very similar).

 

4 hours ago, Chris B said:

Hey @Chris J - By Jove I think you've got it! Reproduced it here, first time. 

Awesome :-)

Share this post


Link to post
Share on other sites

Hello everyone, could we encourage you to try out the latest customer beta and see whether this issue is resolved for you.

 

Designer - https://forum.affinity.serif.com/index.php?/topic/55132-affinity-designer-customer-beta-163100/

Photo - https://forum.affinity.serif.com/index.php?/topic/55131-affinity-photo-customer-beta-163100/

 

Thanks!

 

Share this post


Link to post
Share on other sites
29 minutes ago, Mark Ingram said:

Hello everyone, could we encourage you to try out the latest customer beta and see whether this issue is resolved for you.

 

Designer - https://forum.affinity.serif.com/index.php?/topic/55132-affinity-designer-customer-beta-163100/

Photo - https://forum.affinity.serif.com/index.php?/topic/55131-affinity-photo-customer-beta-163100/

 

Thanks!

 

I can no longer reproduce it using Chris J's recipe using build 100 :1_grinning:

Share this post


Link to post
Share on other sites
1 hour ago, Mark Ingram said:

Hello everyone, could we encourage you to try out the latest customer beta and see whether this issue is resolved for you.

 

Designer - https://forum.affinity.serif.com/index.php?/topic/55132-affinity-designer-customer-beta-163100/

Photo - https://forum.affinity.serif.com/index.php?/topic/55131-affinity-photo-customer-beta-163100/

 

Thanks!

 

Awesome, and many thanks for hunting the bugger down! Will start playing with it immediately.

Share this post


Link to post
Share on other sites
30 minutes ago, CaptNeo said:

Awesome, and many thanks for hunting the bugger down! Will start playing with it immediately.

 

I'm going to point out that this was a bug caused by WPF / .NET ;-). This is why we require the update to 4.7.1 in the latest beta.

Share this post


Link to post
Share on other sites
4 hours ago, Mark Ingram said:

 

I'm going to point out that this was a bug caused by WPF / .NET ;-). This is why we require the update to 4.7.1 in the latest beta.

That's your happy Valentine's gift from MS!

Kidding aside, you had an impressive turnaround time for catching and fixing the issue after Chris J found the steps to reproduce. Chapeau!

Doodled on the Surface for an hour or so, and everything still works smoothly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.