Jump to content
Brammy

Problems with Topaz Lab Adjust and OS X Affinity

Recommended Posts

Hi all,

I am having a problem with Topaz Labs and Affinity Photo on my 2016 15" MBP, running latest production build of Sierra (not the betas). I installed Toaz Adjust 2.0. I added the folder to my plug-ins preferences search folder. That made the plug in show up, but whenever I try and use it I get the following error: 

IPC Memory in use or 

 Image size is too big for the system.

 

The actual image is very small: only 9.8mb. Searching on Topaz seemed to bring me to mostly Windows users.

 

The plug-in works fine in Creative Cloud Photoshop as well/

Share this post


Link to post
Share on other sites

Hi Brammy,

Welcome to Affinity Forums :)

We are aware of a few issues with various topaz plugins with the Mac version. The latest Beta (1.6) introduced a few improvements here and i believe it will fix a couple of these issues (if not all). I haven't tried/tested them yet (with the latest Beta) so the info provided on the link @RNKLN pointed out may be outdated/incorrect. I will test all the Topaz plugins with it soon. Meanwhile if you want to give the Beta a try and check for yourself if it helps or not you can download it from here (v1.6.4 Beta 4). Alternatively wait a little more for the next retail update. I hope to have that plugin list updated before 1.6 release.

Share this post


Link to post
Share on other sites

No joy: exact same IPC error.

 

I've tried a reinstall after following Topaz's instructions for a clean install, but I wonder if something else is weird -- although as stated, it works fine on CC.

 

I've seen some people having success with the Topaz filters, which is making me wonder if I am doing something wrong.

Share this post


Link to post
Share on other sites

So, we can close this out.

 

For people after me who may have this problem, here are the steps:

  1. Add the PS Plug In folder to to the Plug-in search in Affinity. Note: not entirely sure how this works if you don’t have PS installed at all
  2. Make sure “Use Unknown Plug-ins” is checked
  3. Click the “authorize global” button. This is the step I did not know I needed to do. After this, it worked fine.

Share this post


Link to post
Share on other sites
45 minutes ago, Brammy said:

Add the PS Plug In folder to to the Plug-in search in Affinity. Note: not entirely sure how this works if you don’t have PS installed at all

You don't need Photoshop so long as you tell Affinity where the plugin can be found. On my Windows 10 machine, I point Affinity to: D:\Topaz Labs\Topaz Adjust 5\Pluginsx64

 


Windows 10, Affinity Photo 1.8,3 Designer 1.8.3 and Publisher 1.8.3 (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

That directory was where I installed Topaz Adjust. Use Finder to find the equivalent location on your Mac


Windows 10, Affinity Photo 1.8,3 Designer 1.8.3 and Publisher 1.8.3 (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.